Форум программистов, компьютерный форум, киберфорум
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.55/11: Рейтинг темы: голосов - 11, средняя оценка - 4.55
Заблокирован
1

Как в столбце Excel найти совпадение по части текста и вывести ячейки где нет совпадений?

24.05.2019, 08:29. Просмотров 2191. Ответов 4
Метки нет (Все метки)


Нужно:
- сравнить каждое значение из второго столбца с первым столбцом (т.е. сравнить два столбца между собой).
Вывести найденные значения.
Вот пример: https://yadi.sk/i/ZFmqUULdPUmevA
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
24.05.2019, 08:29
Ответы с готовыми решениями:

Форматирование части текста ячейки через Excel.Application
Здравствуйте коллеги. Заполняю Excel из Access с помощью похожего кода: В ячейку A:1 вставляется...

Excel создание собственной функции для выделения части текста в ячейки
Доброго дня всем. Прошу помощи в разрешении следующей задачи: Формирую много отчетов и для...

Сравнить два бинарных файла и вывести в label количество не совпадений, или что нет не совпадений
Добрый день ! Прошу помощи в реализации задачи. В программе нужно сравнить два файла (разной...

Найти номер последней заполненной ячейки в столбце, Excel
Добрый день! Импортирую данные из таблицы Excel,таблица состоит из двух столбцов. Первый очень...

4
2631 / 1688 / 694
Регистрация: 04.09.2015
Сообщений: 3,367
24.05.2019, 09:11 2
Вторая формула массива
Код
=ПРОСМОТР(;-ПОИСК(B$3:B$17;A3);B$3:B$17)
=ЕСЛИ(И(ЕОШ(ПОИСК(B3;A$3:A$17)));B3;"")
Первую формулу дополните функцией ЕСЛИОШИБКА()
0
Вложения
Тип файла: xlsx столбце Excel найти совпадение 2_01.xlsx (9.1 Кб, 5 просмотров)
Заблокирован
24.05.2019, 10:58  [ТС] 3
Цитата Сообщение от AlexM Посмотреть сообщение
Вторая формула массива
сорри, поправил пример.
Нужен поиск по совпадению с частью текста.
0
2631 / 1688 / 694
Регистрация: 04.09.2015
Сообщений: 3,367
24.05.2019, 11:02 4
Две формулы массива
Код
=ЕСЛИ(ИЛИ(ЕЧИСЛО(ПОИСК(B3;A$3:A$17)));B3;"")
=ЕСЛИ(И(ЕОШ(ПОИСК(B3;A$3:A$17)));B3;"")
0
Вложения
Тип файла: xlsx столбце Excel найти совпадение 2_02.xlsx (9.1 Кб, 19 просмотров)
Заблокирован
24.05.2019, 11:25  [ТС] 5
Цитата Сообщение от AlexM Посмотреть сообщение
Две формулы массива
Спасибо! Работает!
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
24.05.2019, 11:25

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь или здесь.

Как выбрать ширину и высоту ячейки Excel? Перенос текста внутри ячейки
Как выбрать ширину и высоту ячейки C# Excel*и перенос текста внутри ячейки или внутри диапазона,...

Найти ячейки где нет формулы
"Найти ячейки где нет формулы, выделить их цветами, отличающимися в зависимости от форматов (дата,...

Как в excel в столбце выделить определённые ячейки с шагом если их Овер 3000+
Как в excel в столбце выделить определённые ячейки с шагом если их Овер 3000+

Удаление части текста ячейки, который совпадает с текстом соседней ячейки
Добрый день. Заранее извиняюсь, за возможный повтор темы. Ситуация следующая: Есть таблица на...

Как найти количество совпадений в таблице (массиве) excel по строкам?
Здравствуйте! Как найти совпадения по строкам в таблице (массиве) в Excel и вывести их в отдельную...

Как в Excel создать дополнительные фильтры или выпадающие списки в столбце и чтобы данные определенной ячейки
При создании базы данных по производителям металлопроката, я столкнулся с проблемой создания...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.