Форум программистов, компьютерный форум, киберфорум
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.67/9: Рейтинг темы: голосов - 9, средняя оценка - 4.67
Boroda2003
0 / 0 / 0
Регистрация: 18.01.2016
Сообщений: 5
1

Выдернуть цветные строки на другой лист. Задача для ГУРУ Excel

26.03.2020, 00:06. Просмотров 1690. Ответов 10
Метки нет (Все метки)

Друзья, приветствую вас!
У меня уже опускаются руки. Искал на форуме подобную проблему, но подобного не нашел. Шесть часов не могу сделать таблицу. Нуждаюсь в помощи Гуру экселя.

Итак задача:
Есть файл эксель (прикрепил). Нужно в нем сделать автоматизацию.
При заполнении N-ого количества полей на листе "Смета" я помечаю строки (зеленой заливкой), которые автоматически должны перенестись на лист "КС-3".
Зеленых строк может быть произвольное количество, зависит от текущей сметы. Затем должна быть строка с перечислением материалов (оранжевая строка, лист "КС-3")
Материалы перенестись должны из листа "СМЕТА", это все остальные строки (не выделенные зеленым)

Прикрепил дополнительно картинку того как я себе это представляю, мне кажется так нагляднее:

Кликните здесь для просмотра всего текста
0
Миниатюры
Выдернуть цветные строки на другой лист. Задача для ГУРУ Excel  
Вложения
Тип файла: xls SMETA,KS-2,KS-3.xls (72.0 Кб, 3 просмотров)
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
26.03.2020, 00:06
Ответы с готовыми решениями:

Комплексная задача по excel vba для настоящих гуру своего дела
ну очень не просто... Смеющийся Вобщем так. Из программы выгружается excel - файл со следующей...

Экономное копирование из одного листа в другой (добавление готовых накладных на лист для печати в excel)
Здравствуйте, подскажите, пожалуйста макрос который будет компактно копировать подготовленные...

Подскажите формулу для переноса строки на другой лист по условию
Доброго времени суток, возможно не раз обсуждалось подобное, но я не очень разобралась, поэтому...

Задача по Excel: Подготовить лист для определения названия планеты Солнечной системы по ее номеру
Подготовить лист для определения названия планеты Солнечной системы по ее номеру. Нумерацию начать...

10
Narimanych
874 / 622 / 307
Регистрация: 23.03.2015
Сообщений: 2,122
26.03.2020, 00:52 2
Boroda2003,
привет. Вы хотите скриптом?
0
Boroda2003
0 / 0 / 0
Регистрация: 18.01.2016
Сообщений: 5
26.03.2020, 00:53  [ТС] 3
Цитата Сообщение от Narimanych Посмотреть сообщение
Boroda2003,
привет. Вы хотите скриптом?
Любым способом, лишь бы работало.
0
Narimanych
874 / 622 / 307
Регистрация: 23.03.2015
Сообщений: 2,122
26.03.2020, 01:02 4
Boroda2003,
Сделать можно, покажите в вашем файле каким столбцам листа "Смета" соответствуют столбцы листа КС-3
0
Boroda2003
0 / 0 / 0
Регистрация: 18.01.2016
Сообщений: 5
26.03.2020, 01:13  [ТС] 5
Держите:
0
Вложения
Тип файла: xls SMETA,KS-2,KS-3 — вручную.xls (75.0 Кб, 0 просмотров)
Boroda2003
0 / 0 / 0
Регистрация: 18.01.2016
Сообщений: 5
26.03.2020, 01:15  [ТС] 6
Цитата Сообщение от Narimanych Посмотреть сообщение
Boroda2003,
Сделать можно, покажите в вашем файле каким столбцам листа "Смета" соответствуют столбцы листа КС-3
Держите:
0
Вложения
Тип файла: xls SMETA,KS-2,KS-3 — вручную.xls (75.0 Кб, 4 просмотров)
AlexM
2255 / 1606 / 658
Регистрация: 04.09.2015
Сообщений: 3,190
26.03.2020, 11:32 7
Лучший ответ Сообщение было отмечено Boroda2003 как решение

Решение

На листе "Смета" доп. столбец М, в котором любым знаком отмечаете строку для подкраски. Подкраска сделана УФ
На лист"КС-3" доп. столбец J для расчета индекса строки с нужными данными. По этому столбцу работает УФ для подкраски строк.
1
Вложения
Тип файла: xls SMETA,KS-2,KS-3_01.xls (83.5 Кб, 2 просмотров)
AlexM
2255 / 1606 / 658
Регистрация: 04.09.2015
Сообщений: 3,190
26.03.2020, 11:50 8
Поправил формулы, чтобы индекс был без сотни
1
Вложения
Тип файла: xls SMETA,KS-2,KS-3_02.xls (83.5 Кб, 1 просмотров)
Boroda2003
0 / 0 / 0
Регистрация: 18.01.2016
Сообщений: 5
26.03.2020, 12:39  [ТС] 9
AlexM, Большое Вам человеческое спасибо. Сразу видно, что вы профи своего дела.
Единственное, что не могу пока разобраться как можно добавлять доп. поля (можно ли сделать при добавлении на лист "Смета" автодобавление полей на лист КС-3? ).
Для теста вручную добавил на листах "Смета" и "КС-3", по 5 полей. На листе "Смета" все отлично, зеленым подкрашивается, а вот на листе "КС-3" возникают ошибки.
Скриншот прикрепляю и файл. Посмотрите, пожалуйста, в чем моя ошибка при добавлении доп. полей?

UPD! Добавил файлы:
0
Миниатюры
Выдернуть цветные строки на другой лист. Задача для ГУРУ Excel  
Вложения
Тип файла: xls SMETA,KS-2,KS-3_02 тест добавил 5 новых строк в смету.xls (84.0 Кб, 1 просмотров)
AlexM
2255 / 1606 / 658
Регистрация: 04.09.2015
Сообщений: 3,190
26.03.2020, 12:48 10
В формулах столбца С нужно сделать диапазон с запасом
Формула для С25
Код
=ЕСЛИ(J25="";"в том числе материалы:";ИНДЕКС(Смета!$B$1:$L$99;J25;C$24-1))
Это еще не все. Подумаю.
1
AlexM
2255 / 1606 / 658
Регистрация: 04.09.2015
Сообщений: 3,190
26.03.2020, 13:22 11
Лучший ответ Сообщение было отмечено Boroda2003 как решение

Решение

Поправил формулу в столбце J
Код
=ЕСЛИ(СЧЁТЕСЛИ(Смета!$M$14:$M$99;"<>")+1=СТРОКА(A1);"";ОСТАТ(НАИМЕНЬШИЙ(100*(Смета!$M$14:$M$99="")+СТРОКА($A$14:$A$99);A25-(СЧЁТЕСЛИ(J$24:J24;"")=2));100))
1
Вложения
Тип файла: xls SMETA,KS-2,KS-3_03.xls (87.0 Кб, 1 просмотров)
26.03.2020, 13:22
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
26.03.2020, 13:22

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Перенос данных по выборке в Excel на другой лист
Сразу прошу прощения если не в той теме пишу! Добрый день уважаемые знатоки excel. Прошу помощи...

ActiveQt + Excel. Перенос Chart на другой лист
Доброго времени суток. Пишу программу для переноса данных из текстового файла в Excel. Возникла...

Excel копирование определенных ячеек и строк на другой лист
Здравствуйте. Имеется лист с которого нужно при нажатии кнопки скопировать определенные данные на...

Подсчет, фильтрация и перенос данных на другой лист Excel
Доброго времени суток! Мне была поставлена следующая задача Есть 2 книги excel Одна как...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
11
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.