Форум программистов, компьютерный форум, киберфорум
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.80/5: Рейтинг темы: голосов - 5, средняя оценка - 4.80
0 / 0 / 0
Регистрация: 01.06.2021
Сообщений: 5
1

Суммирование двух столбиков без дублирования по ячейкам

01.06.2021, 10:35. Показов 977. Ответов 2

Здравствуйте! Разрабатываю функциональную таблицу, чтобы в дальнейшем быстро формировать по ней отчеты руководству.
Столкнулся с проблемой)) Нужно засуммировать два столбика с ценами в ячейку на другой странице файла, которые были занесены в эти столбики на второй неделе, но при этом если в первом столбике есть число (не ноль), второй суммироваться не будет и наоборот, если в первом столбике нет суммы (стоит ноль) то будет суммироваться сумма из второго столбика.

Пытался все это делать с условиями функции "СУММЕСЛИМН" но пока не получилось того, что хочу увидеть

Во вложениях файл с примером таблицы

Рассчитываю на вас!
0
Вложения
Тип файла: xlsx Сложение без дублирования.xlsx (10.9 Кб, 3 просмотров)
Лучшие ответы (1)
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
01.06.2021, 10:35
Ответы с готовыми решениями:

Строка: создать из двух строк третью строку, содержащую общие символы первой и второй строки без их дублирования.
создать из двух строк третью строку, содержащую общие символы первой и второй строки без их...

Сделать так, чтобы фильтрация была двух столбиков с двух разных edit и не одновременно
Есть фильтрация, которая фильтрует определенный столбик в таблице, но только один. Нужно сделать...

Сложение столбиков двух массивов чисел
Например есть два массива int a={2,8,3,9,4,7,5,8,6,7,3,8,2}; int b={4,7,3,8,5,7,3,8}; Как мне...

Отображение картинок без дублирования
Подскажите пожалуйста как сделать так чтобы картинки не дублировались...

2
3437 / 2102 / 697
Регистрация: 02.11.2012
Сообщений: 5,491
01.06.2021, 10:59 2
Лучший ответ Сообщение было отмечено D_A_Y_T как решение

Решение

такой подход подойдет?
Код
=СУММЕСЛИ($D$2:$D$8;$D$3;B2:B8)+СУММЕСЛИМН($C$2:$C$8;$D$2:$D$8;$D$3;B2:B8;"=0")
1
0 / 0 / 0
Регистрация: 01.06.2021
Сообщений: 5
01.06.2021, 14:34  [ТС] 3
Да, получилось то, что нужно! Такая формула у меня
=СУММЕСЛИ('Реестр 2021'!$AF$3:$AF$402;"Седьмая";'Реестр 2021'!U3:U402)+СУММЕСЛИМН('Реестр 2021'!$V$3:$V$402;'Реестр 2021'!$AF$3:$AF$402;'Реестр 2021'!$AF$51;'Реестр 2021'!U3:U402;"=0")

Но еще много предстоит сделать)) Это только начало

Спасибо большое!

Добавлено через 12 минут
В итоге сложил три столбика, так как значений у меня три и их в одном столбике вести нельзя и дублировать при сложении нельзя

=СУММЕСЛИ('Реестр 2021'!$AF$3:$AF$402;"Пятая";'Реестр 2021'!U3:U402)+СУММЕСЛИМН('Реестр 2021'!$V$3:$V$402;'Реестр 2021'!$AF$3:$AF$402;'Реестр 2021'!$AF$35;'Реестр 2021'!U3:U402;"=0")+СУММЕСЛИМН('Реестр 2021'!$W$3:$W$402;'Реестр 2021'!$AF$3:$AF$402;'Реестр 2021'!$AF$35;'Реестр 2021'!V3:V402;"=0")
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
01.06.2021, 14:34

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Выполнение функции по без дублирования по нажатию
Привет, всем! Помогите пожалуйста. Есть на сайте radio. <span dtitle="kid"...

Запись с одной БД в другую без дублирования
Всем привет. Необходимо, чтобы программа получала данные с БД Oracle и записывала их в БД...

Запрос на добавление без дублирования записей
Здравствуйте, помогите, пожалуйста. Из двух таблиц 1 и 2 (в форме 2) нужно добавить данные в форму...

Защита от дублирования лайков без регистрации
Есть материалы которые могут оценивать пользователи (лайк,дизлайк) не могу решиться как реализовать...

Оптимальная сортировка без дублирования данных
Прошу помочь написать сортировку, которая позволит рационально расходовать память, избегая...

Вывод данных в таблицу без дублирования
КАРОЧ! как вывести с двух таблиц в один грид данные,чтобы они не дублировались при выводе? HELP...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.