Форум программистов, компьютерный форум, киберфорум
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
0 / 0 / 0
Регистрация: 04.04.2020
Сообщений: 28
1

Макрос для расчета среднего значения по нескольким листам книги, с условием

03.06.2021, 18:22. Показов 246. Ответов 1

Добрый день, форумчане!
Имеется формула которая считает среднее значение всех ячеек столбца AC из заданного диапазона, по заданным листам (в данном случае по всем).
Код
=СРЗНАЧ('1_Jan_2020:31_Jan_2020'!$AC$3601:$AC$3960)
Но, появилась потребность сделать условие для этой формулы, по которому бы она работала причем только для тех значений AC напротив которых в столбце AE стоит значение 1 (или 0).
Пытаюсь нагородить такого монстра:

Код
=ЕСЛИ('*Aug_2020'!$AC$3601:$AC$3960=1;СРЗНАЧ('*Aug_2020'!$AC$3601:$AC$3960;))
- эта формула выдет просто сообщение в ячеку "ложь"

или

Код
=СРЗНАЧЕСЛИ('1_Aug_2020'!$AE$3601:$AE$3960;"=1";'1_Aug_2020'!$AC$3601:$AC$3960)
- для одного листа она работает.
Но если попытаться сделать для всех листов (или для их диапазона)
Код
=СРЗНАЧЕСЛИ('*Aug_2020'!$AE$3601:$AE$3960;"=1";'*Aug_2020'!$AC$3601:$AC$3960)
то эксель уже ругается на слишком большой диапазон данных.
Возможно ли данный расчет сделать макросом а не формулой? В файле 365 листов, по 8760 строк каждый, макросу наверняка будет легче справится с этой задачей. И еще один важный момент - макрос не должен работать с данными того листа на котором он вызывается.

Спасибо!
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
03.06.2021, 18:22
Ответы с готовыми решениями:

Макрос Excel поиск по листам в книге с условием
Макрос Excel поиск по листам в книге с условием что при наличии запроса на листе, из него будет...

Макрос для расчета максимального значения от разностей
Здравствуйте, существует такая проблема, с VBA мало знаком, однако возникла необходимость с ним...

Макрос для поиска среднего значения диапазона
Прошу прощения за глупый вопрос, но либо я плохо мониторил, либо действительно не нашел решения...

Написать метод для расчета среднего арифметического значения элементов двумерного массива
Написать метод для расчета среднего арифметического значения элементов двумерного массива. (...

1
0 / 0 / 0
Регистрация: 04.04.2020
Сообщений: 28
04.06.2021, 17:51  [ТС] 2
Попробовал вариант с формулой

Код
=СРЗНАЧЕСЛИМН('1_Aug_2020:31_Aug_2020'!AC3601:AC3960;AE3601:AE3960;"=1")
но она выдает ошибку #знач!
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
04.06.2021, 17:51

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Создать макрос для рабочей книги MS Excel, позволяющий формировать значения в диапазонах ячеек
Помогите пожалуйста, я начинающий пр. мне очень трудно решать 1. Создать макрос для рабочей книги...

Как сделать кнопку для навигации по листам книги
Ребята, у меня такая проблема! нужно чтоб при открытии Excel открывалась форма и на ней кнопки, с...

Определение среднего значения по нескольким условиям
Здравствуйте форумчане! Нужна ваша смекалка. Запутался я нафиг... Вот прикрепил файл. Постарался...

Макрос для удаления строк с нулевыми значениями,сортировкой по нужным листам
Всем доброго времени суток! Решил сделать макросец для облегчения работы,но что-то идёт...

Вопрос по поводу расчета среднего значения
Подскажите,пожалуйста, как осуществить в Visual Basic расчет среднего значения тех чисел, которые...

Поиск по нескольким листам
Добрый день. В Общем. Имею Книгу Excel с 10 листами. В каждой из них Имеется всего один столбец с...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.