Форум программистов, компьютерный форум, киберфорум
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.67/3: Рейтинг темы: голосов - 3, средняя оценка - 4.67
0 / 0 / 0
Регистрация: 25.01.2021
Сообщений: 4
1

Написать формулу для нахождения числа

03.06.2021, 18:49. Показов 524. Ответов 5
Метки нет (Все метки)

Доброго времени суток!
Написать программу, которая выводит на экран нечетные числа, сумма цифр которых больше заданного значения m . Изначально задается три трехзначных числа.
Это задание для языка Java. Мне нужно сделать отчет по написанной программе и проверить ее. При написании формулы возникла затрудненность в виде того, что не знаю как разбить 3-х значное число на ее составляющие и сложить их (например дано число 835, следовательно его нужно проверить на нечетность, если оно нечетное, то разложить данное число на составляющие: 8, 3 и 5, после чего сложить их и если эта сумма больше числа m (допустим 10), то число (835) должно показываться в ячейке, если одно из условий не выполняется, то писать "данное число не подходит ни к одному из условий").
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
03.06.2021, 18:49
Ответы с готовыми решениями:

Написать формулу для нахождения количества элементов.
Для нахождения количества элементов обладающих свойствами t1 и t3 и не обладающих t2и t4,если...

Написать формулу для нахождения емкости на участке цепи
написать формулу для нахождения емкости на участке цепи А-В

Вывести формулу для нахождения числа молекул
Я понимаю что она не очень трудная, но у меня при выводах постоянно по 2 не известных переменных,...

Написать функцию для нахождения наибольшего числа
В текстовом файле записана непустая последовательность действительных чисел, разделенных пробелами...

5
3437 / 2102 / 697
Регистрация: 02.11.2012
Сообщений: 5,491
04.06.2021, 09:06 2
проверка
Код
=ЕСЛИ(ОСТАТ(A1;2);"нечетное";"четное")
суммирование
Код
=СУММПРОИЗВ(--ПСТР(A1;СТРОКА(A1:A3);1))
в одну формулу соберете сами?

Добавлено через 1 минуту
Цитата Сообщение от kakoyto Посмотреть сообщение
Это задание для языка Java.
здесь Эксель, Java скорей всего есть в другой ветке форума.
1
Модератор
1304 / 899 / 206
Регистрация: 31.05.2013
Сообщений: 6,070
Записей в блоге: 6
08.06.2021, 01:30 3
kakoyto, на каком языке Вам всё-таки нужно решение?
1
733 / 435 / 148
Регистрация: 22.12.2015
Сообщений: 1,308
08.06.2021, 02:18 4
Цитата Сообщение от kakoyto Посмотреть сообщение
Мне нужно сделать отчет по написанной программе и проверить ее.
Как я понимаю - есть программа на Java, нужно проверить правильность результатов, то есть сложить 3 цифры и сравнить с четвертой. На Java это будет выглядеть примерно так:
Java
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
import java.util.Scanner;
 
public class Main {
 
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int n, m, z;
        do {
            n = 0;
            m = 0;
            z = 0;
            p("Введите число (больше 99 и меньше 1000). Для выхода - введите ноль.");
            if (sc.hasNextInt()) n = sc.nextInt();
            if (n % 2 != 0 && n <= 999 && n >= 100) {
                p("Число проходит по критериям. Введите m");
                m = sc.nextInt();
                z = ((n / 1) % 10 + (n / 10) % 10 + (n / 100) % 10);
                if (z > m)
                    p((n + "\n" + z + ">" + m));
                else p("m больше суммы");
            } else if (n != 0) p("Число четное / не входит в диапазон. Обработка не требуется.");
            else p("Число равно 0. Выход из программы.");
        } while (n != 0);
    }
    public static void p(Object o) {
        System.out.println(o.toString());
    }
}
1
83 / 60 / 21
Регистрация: 03.12.2014
Сообщений: 232
08.06.2021, 08:36 5
Цитата Сообщение от Dinoxromniy Посмотреть сообщение
Как я понимаю - есть программа на Java
я б вставил бы этот код в любой компилятор JAVA, и начал бы проверять данный код на всякие разные кейсы, параллельно проверил бы результат на простом калькуляторе ) (если не принципиально искать решение в Excel)
0
0 / 0 / 0
Регистрация: 25.01.2021
Сообщений: 4
08.06.2021, 15:52  [ТС] 6
Всем большое спасибо за помощь, преподаватель не стал придираться и принял задание без проверки.
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
08.06.2021, 15:52

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Написать функцию для нахождения суммы цифр числа
Написать функцию для нахождения суммы цифр числа. Показать ее работу для однозначного, двузначного...

Нужно написать формулу нахождения функции у экспонент со степенями
Пишу программу нужно написать формулу для функций экспонента в степени корня третей и пятой...

Написать рекурсивную функцию для нахождения n-го числа арифметической прогрессии
2. Даны первый член и разность арифметической прогрессии. Написать рекурсивную функцию для...

Написать рекурсивную функцию для нахождения произведения цифр натурального числа
.Написать рекурсивную функцию для нахождения произведения цифр натурального числа. С помощью этой...

Написать программу на С++ для нахождения Получить все простые числа из промежутка
Написать програму на языке С++, использую цикл for. Задача: Даны натуральные числа a, b (a&lt;b)....

Написать процедуру для нахождения степени числа и вычислить значение выражения
Написать процедуру для нахождения степени числа и вычислить значение выражения:a^5+b^4+c^8


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.