Форум программистов, компьютерный форум, киберфорум
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
0 / 0 / 0
Регистрация: 08.06.2021
Сообщений: 1
1

Как найти предыдущую дату

08.06.2021, 16:10. Показов 242. Ответов 2
Метки нет (Все метки)

Доброго времени суток! Помогите пожалуйста найти предыдущую дату. Нужно чтобы в столбце Z появлялась предыдущая дата анализа (дата анализа записана в столбце I) определённого оборудования, есть уникальный код( столбец D).
0
Вложения
Тип файла: xlsx Журнал ХАРГ.xlsx (545.1 Кб, 4 просмотров)
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
08.06.2021, 16:10
Ответы с готовыми решениями:

Как получить предыдущую дату?
Помогите решить проблему. С помощью класса CTime получаю тек. дату и все ОК. CTime currentTime...

Определить предыдущую дату
Дата некоторого дня характеризуется тремя натуральными числами: g (год), m (порядковый номер...

Определить предыдущую дату
Вот сама задача: Даны 2 числа d-день и m-месяц Определить предыдущую дату... Я её сделал, но она...

Определить предыдущую дату
Нужно написать программу, которая считывает дату с клавиатуры в ЧЧ.ММ.ГГ. Определить предыдущую...

2
556 / 367 / 163
Регистрация: 09.01.2017
Сообщений: 1,138
08.06.2021, 17:03 2
ilyaigorevich, в столбец Z вторая строка, и протяните до конца
Visual Basic
1
=ВПР(D2;общий!D2:I1451;6;ЛОЖЬ)
0
812 / 471 / 147
Регистрация: 30.03.2013
Сообщений: 953
09.06.2021, 09:37 3
Предлагаю такую формулу.
Код
=IFERROR(AGGREGATE(14;6;общий!I$2:I$1569/(общий!D$2:D$1569=D2)/(общий!I2:I1569<I2);1);"")
0
Вложения
Тип файла: xlsx Журнал ХАРГ.xlsx (507.1 Кб, 2 просмотров)
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
09.06.2021, 09:37

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Определить предыдущую по порядку дату
Дата представляется тремя числами: d (день), m(месяц), y (год). Определить предыдущую по порядку...

Определить предыдущую по порядку дату
Дата представляется тремя числами: d (день), m(месяц), y (год). Определить предыдущую по порядку...

Вычисление суммы за предыдущую дату MS SQL
Здравствуйте! Помогите решить проблему. Не получается правильно составить запрос. Для того,...

Перемещение файлов, созданных за предыдущую дату (xcopy)
Здравствуйте! Прошу подсказать синтаксис команды xcopy. Нужно переместить файлы из папки...

Вычисление суммы за предыдущую дату MS SQL. Часть 2
Здравствуйте! Подскажите, как посчитать конечный остаток. У меня есть запрос, с помощью...

Особенные даты, определить следующую и предыдущую дату
Всем Hello, осуществил данный алгоритм, но вот не задача особенную дату вывести правильно никак не...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.