0 / 0 / 0
Регистрация: 14.07.2021
Сообщений: 1
1

Суммирование нормированных переменных в Excel

14.07.2021, 17:28. Показов 468. Ответов 6
Метки нет (Все метки)

Доброго времени суток!
Подскажите, пожалуйста, как правильно написать формулу для суммирования нормированных переменных в Excel? Заранее спасибо огромное)
__________________
Помощь в написании контрольных, курсовых и дипломных работ здесь
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
14.07.2021, 17:28
Ответы с готовыми решениями:

Суммирование скалярных переменных
Здравствуйте товарищи форумчане! Подскажите пожалуйста как решить данную задачу. Имею программу в...

Суммирование 2-х переменных типа Char
Снова такая проблема.... есть 2 переменные char x='1'; char y='2'; мне нужно...

Запись и суммирование переменных в файле
При сталкивании модельски объекта с моделью монет происходит увелечение переменной co на 1,...

Линейные операторы в нормированных пространтствах
Всем привет! A:C->C (Ax)(t)=x(t2) A:l1->l2 (Ax)(t)=(0,x1,x2,...) Являются ли они...

6
986 / 607 / 158
Регистрация: 05.10.2014
Сообщений: 2,795
15.07.2021, 09:30 2
Цитата Сообщение от gridyakinae1 Посмотреть сообщение
нормированных переменных в Excel
это что?
0
672 / 227 / 110
Регистрация: 30.01.2020
Сообщений: 599
15.07.2021, 10:13 3
Цитата Сообщение от gridyakinae1 Посмотреть сообщение
нормированных переменных в Excel
Цитата Сообщение от mihailm Посмотреть сообщение
это что?

Не по теме:

В процессе работы с Excel мы часто выражаем своё отношение к нему и его создателям словами и идиоматическими выражениями.
Если собрать этот поток выражений, и удалить из него ненормированную лексику - останутся только нормированные выражения.
Если из того, что осталось теперь отсеять постоянно повторяющиеся фразы - останутся только переменные.
Это и называется: нормированные переменные. Просто по определению.

0
1879 / 1005 / 211
Регистрация: 13.12.2016
Сообщений: 3,439
Записей в блоге: 3
15.07.2021, 10:25 4
Цитата Сообщение от gridyakinae1 Посмотреть сообщение
Подскажите, пожалуйста, как правильно написать формулу для суммирования нормированных переменных в Excel?
1.Напишите формулу для суммирования ненормированных переменных.
2.Убедите себя, что переменные нормированы.
3.Если у вас переменные могут давать ошибку (такое бывает) то оберните их в формулу ЕСЛИШИБКА или Nz() для VBA
0
3992 / 1389 / 382
Регистрация: 07.08.2013
Сообщений: 3,489
15.07.2021, 10:37 5
Цитата Сообщение от АЕ Посмотреть сообщение
Nz() для VBA
NZ вроде как только в аксе пролазит (хотя могу ошибаться)
1
1879 / 1005 / 211
Регистрация: 13.12.2016
Сообщений: 3,439
Записей в блоге: 3
15.07.2021, 11:43 6
snipe, вы абсолютно правы.
Цитата Сообщение от snipe Посмотреть сообщение
NZ вроде как только в аксе пролазит
сам проверил. там надо городить типа IF(ISBLANK(ref),value,ref)

Добавлено через 15 минут
вот такая функция будет работать как и в аксе
Visual Basic
1
2
3
Public Function Nz(ByVal Value, Optional ByVal ValueIfNull = "")
    Nz = IIf(IsNull(Value), ValueIfNull, Value)
End Function
Добавлено через 21 минуту
доработал на случай ошибки или деления на ноль
Visual Basic
1
2
3
4
5
6
7
Public Function Nz(ByVal Value, Optional ByVal ValueIfNull = "")
    If IsError(Value) Then
        Nz = 0
    Else
        Nz = IIf(IsNull(Value), ValueIfNull, Value)
    End If
End Function
0
5445 / 1478 / 361
Регистрация: 23.12.2010
Сообщений: 2,211
Записей в блоге: 1
15.07.2021, 15:26 7
=СУММ(A1:A10)/(МАКС(A1:A10)-МИН(A1:A10))

Добавлено через 7 минут
Формула оказалась посложнее:
=СУММ(A1:A10)/(МАКС(A1:A10)-МИН(A1:A10))-МИН(A1:A10)/(МАКС(A1:A10)-МИН(A1:A10))*СЧЁТ(A1:A10)
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
15.07.2021, 15:26

Уравнение плоскости для нормированных исходных данных
Исходные данные представляют собой массив точек (x,y,z), по ним по методу мнк успешно находится...

Суммирование в Excel
Добрый день, есть необходимость создать формулу вида X+X*1+X*2+...X*i,где i-e - это значение одной...

Суммирование ячеек в Excel
Добрый день, интересует вопрос как суммировать ячейки, одни или две с которых могут содержать...

Суммирование ячеек Excel
Здравствуйте! Помогите с Excel-ем. Мне нужно суммировать ячейки, но заранее я не знаю конкретный...

Суммирование. Импорт Excel
Имеется формула и таблица значений в Excel. Естественно необходимо посчитать формулу по данным этой...

Суммирование в одной ячейке (Excel)
Скажите пожалуйста, каким образом можно организовать суммирование вводимого в ячейку числа с уже...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
7
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.