0 / 0 / 0
Регистрация: 10.03.2021
Сообщений: 6
1

Закрашивание ячейки по формуле

19.07.2021, 10:30. Показов 414. Ответов 3
Метки нет (Все метки)

Всем привет! Есть таблица в которой перечислены агрегаты, даты их выпуска, сроки эксплуатации и даты окончания эксплуатации. Нужна формула для заливки ячейки при условии, что когда до окончания эксплуатации агрегата останется 3 месяца будет жёлтый цвет, а при полном истечении срока-красный! Как это реализовать? Образец приложил!
Вложения
Тип файла: xlsx Образец.xlsx (10.6 Кб, 9 просмотров)
__________________
Помощь в написании контрольных, курсовых и дипломных работ здесь
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
19.07.2021, 10:30
Ответы с готовыми решениями:

Пустые ячейки в формуле
Доброго дня. Есть формула =1/((1/8,7)+(D21/D20)+(D23/D22)+(D25/D24)+(1/D19)) Проблема в том,...

Как в формуле использовать имя ячейки
Здравствуйте. Как сделать, чтобы в формулу ячейки E3 приходило значение ячейки B3 в виде...

Запретить формуле считать пустые ячейки
Доброе время суток. Есть такая формула: =ЕСЛИ(F2=H2;1;0) Так вот, в ячейки f2 и h2 не всегда...

Как формуле пропустить пустые ячейки?
Есть столбец "А" с данными, но данные идут не подряд, а вразнобой, т.е. 1 ячека с данными следующие...

3
791 / 481 / 161
Регистрация: 22.12.2015
Сообщений: 1,439
19.07.2021, 10:45 2
Красное форматирование:
=ЕСЛИ(O5<СЕГОДНЯ();ИСТИНА;ЛОЖЬ)
Желтое форматирование:
=ЕСЛИ(O5-СЕГОДНЯ()<90;ИСТИНА;ЛОЖЬ)
1
5753 / 3018 / 642
Регистрация: 23.11.2010
Сообщений: 10,056
19.07.2021, 10:49 3
Еще вариант:
Красное форматирование:
=РАЗНДАТ(O5;$N$1;"m")>3
Желтое форматирование:
=РАЗНДАТ(O5;$N$1;"m")<=3
1
0 / 0 / 0
Регистрация: 10.03.2021
Сообщений: 6
19.07.2021, 11:09  [ТС] 4
Спасибо большое!
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
19.07.2021, 11:09

Выделяет некорректно ячейки по заданым мною формуле
Добрый день, пытался залить строку если одна из ячеек имеет букву &quot;б&quot; или &quot;к&quot; использовал...

Закрашивание части ячейки
Можно ли закрасить часть ячейки StringGrid'a?

C#. закрашивание ячейки сетки
У меня есть pictureBox произвольного размера, при нажатии на кнопку, на нем появляется сетка из...

Закрашивание ячейки в StringGrid
Возникла такая проблема. Нахожу в StringGrid-е MAX значение записываю его в переменную, затем...

Закрашивание ячейки StringGrid
Подскажите, пожалуйста, как закрасить ячейку при таком условии: Если a&gt;b, то ячейка закрашивается,...

Закрашивание ячейки массива
Можно закрасить ячейку массива? Если да,то как?


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.