0 / 0 / 0
Регистрация: 28.04.2015
Сообщений: 7
1

Вывод названия группы ячеек

05.10.2021, 19:17. Показов 395. Ответов 3
Метки нет (Все метки)

Приветствую всех.
Не могу понять, как реализовать следующую задачу. Есть две группы данных Рога и Копыта. В каждой из них есть список наименований товаров со стоимостью (столбики 11 и 51) для каждого товара. В столбике 56 выбирается минимальное значение стоимости товара, соответствующее Рогам или Копытам. Например, стоимость Антистеплер в группе Рога меньше, чем в группе Копыта, поэтому выводится значение из столбца 11. Необходимо в столбце 58 отобразить название группы (Рога или Копыта) в зависимости от выбранной минимальной стоимости. Как задать зависимость?
0
Вложения
Тип файла: xlsx Example.xlsx (98.3 Кб, 12 просмотров)
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
05.10.2021, 19:17
Ответы с готовыми решениями:

Название группы в зависимости от содержания ячеек
Здравствуйте. Помогите пожалуйста с формулой. В столбце "H" есть длинный список фраз. В столбце...

Выделение группы ячеек с одинаковыми значениями, но в разном порядке
Всем здравия! А как можно выделить строки, в которых ячейки одинаковые, но расположены в разном...

Как задать условное форматирование на группу ячеек по значению другой группы
Как сделать условное форматирование (выделение цветом) ячеек одного столбца при их значениях выше...

Как в comp model сделать вывод на дисплей содержимого группы ячеек памяти в числовой форме
Вывод на дисплей содержимого группы ячеек памяти в числовой форме (адрес и длина группы — параметры...

3
5714 / 2992 / 626
Регистрация: 23.11.2010
Сообщений: 9,976
05.10.2021, 20:26 2
Вариант, обратите внимание что ячейка с Копытами не объединена, как в Рогах (исправлено в файле)
Код
=ИНДЕКС($H$9:$BC$9;ПОИСКПОЗ(BD17;I17:BC17;0))
0
Вложения
Тип файла: xlsx Example.xlsx (105.2 Кб, 2 просмотров)
0 / 0 / 0
Регистрация: 28.04.2015
Сообщений: 7
06.10.2021, 18:25  [ТС] 3
Спасибо! Я нашёл другой способ, но он работает только для двух групп.
Код
=ЕСЛИ(RC[-1]=RC[-47];R9C8;R9C49)
0
5714 / 2992 / 626
Регистрация: 23.11.2010
Сообщений: 9,976
06.10.2021, 20:47 4
Цитата Сообщение от Arkusha Посмотреть сообщение
только для двух групп
в файле только две группы и есть
Цитата Сообщение от Arkusha Посмотреть сообщение
Я нашёл другой способ
рада за вас
1
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
06.10.2021, 20:47

Вывод группы записей, если условие выполняется хотя бы с одной записью из группы
Из базы данных со связью "многие ко многим" выбираю таблицу с сообщениями, соединённую с таблицей...

Одинаковые группы букв и вывод их количества: переделать, чтобы находились абсолютно все группы
Есть такая прога: находит одинаковые группы букв и выводит их количество, но рабоатет только если...

В зависимости от ячеек автозамена названия файла книги Excel
Последняя мелочь, в создании просчет программы для клиента: Нужно из ячеек ФИО и ячейки даты, при...

программа которая создает список группы(фамилия, имя, дата рождения,оценки матем,информатика,физика) вывод всего списка,вывод отличников,вывод двоиечн
программа которая создает список группы(фамилия, имя, дата рождения,оценки...

Макрос поиска объединенной группы ячеек
Привет. Имеется лист на котором есть несколько объединенных ячеек. Кто нибудь знает с помощью...

Передать значение группы ячеек в комбобокс
Ребята подскожите, Combo1.text=Xl.Worksheets("БД").Range("A2:A6").Value, почему у меня выдает...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.