0 / 0 / 0
Регистрация: 08.10.2021
Сообщений: 1
1

Функция для счета полных месяцев

08.10.2021, 16:43. Показов 202. Ответов 1
Метки нет (Все метки)

Всем привет!
Вопрос в следующем:
какую функцию нужно написать, чтобы посчитать число полных месяцев? с той особенностью, что, например,

если дата до 15 числа месяца, то это полный месяц <01.01.21 - 16.02.21 = два полных месяца>,

после 15 числа - не полный <16.02.21 - 16.03.21 = один полный месяц>.

Спасибо заранее.
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
08.10.2021, 16:43
Ответы с готовыми решениями:

Количество полных месяцев между двумя датами
Подскажите пожалуйста!) Имеются две даты, как подсчитать количество полных месяцев между ними?

Вычислить количество дней, полных месяцев, и полных лет, прошедших между датами
Даны натуральные числа a1, b1 , c1 (число, месяц, год) a2, b2, ...

Определить возраст человека и число полных месяцев
Напишите код прог.Я Вас прошу. (С уважением к вашом труду) Известны год и номер месяца рождения...

Подсчет количества полных месяцев между датами
плиз, помогите с кодом SQL на расчет количества полных месяцев между двумя датами

Определить состояние счета через заданное количество месяцев
Фирма заказчик(А) каждый месяц перечисляет на счёт фирмы подрядчика (В) сумму равную S, а фирма В...

1
5714 / 2992 / 626
Регистрация: 23.11.2010
Сообщений: 9,976
08.10.2021, 17:16 2
Привет. Как-то так, наверное.... проверьте
Код
=ЕСЛИ(ДЕНЬ(A1)<=15;РАЗНДАТ(A1;B1;"m")+1;РАЗНДАТ(A1;B1;"m"))
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
08.10.2021, 17:16

Вывести количество полных месяцев от этой даты до 10.11.2020
Помогите пожалуйста написать код к условию на C#: Задано дату рождения пользователя в формате...

Определение полных лет,месяцев и дней по введённой с клавиатуры дате.
Требуется составить программу,определяющую число полных лет, месяцев и дней на текущий момент по...

Функция для определения месяцев квартала
Здравствуйте, нужно сделать запрос с параметром, где будет выборка по столбцу из одной таблицы....

Посчитать сколько полных лет, месяцев и дней отделяют введенную дату от текущей
В поле ввода вводится дата. Посчитать сколько полных лет, месяцев и дней отделяют введенную дату от...

С клавиатуры вводится дата. Определить число полных лет, месяцев и дней, прошедших с этой даты
Составьте программу для решения одной из следующих задач. Добавьте в нее защиту от ввода...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.