0 / 0 / 0
Регистрация: 19.08.2021
Сообщений: 7
1

Условие с подсчетом данных по нескольким значениям

12.10.2021, 12:52. Показов 614. Ответов 6
Метки нет (Все метки)

Здравствуйте, столкнулся со сложностью с пониманием действия подсчета

Есть таблица
Условие с подсчетом данных по нескольким значениям


Необходимо если в столбце H указано "Победа", то делать суммирование всех строк столбца G которые соответствуют значению "Победа".
Если же в столбце H указано "Проигрыш", то отнимаем значение из столбца Е относительной той строки в которой указан "Проигрыш"

Подскажите пожалуйста как эту формулу написать?
0
Лучшие ответы (1)
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
12.10.2021, 12:52
Ответы с готовыми решениями:

Отбор данных в запросе по нескольким значениям в форме
Уважаемые форумчане. Пытаясь сделать простенькую базу данных натолкнулся на камень отбора данных в...

Фильтр по нескольким значениям
Здравствуйте, возникла проблема с фильтрацией таблицы. Имеется грид и 6 комбобоксов. Задача: при...

Отбор по нескольким значениям.
Здравствуйте, уважаемые форумчане. Если тема моя повторяется, то не судите строго, ткните носом...

Фильтрация по нескольким значениям
Я хочу провести фильтрацию поля таблицы TDB по нескольким значениям. Есть...

Выборка по нескольким значениям
Добрый день, друзья. Собственно ситуация такая: На фильтре из checkedComboBoxEdit1-a выбираю...

6
3458 / 2119 / 703
Регистрация: 02.11.2012
Сообщений: 5,542
12.10.2021, 14:27 2
Цитата Сообщение от StopTop13 Посмотреть сообщение
то отнимаем значение из столбца Е
от чего?
файл показываем, ну и вручную можете прописать для пару строк что да как.
0
0 / 0 / 0
Регистрация: 19.08.2021
Сообщений: 7
12.10.2021, 15:47  [ТС] 3
Цитата Сообщение от Vlad999 Посмотреть сообщение
от чего?
Приложил фото таблицы, там столбцы указаны. Файла нет, делаю через гугл таблицы.

Цитата Сообщение от Vlad999 Посмотреть сообщение
файл показываем, ну и вручную можете прописать для пару строк что да как.
Какие именно строчки интересуют?


============================

Например условие пересчета относительно первой строчки таблицы

Столбец E "Сумма ставки" 200
Столбец G "В. выйгрыш" 442
Столбец H "Результат" Победа

Нужно если в столбце H значение "Победа", то берем значения столбца G и прибавляем к числу, например 1000 + 442
Если же в столбце H значение "Проигрыш", то берем значение из столбца E и вычитаем его из числа, например 1000 - 200

Нужно это все из столбцов выводить в одну любую ячейку как результат просчета
0
5714 / 2992 / 626
Регистрация: 23.11.2010
Сообщений: 9,976
12.10.2021, 16:27 4
Цитата Сообщение от StopTop13 Посмотреть сообщение
Приложил фото таблицы
ответ тоже в картинке хотите?
0
0 / 0 / 0
Регистрация: 19.08.2021
Сообщений: 7
12.10.2021, 16:32  [ТС] 5
Цитата Сообщение от Fairuza Посмотреть сообщение
ответ тоже в картинке хотите?
Можно и в картинке. Не принципиально, переписать с картинки знаний хватит.

Таблица так принципиально я понять не могу? Мне кажется быстрей самому в три столбца накидать таблицу с рандомными данными чем мне щас с интернет таблицы все переносить в оффлайн и скидывать сюда...
0
3458 / 2119 / 703
Регистрация: 02.11.2012
Сообщений: 5,542
12.10.2021, 16:59 6
Лучший ответ Сообщение было отмечено StopTop13 как решение

Решение

СУММЕСЛИ в помощь.
Вангую.
типа этого
Код
=СУММЕСЛИ(H2:H4;"Победа";G2:G4)-СУММЕСЛИ(H2:H4;"Проигрыш";E2:E4)
1
0 / 0 / 0
Регистрация: 19.08.2021
Сообщений: 7
12.10.2021, 17:11  [ТС] 7
Цитата Сообщение от Vlad999 Посмотреть сообщение
=СУММЕСЛИ(H2:H4;"Победа";G2:G4)-СУММЕСЛИ(H2:H4;"Проигрыш";E2:E4)
Идеально, спасибо огромное, не понимал суть работы условия "СУММЕСЛИ" пытался через "СУММЕСЛИМН" сделать, но выдавало ошибку постоянно
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
12.10.2021, 17:11

Фильтр по нескольким значениям
Добрый день, необходимо по полученной коллекции произвести фильтр. Здесь я получаю несколько...

Поиск по нескольким значениям
Доброе утро всем. Ребята такой вопрос как сделать поиск сразу по нескольким значениям Если к...

Текстовый фильтр по нескольким значениям
Доброго времени суток. Существует лист с таблицей, в этой таблице мне нужно при помощи...

Выбор элементов по нескольким значениям
Всем привет, так сложилось что теперь редко работаю с mysql - затупил в простом запросе Есть...

Поиск результатов по нескольким значениям
Добрый день, Думаю, для гуру EXCEL моя задачка не покажется сложной, но я сломала уже голову,...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
7
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.