Форум программистов, компьютерный форум, киберфорум
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.77/121: Рейтинг темы: голосов - 121, средняя оценка - 4.77
RumOleg
1

Выборка из таблицы по двум условиям

28.01.2012, 15:26. Показов 22516. Ответов 3
Метки нет (Все метки)

Уважаемые эксперты!

Прошу помощи с небольшой задачей в Excel:

Имеется 2 выпадающих меню с условиями:
Сектор предприятия (нефть и газ, телеком, металлургия и др.)
Размер предприятия Tier 1 (малое), Tier 2 (среднее), Tier 3 (крупное).
И имеется таблица значений.

Как сделать, чтобы в одну клетку брался результат из этой таблицы в зависимости от обоих условий, выбранных в выпадающих меню?
Спасибо!

Пытался сделать через ЕСЛИ что-то вроде такого способа =ЕСЛИ(И(С4=”Нефть и газ”;С5=”Tier 1”);=Значения!C6;0), но в результирующей клетке получается очень-очень много если ЕСЛИ в ЕСЛИ, а, насколько я знаю, можно только 7). Пытался через ВПР, не получилось. Очень надеюсь на Вашу помощь!

Вот сам Файл Excel (скачать)

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
28.01.2012, 15:26
Ответы с готовыми решениями:

Выборка значения из массива по двум условиям
Доброго дня, уважаемый программисты. Ломаю голову над задачей, но опыта и знаний мало. Есть форма,...

Выборка последних ненулевых значений из столбца по двум условиям
пытаюсь написать формулу для :выборка последних не нулевых значений из столбца по двум условиям, но...

Выбор значения из таблицы по двум условиям
Здравствуйте Уважаемые! Необходимо сделать выборку из таблицы. Условия такие: 2 Столбца, В первом...

Сумма значений по двум условиям из таблицы
Господа, прошу помощи! Есть сводная таблица партнеров и планами проектов на будущее необходимо...

3
1250 / 408 / 52
Регистрация: 14.06.2009
Сообщений: 629
28.01.2012, 16:33 2
......
2
Вложения
Тип файла: xls Выборка из таблицы по двум условиям.xls (28.5 Кб, 3645 просмотров)
RumOleg
28.01.2012, 17:10 3
Огромное спасибо! Прекрасное решение!
671 / 177 / 10
Регистрация: 28.07.2010
Сообщений: 253
28.01.2012, 17:51 4
Если структура именно такая, то можно и так:
Код
=ИНДЕКС(Значения!C3:C35;ПОИСКПОЗ(C4;Значения!A3:A35;)+ПРАВСИМВ(C5)-1)
плюсы:
1. не формула массива
2. нет сцепления диапазонов, тормозящего расчеты.
еще вариант:
Код
=ИНДЕКС(Значения!C3:C35;ПОИСКПОЗ(1;ИНДЕКС((C4=Значения!A3:A35)*(C5=Значения!B3:B35););))
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
28.01.2012, 17:51

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Значение из одной таблицы в другую по двум условиям
Всем добрый день) Я у вас новичёк на форуме и хочу задать такую задачку, помогите, чем сможете)...

Выборка из таблицы по нескольким условиям MS Excel
Уважаемые эксперты, подскажите пожалуйста как сделать в данном случае. Есть 4 критерия - 4 столбца...

В запросе к БД фигурируют 3 таблицы. Нужны данные по двум условиям
1. Первая таблица oc_product. Берем поля model и geolocation 2. Вторая таблица...

Entity framework. Как объединить таблицы по двум условиям?
Всем привет. Кто пользовался EF подскажите пожалуйста как объединить таблицы по двум условиям ...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.