Форум программистов, компьютерный форум, киберфорум
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.85/67: Рейтинг темы: голосов - 67, средняя оценка - 4.85
0 / 0 / 0
Регистрация: 22.12.2012
Сообщений: 7
1

Как подсчитать количество значений в диапазоне

04.01.2013, 20:26. Просмотров 13819. Ответов 3
Метки нет (Все метки)


Помогите решить следующую проблему:
В диапазоне A4 находятся следующие значения: 1,2 1,X и.т.д
Как подсчитать общее количество содержащихся 1 2 и X ? Пробовал через функцию СЧЕТЕСЛИ, но считает только значения не разделенные запятой (целые).
0
Вложения
Тип файла: xlsx пример.xlsx (10.1 Кб, 92 просмотров)
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
04.01.2013, 20:26
Ответы с готовыми решениями:

Как подсчитать количество столбцов в несмежном диапазоне?
Подскажите пожалуйста, как подсчитать кол-во столбцов в не смежном диапазоне? Sub test() Dim...

Как вывести общее количество значений в диапазоне?
Добрый день. Вот возникла такая задача. В диапазоне A1:T20 есть прямоугольное поле 20х20, клетки...

Как подсчитать количество значений y на интервале от 1 до 2
Помогите пожалуйста, интересует как подсчитать количество значений y на интервале от 1 до 2, в...

Как подсчитать количество значений в столбце?
Доброго всем времени суток. Как программно подсчитать количество значений в столбце?

__________________
Помогаю в написании студенческих работ здесь.
3
2624 / 1324 / 255
Регистрация: 25.10.2010
Сообщений: 2,194
04.01.2013, 20:46 2
В функции СЧЁТЕСЛИ можно использовать подстановочные знаки.
Формула
Код
=СЧЁТЕСЛИ($A$1:$A$4;"*1*")
считает единицы, НО при условии, что формат ячеек текстовый и в каждой ячейке по одной единице

В критерии можно также использовать ссылку на ячейку (см. файл)
2
Вложения
Тип файла: xlsx пример-5.xlsx (10.2 Кб, 167 просмотров)
15016 / 6344 / 1725
Регистрация: 24.09.2011
Сообщений: 9,976
04.01.2013, 23:51 3
Вариант, в ячейках могут быть числа и более чем одна единица
Код
=СУММПРОИЗВ(ДЛСТР(A1:A4)-ДЛСТР(ПОДСТАВИТЬ(A1:A4;"1";"")))
или формула массива
Код
=СУММ(ДЛСТР(A1:A4)-ДЛСТР(ПОДСТАВИТЬ(A1:A4;"1";"")))
2
0 / 0 / 0
Регистрация: 22.12.2012
Сообщений: 7
05.01.2013, 19:14  [ТС] 4
Большое спасибо всем ответившим, все заработало.
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
05.01.2013, 19:14

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь или здесь.

Как подсчитать количество значений, выбранных фильтром?
как подсчитать количество значений выбранных фильтром???

Как подсчитать количество одинаковых значений в массиве?
Имеется большой отсортированный массив в котором нет уникальных значений.Необходимо подсчитать...

Как подсчитать общее количество числовых значений во всей таблице mysql
Здравствуйте! Подскажите пожалуйста, есть база mysql с текстовыми и числовыми значениями, как...

Подсчитать в массиве количество элементов, лежащих в диапазоне [0,10]
Дан массив А целых чисел. Подсчитать в нём количество элементов, лежащих в диапазоне . Помогите...

Подсчитать количество элементов,значений которых больше значений предыдущего элемента
Подсчитать количество элементов,значений которых больше значений предыдущего элемента?Спасибо.

Узнать количество значений в диапазоне
Подскажите формулу, пожалуйста Допустим, у меня есть значения от 1 до 15 и мне нужно узнать,...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.