Форум программистов, компьютерный форум, киберфорум
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.57/7: Рейтинг темы: голосов - 7, средняя оценка - 4.57
0 / 0 / 0
Регистрация: 30.03.2012
Сообщений: 6
1

Средний показатель для дня недели

06.01.2013, 03:41. Просмотров 1299. Ответов 1
Метки нет (Все метки)


В общем есть статистика. В первой колонке идут индексы дней недели(7-вс,6-сб,5-пт,4-чт.....1-пн).
Во второй колонке идут показатели.
Мне нужно высчитать средний показатель для дня недели.

На словах это делается так:
Например, для подсчета среднего показателя для воскресения.
Сумма строк в столбце B, при условии, что в столбце A той же строки значение равно 7. И эту сумму делить на количество строк в столбце А, где значение равно 7.
0
Миниатюры
Средний показатель для дня недели  
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
06.01.2013, 03:41
Ответы с готовыми решениями:

Написать программу, которая запрашивает у пользователя номер дня недели, затем выводит название дня недели
Написать программу, которая запрашивает у пользователя номер дня недели, затем выводит название дня...

Найти номер дня недели К-го дня года, если в этом году 1 января было днем недели с номером N
Дни недели пронумерованы следующим образом: 0 - воскресенье, 1 - понедельник, 2 - вторник, ..., 6 -...

Написать программу, которая по номеру дня недели (целому числу от 1 до 7) выдает в качестве результата название дня недели
!!!!!

Определить номер дня недели для заданного номера дня года
Дано целое число k (1<=k<=365). Присвоить целочисленной величине n значение 1, 2, ... , 6 или 0 в...

__________________
Помогаю в написании студенческих работ здесь.
1
5683 / 891 / 298
Регистрация: 25.02.2011
Сообщений: 1,265
Записей в блоге: 1
06.01.2013, 05:01 2
Среднее для воскресений (для остальных дней аналогично)
Формула массива:
Код
=СРЗНАЧ(ЕСЛИ($A$1:$A$21=7;$B$1:$B$21))
Обычная формула:
Код
=СУММЕСЛИ($A$1:$A$21;7;$B$1:$B$21)/СЧЁТЕСЛИ($A$1:$A$21;7)
для 2007/2010
Код
=СРЗНАЧЕСЛИ($A$1:$A$21;7;$B$1:$B$21)
1
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
06.01.2013, 05:01

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь или здесь.

Определить номер дня недели для заданного номера дня года
а как это примерно будет на C++ ?

Выведите номер дня недели для данного дня года
Помогите,пожалуйста...Среда Free Pascal Дан порядковый номер дня года (отсчет идет с 1-го...

Определить номер дня недели для заданного дня года
Дни недели пронумерованы следующим образом: 0 — воскресенье, 1 — понедельник, 2 — вторник, ..., 6 —...

Определить номер дня недели для K-го дня года
Дни недели пронумерованы следующим образом: 0 — воскресенье, 1 — понедельник, 2 — вторник, …, 6 —...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.