0 / 0 / 0
Регистрация: 09.01.2013
Сообщений: 4
1

суммировать по дате, но только определенные суммы

09.01.2013, 13:19. Показов 4171. Ответов 6
Метки нет (Все метки)

Пожалуйста помогите с формулой! У меня вставлена макрос-функция суммировать только те суммы, которые выделены определенным цветом. Теперь мне необходимо делать отчет за период...
0

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Вложения
Тип файла: rar Пример.rar (15.9 Кб, 29 просмотров)
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
09.01.2013, 13:19
Ответы с готовыми решениями:

Суммировать по дате
Доброго времени суток. В столбец F ставлю приход, а в столбец G дату прихода. Нужно помесячно...

Суммировать определенные числа в текстовом файле
Доброго времени суток !!!! Помогите исправить код Мне необходимо суммировать определенные числа в...

Суммировать стоимость при одинаковой дате на графике TChart
например 01.06.2012 - 750 01.06.2012 - 250 02.06.2012 - 500 на графике отображается как 3...

Как суммировать только отфильтрованные значения
Добрый день, Скажите, пожалуйста, как заставить excel считать сумму только тех ячеек, которые...

6
0 / 0 / 0
Регистрация: 09.01.2013
Сообщений: 4
09.01.2013, 16:29  [ТС] 2
=ЕСЛИ((B3:B36>=F3; B3:B36<=G3); СумЦвет(C3:C36; C3); 0)
попробовала эту формулу, но пишет !ЗНАЧ...
0
Вложения
Тип файла: rar Пример2.rar (16.0 Кб, 48 просмотров)
5713 / 2991 / 626
Регистрация: 23.11.2010
Сообщений: 9,975
09.01.2013, 16:39 3
Надо
Код
=ЕСЛИ((И(B3:B36>=F3; B3:B36<=G3)); СумЦвет(C3:C36; C3); 0)
1
0 / 0 / 0
Регистрация: 09.01.2013
Сообщений: 4
09.01.2013, 17:11  [ТС] 4
Спасибо огромнейшее!!!

Добавлено через 20 минут
блин, если внести какую-нибудь сумму за январь и попробовать сформировать отчет за январь, то не считает. Пишет "0". Может он даты воспринимает как числа?
0
3458 / 2119 / 703
Регистрация: 02.11.2012
Сообщений: 5,542
09.01.2013, 17:21 5
возможно это вы имели ввиду.
Код
=СумЦвет(ИНДЕКС(D2:D36;ЕСЛИ(ЕНД(ПОИСКПОЗ(F3;B2:B36;1));1;ПОИСКПОЗ(F3;B2:B36;1))+1):ИНДЕКС(D2:D36;ПОИСКПОЗ(G3;B2:B36;1));D3)
или просите знатаков VBA дописать в функцию выбор критериев. Хотя такие уже написаны например Надстройка MyAddin поищите
0
0 / 0 / 0
Регистрация: 09.01.2013
Сообщений: 4
09.01.2013, 17:35  [ТС] 6
уух, большая какая! работает...Спасибо!
как теперь самой понять, на будущее...)) буду разбираться
0
3458 / 2119 / 703
Регистрация: 02.11.2012
Сообщений: 5,542
09.01.2013, 17:46 7
она будет работать только если даты будут идти по возрастающей.
если дата до будет больше последней даты то формула выдаст ошибку.
1
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
09.01.2013, 17:46

Суммировать N 50-значных чисел и вывести на экран первые 10 цифр суммы
День добрый. Нужно найти первые 10 цифр суммы нескольких 50-значных чисел. На первой строке...

Нужно суммировать только те ячейки, которые удовлетворяют условию
если вот такая таблица: ЦФУ ДОЛГ ПОГАШЕНО ола 160 000 долг ила 195 000 195 000 ола 90...

Склад в Аксесс не получается суммировать приход и вычитать из общей суммы по позиции расход
Не получается придать приличный вид и создать форму или запрос где было видно приход- расход =...

Проверять в DBgrid записи, и суммировать только те, где присутствует 9008
Нужен алгоритм который будет поверять в DBgrid записи и суммировать только те где присутствует...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
7
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.