Форум программистов, компьютерный форум, киберфорум
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.66/32: Рейтинг темы: голосов - 32, средняя оценка - 4.66
0 / 0 / 0
Регистрация: 31.07.2013
Сообщений: 70
1

Как правильно написать формулу учёта "0" "пустоты" и "1"

29.08.2013, 09:29. Просмотров 5796. Ответов 14
Метки нет (Все метки)

Есть формула {=И(H4:K4=0;H4:K4<>"";O4:R4=0;O4:R4<>"")} - которая в ячейках H4:K4, O4:R4 - выбирает 0 или пустоту и если таковые имеются то показывается истину. Как сделать так чтобы при значении "1" в любой из этих ячеек она показывала ИСТИНА, а при "0" - ЛОЖЬ и другая формула должна показывать всё наоборот если "1" - то ЛОЖЬ если "0" истина, пустоту в любом случае считать как "0"

P.S. Мне нужно в каждой строчке сделать так если в H4:K4 и O4:R4 всё равно 0 или пустоте то значение должно быть ИСТИНА для колонки "Не принимают", если в одной из ячеек есть 1 то в колонке филиал "Не принимают" должно стоять ЛОЖЬ. А в колонке "Принимают" нужно указать ИСТИНА.

primer.zip
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
29.08.2013, 09:29
Ответы с готовыми решениями:

Требуется чтобы в "Таблице" при заполнении столбца "тип картриджа" столбец "аппарат" заполнялся автоматически
Доброго времени суток! Есть таблица по учету картриджей и техники. Требуется чтобы в &quot;Таблице&quot; при...

Как сделать: если во всех ячейках диапазона знач.="выполнено", то в данной ячейке тоже "выполнено" иначе "в работе"
Прилагаю файл. В ячейке G17 формула, в которой надо упростить условие: Если в диапазоне ячеек...

Ответ в виде "правда" или "ложь" на "а правда ли что" с определенным условие №1
Нужна помощь с екселем

Ответ в виде "правда" или "ложь" на "а правда ли что" с определенным условие №2
Нужна помощь с екселем

14
97 / 48 / 0
Регистрация: 14.08.2013
Сообщений: 230
Записей в блоге: 4
29.08.2013, 10:03 2
для ячейки AD4: =ЕСЛИ(СУММ(СЧЁТЕСЛИ(H4:K4;1);СЧЁТЕСЛИ(O4:R4;1))=0;ИСТИНА;ЛОЖ Ь)

для ае4: =не(AD4).

И протянуть.

Так?
0
0 / 0 / 0
Регистрация: 31.07.2013
Сообщений: 70
29.08.2013, 10:13  [ТС] 3
Цитата Сообщение от -DimN- Посмотреть сообщение
для ячейки AD4: =ЕСЛИ(СУММ(СЧЁТЕСЛИ(H4:K4;1);СЧЁТЕСЛИ(O4:R4;1))=0;ИСТИНА;ЛОЖ Ь)

для ае4: =не(AD4).

И протянуть.

Так?
Сейчас попробую
0
0 / 0 / 0
Регистрация: 31.07.2013
Сообщений: 70
29.08.2013, 10:23  [ТС] 4
Цитата Сообщение от -DimN- Посмотреть сообщение
для ячейки AD4: =ЕСЛИ(СУММ(СЧЁТЕСЛИ(H4:K4;1);СЧЁТЕСЛИ(O4:R4;1))=0;ИСТИНА;ЛОЖ Ь)

для ае4: =не(AD4).

И протянуть.

Так?
Формула считает не так как хотелось бы. в AE4 точно не так, слишком большой показатель получается. в AD4 - счёт ведётся не правильно. Я приложил обезличенную таблицу со значениями, должно в результате получится так в столбце "Не принимают" = 2 в столбце "Принимают" = 33.

Пример таблички:
Пример таблицы.zip
0
97 / 48 / 0
Регистрация: 14.08.2013
Сообщений: 230
Записей в блоге: 4
29.08.2013, 10:48 5
Считает правильно!!!, ты же говорил, что пустые тоже в расчёт брать.
Если удалишь из таблицы не заполненные строки всё получится или:
для AB5: =СЧЁТЕСЛИМН(AE4:AE310;ИСТИНА;A4:A310;"<>")
для AB6: =СЧЁТЕСЛИМН(AD4:AD310;ИСТИНА;A4:A310;"<>")

Понимаешь, ограничить надо конечный подсчёт только "действующими" строками таблицы.
0
36 / 36 / 0
Регистрация: 18.06.2013
Сообщений: 84
29.08.2013, 10:56 6
sabotajue, по-моему, все проще))) если есть хотя бы одна единица, то сумма 2х диапазонов =>1. если единиц нет, то сумма <1...

для столбца "не принимают":
=ЕСЛИ(A4="";"";ЕСЛИ(СУММ(H4:K4;O4:R4)<1;ИСТИНА;ЛОЖЬ))

а второй столбец оставьте через "Не", хорошее решение, только чуть подправить:
=ЕСЛИ(AD4="";"";НЕ(AD4))
0
0 / 0 / 0
Регистрация: 31.07.2013
Сообщений: 70
29.08.2013, 11:06  [ТС] 7
Цитата Сообщение от -DimN- Посмотреть сообщение
Считает правильно!!!, ты же говорил, что пустые тоже в расчёт брать.
Если удалишь из таблицы не заполненные строки всё получится или:
для AB5: =СЧЁТЕСЛИМН(AE4:AE310;ИСТИНА;A4:A310;"<>")
для AB6: =СЧЁТЕСЛИМН(AD4:AD310;ИСТИНА;A4:A310;"<>")

Понимаешь, ограничить надо конечный подсчёт только "действующими" строками таблицы.
Так, в принципе потихоньку начал схватывать. А скажите почему тогда в ячейке AB6 значение отображается как 274?
0
0 / 0 / 0
Регистрация: 31.07.2013
Сообщений: 70
29.08.2013, 11:11  [ТС] 8
Вот посмотрите что получается, когда я ввёл формулы

для AB5: =СЧЁТЕСЛИМН(AE4:AE310;ИСТИНА;A4:A310;"<>")
для AB6: =СЧЁТЕСЛИМН(AD4:AD310;ИСТИНА;A4:A310;"<>")

для ячейки AD4: =ЕСЛИ(СУММ(СЧЁТЕСЛИ(H4:K4;1);СЧЁТЕСЛИ(O4:R4;1))=0;ИСТИНА;ЛОЖ Ь)
для ае4: =не(AD4).

Пример таблицы.zip


Странно почему-то? В чём проблема не понимаю
0
97 / 48 / 0
Регистрация: 14.08.2013
Сообщений: 230
Записей в блоге: 4
29.08.2013, 11:16 9
Потому что первый столбец пустой!!! Заполни ВСЁ (или первый столбец) и увидишь, что "ФСЁ НАРАМАЛЬНА"!!!

В формулах АВ5 - АВ6 идёт определение конца таблицы по первому столбцу таблицы, если можно так выразиться и счёт результатов в AD:AE берётся в интервале от начала до определённого ранее конца таблицы
1
36 / 36 / 0
Регистрация: 18.06.2013
Сообщений: 84
29.08.2013, 11:18 10
Цитата Сообщение от -DimN- Посмотреть сообщение
Потому что первый столбец пустой!!! Заполни ВСЁ и увидишь, что "ФСЁ НАРАМАЛЬНА"!!!

В формулах АВ5 - АВ6 идёт определение конца таблицы по первому столбцу таблицы, если можно так выразиться и счёт результатов в AD:AE берётся в интервале от начала до определённого конца таблицы
зачем вручную все время проверять заполнены строки или нет и потом что-то удалять??? проще сразу в формуле учесть
0
0 / 0 / 0
Регистрация: 31.07.2013
Сообщений: 70
29.08.2013, 11:20  [ТС] 11
Цитата Сообщение от -DimN- Посмотреть сообщение
Потому что первый столбец пустой!!! Заполни ВСЁ (или первый столбец) и увидишь, что "ФСЁ НАРАМАЛЬНА"!!!

В формулах АВ5 - АВ6 идёт определение конца таблицы по первому столбцу таблицы, если можно так выразиться и счёт результатов в AD:AE берётся в интервале от начала до определённого ранее конца таблицы
Действительно заработало! Спасибо большое за мучение со мной +1
0
DimN
29.08.2013, 11:23
  #12

Не по теме:

Цитата Сообщение от sabotajue Посмотреть сообщение
Действительно заработало! Спасибо большое за мучение со мной :) +1
Приходи ещё!!!

0
0 / 0 / 0
Регистрация: 31.07.2013
Сообщений: 70
29.08.2013, 11:25  [ТС] 13
Цитата Сообщение от -DimN- Посмотреть сообщение
Потому что первый столбец пустой!!! Заполни ВСЁ (или первый столбец) и увидишь, что "ФСЁ НАРАМАЛЬНА"!!!

В формулах АВ5 - АВ6 идёт определение конца таблицы по первому столбцу таблицы, если можно так выразиться и счёт результатов в AD:AE берётся в интервале от начала до определённого ранее конца таблицы
Заработало, только есть одна проблема первый столбец не всегда заполняется. Т.е. заполняться может или первый столбец (Колонка A) если он не заполняется, то заполняться должен столбец F, он примерно такую же функцию несёт как и столбец А. Как можно учёт или одного или другого, или вообще убрать этот учёт? Заранее спасибо
0
97 / 48 / 0
Регистрация: 14.08.2013
Сообщений: 230
Записей в блоге: 4
29.08.2013, 11:31 14
Вот тут:
=СЧЁТЕСЛИМН(AE4:AE310;ИСТИНА;A4:A310;"<>")
или добавь нужный диапазон дальше в функцию по образу и подобию, или убери выделенное...
0
0 / 0 / 0
Регистрация: 31.07.2013
Сообщений: 70
29.08.2013, 11:47  [ТС] 15
Цитата Сообщение от -DimN- Посмотреть сообщение
Вот тут:
=СЧЁТЕСЛИМН(AE4:AE310;ИСТИНА;A4:A310;"<>")
или добавь нужный диапазон дальше в функцию по образу и подобию, или убери выделенное...
убрал, всё равно не получается. Попытал формулу дополнить =СЧЁТЕСЛИМН(AD4:AD310;ИСТИНА;A4:A310;"<>";F4:F310;"<>") при этом получаются "0"

или убрать =СЧЁТЕСЛИМН(AD4:AD310;ИСТИНА) при этом значения не реальны
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
29.08.2013, 11:47

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

НА ЭКСЕЛЕ БАЗА ДАННЫХ .Создать листы "сотрудники" кафедры","дисциплины". и с помощью ВПР и СУММЕСЛИ связать эти листы
Предметная область: Учебно-методическое управление (профессорско-преподавательский состав)....

Как взять с формата "чч:мм:сс" только целые "чч"?
Помогите с решением вопроса, голову сломал: Формулой в Excel получил заведомое значение времени...

Для товаров, находящихся на отдельном листе "Товары", найти и сопоставить цены из листа "Прайс"
Нужно решить 2 теста, у меня нет офиса, только онлайн. Как это можно решить в онлайн офисе?...

Работа с данными в форматах "дата" и "время". Расчет отклонения от нормы
Добрый день! Подскажите пожалуйста: У меня есть ячейка, с данными хронометража (ЯЧЕЙКА №1)....


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
15
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.