Форум программистов, компьютерный форум, киберфорум
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.88/8: Рейтинг темы: голосов - 8, средняя оценка - 4.88
1 / 1 / 0
Регистрация: 09.02.2013
Сообщений: 95
1

Подсчёт количества значений в ячейках

28.10.2013, 02:58. Просмотров 1576. Ответов 2
Метки нет (Все метки)


Здравствуйте! Возникла такая проблема, - никак не могу составить формулу для подсчёта количества побед (ячейки F4:F19). Формулы для подсчёта призового места (G4:G19) и количества боёв (E4:E19) подобрал, а вот для количества побед никак не получается. Для количества боёв проще, там надо посчитать сколько раз фамилия в этой же строке в столбце "B" повторяется в диапазоне B22:K39. А для количества побед надо сложить все значения в ячейке справа от этой фамилии в том же диапазоне (B22:K39). Как это сделать, никак не пойму. Подскажите пожалуйста, как это сделать? Файл прилагаю.
0
Вложения
Тип файла: rar Подсчет количества побед.rar (20.7 Кб, 19 просмотров)
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
28.10.2013, 02:58
Ответы с готовыми решениями:

Подсчёт количества значений
Здравствуйте. Имеем таблицу из 3 столбцов. В первом столбце только даты, во втором либо дата...

Подсчёт количества значений по условию
Подскажите, пожалуйста, где ошибка в формуле? Нужно посчитать количество значений в столбце D по...

Подсчет количества ячеек в диапазоне их значений
1. Подсчет количества ячеек в диапазоне их значений. Нужно посчитать, например, в файле в колонке С...

Подсчет количества значений, удовлетворяющих условию
Здравствуйте! Мне надо подсчитать в каждом столбце количество определенных значений,...

2
671 / 177 / 10
Регистрация: 28.07.2010
Сообщений: 253
28.10.2013, 12:09 2
Используйте формулу:
Код
=СУММЕСЛИ(B$22:J$39;B4;C$22:K$39)
1
1 / 1 / 0
Регистрация: 09.02.2013
Сообщений: 95
28.10.2013, 13:25  [ТС] 3
Цитата Сообщение от DV68 Посмотреть сообщение
Используйте формулу:
Код
=СУММЕСЛИ(B$22:J$39;B4;C$22:K$39)
Спасибо большое! Работает! И какая простая формула! Вы даже не представляете, сколько времени я убил на подбор формулы, не зная, как правильно это делается. Примерный вариант моих вычислений:
=ЕСЛИ(B4<>"";ЕСЛИ(G4=1;E4;ЕСЛИ(G4=2;E4-1;ЕСЛИ(G4=3;E4-1;ЕСЛИ(G4=4;E4-2;ЕСЛИ(E4<4;E4-1;"ФБ не завершены")))));0)
Но были и такие, что вспомнить страшно... :-)
Ещё раз спасибо!
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
28.10.2013, 13:25

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь или здесь.

Подсчет сумм максимального количества подряд идущих значений
Добрый день! Нашел в интернете урок Подсчет максимального количества подряд идущих значений в MS...

Подсчет количества одинаковых значений в последних 10 ячейках
Возможно ли сделать подсчет количества значений в последних 10 ячейках То есть в столбце 1:...

Подсчет количества изменений в ячейках столбца
Привет! Необходимо написать запрос, как проставить ранжирование по условию задачи. Есть таблица...

Подсчет количества нечетных чисел в ячейках $8200-$82ff
Нужна программа, производящую подсчет количества нечетных чисел в ячейках $8200...$82ff. Если кто...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.