Форум программистов, компьютерный форум, киберфорум
Другие языки программирования
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.64/11: Рейтинг темы: голосов - 11, средняя оценка - 4.64
0 / 0 / 0
Регистрация: 19.07.2014
Сообщений: 9
1

[КуМир] Дана матрица размером 5×4. Поменять местами заданные столбцы с номерами n1 и n2

03.09.2014, 16:33. Просмотров 2161. Ответов 1


Здравствуйте. Помогите пожалуйста с задачей.
Дана матрица размером 5×4. Поменять местами заданные
столбцы с номерами n1 и n2. Вывести полученную матрицу.
Заранее спасибо.
0
Лучшие ответы (1)
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
03.09.2014, 16:33
Ответы с готовыми решениями:

Дана матрица размера N×M. Поменять местами столбцы
Есть такая вот задачка. На мой взгляд, должна работать.Компилятор выдает исключение(индекс за...

Дана вещественная матрица размера N×M. Поменять местами столбцы матрицы
Дана вещественная матрица размера N×M. Поменять местами столбцы матрицы, содержащие наибольшее и...

Дана матрица размера N×M. Поменять местами столбцы матрицы с min и max суммой положительных элементов
Здравствуйте задали написать код, и я не понимаю как сделать, всё что смог написал, но дальше я не...

В двумерном массиве целых чисел размерности 5×9 поменять местами строки и столбцы с одинаковыми номерами
В двумерном массиве целых чисел размерности 5×9 поменять местами строки и столбцы с одинаковыми...

1
Модератор
62899 / 46929 / 32344
Регистрация: 18.05.2008
Сообщений: 113,713
03.09.2014, 17:20 2
Лучший ответ Сообщение было отмечено ildwine как решение

Решение

Код
алг 
нач
цел m,n,i,j,n1,n2,x
цел таб a[1:5,1:4]
m:=5
n:=4
вывод "Исходная матрица", нс
i:=0;
нц m раз
i:=i+1
j:=0;
нц n раз
j:=j+1
a[i,j]:=irand(10,20);
вывод a[i,j],"  "
кц
вывод нс
кц
вывод "Введите номера столбцов для обмена от 1 до 4 n1<>n2", нс
ввод n1,n2
если n1<1 или n1>4 или n2<1 или n2>4 или n1=n2 то вывод "Неверные номера столбцов" все
i:=0;
нц m раз
i:=i+1
x:=a[i,n1]
a[i,n1]:=a[i,n2]
a[i,n2]:=x
кц
вывод "Измененная матрица", нс
i:=0;
нц m раз
i:=i+1
j:=0;
нц n раз
j:=j+1
вывод a[i,j],"  "
кц
вывод нс
кц
кон
1
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
03.09.2014, 17:20

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь или здесь.

Дана целочисленная прямоугольная таблица размером m×n. Поменять местами первую и предпоследнюю строки.
Двумерный массив. 1) Дана целочисленная прямоугольная таблица размером m×n. Поменять местами...

Дана матрица размера M×N. Поменять местами верхнюю и нижнюю половины матрицы
Дана матрица размера M×N. Поменять местами верхнюю и нижнюю половины матрицы.

Дана матрица размера M× N. Поменять местами столбец с номером N и первый из столбцов
Дана матрица размера M× N. Поменять местами столбец с номером N и первый из столбцов, содержащих...

Дана матрица размером nxn. Поменять местами к-ю и 1-ю строки (1<=k, 1<=n)
Выручайте! Заранее благодарна!

Дана матрица размера M × N. Поменять местами строки, содержащие минимальный и максимальный элементы матрицы
Я написал программу меняющую максимальный и минимальный элемент местами, но поменять строчки в...

Дана матрица. Надо поменять местами первый и последний столбцы
namespace матрицы { class Program { public static void Main(string args) {...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.