Форум программистов, компьютерный форум, киберфорум
Другие языки программирования
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.73/15: Рейтинг темы: голосов - 15, средняя оценка - 4.73
1 / 1 / 1
Регистрация: 23.01.2015
Сообщений: 88
1

Кумир- Работа с файлами

14.05.2020, 21:16. Просмотров 2911. Ответов 2
Метки нет (Все метки)

Парни, Не работают файловые команды, вообще

открыть на запись/открыть на чтение, и т.д.

ошибка
алг-функцию не вызывать (2706)

Версия 1.9

в версии новее ни работает вообще всё, Ни создание, ни чего.
ф_вывод, и ф_ввод тоже не работают не там ни там.

Код
использовать Файлы П

цел n,n2,n3, myx,myn
алг save
нач  лит qq,ss
ввод n , n2, n3

qq:="qq.txt"
если не существует файл(qq)
то создать файл(qq)
все
цел x

нц 3 раз
выбор
при n>n2 и n>n3: myx:=n
при n2>n и n2>n3: myx:=n2
при n3>n и n3>n: myx:=n3
все
кц

нц 3 раз
выбор
при n<n2 и n<n3: myn:=n
при n2<n и n2<n3: myn:=n2
при n3<n и n3<n: myn:=n3
все
кц

открыть на запись(qq,x)  - алг-функцию не вызывать  (2706)
вывод x, "max=", myx," min=",myn
закрыть (x)
кон
Может знает как надо вводить, выводить в файл

Добавлено через 13 минут
Если знаете как в новой, то пишите хоть её, Хоть как то бы и где то работало
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
14.05.2020, 21:16
Ответы с готовыми решениями:

Работа с файлами , хотелось бы с windows system файлами
всем привет, нужна интересная идея по программированию, работа с файлами , хотелось бы с windows...

Работа с файлами(Запись,чтение,работа с данными)
Здравствуйте, никак не могу осилить файлы... Для начала вот само задание: В справочной автовокзала...

Лабораторная работа №5. Работа с файлами и алгоритмы сортировки
1. Написать функцию Load для считывания из текстового файла (например, Workers.txt) информации о...

Работа с файлами, чтение/работа со строкой
Доброго времени суток. Начал работать с C++ Builder 6. Есть текстовый файл .txt с различными...

2
Супер-модератор
Эксперт Pascal/DelphiАвтор FAQ
30771 / 20102 / 7853
Регистрация: 22.10.2011
Сообщений: 34,927
Записей в блоге: 6
15.05.2020, 00:48 2
2.1.0-rc10, нормально все работает:
Код
использовать Файлы

цел n,n2,n3, myx,myn
файл f
алг save
   нач  лит qq,ss
   ввод n , n2, n3

   qq:="qq.txt"

нц 3 раз
   выбор
      при n>n2 и n>n3: myx:=n
      при n2>n и n2>n3: myx:=n2
      при n3>n и n3>n: myx:=n3
   все
кц

нц 3 раз
   выбор
      при n<n2 и n<n3: myn:=n
      при n2<n и n2<n3: myn:=n2
      при n3<n и n3<n: myn:=n3
   все
кц

f := открыть на запись(qq)
вывод f, "max=", myx," min=",myn
закрыть (f)
кон
, создался файл с правильным результатом...
0
1 / 1 / 1
Регистрация: 23.01.2015
Сообщений: 88
15.05.2020, 16:15  [ТС] 3
спасибо,
Значит надо к ключу всё приравнивать, окей.
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
15.05.2020, 16:15

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Работа с файлами С++
Перезаписать текстовый файл, выбросив из него все гласные буквы, новый файл не ...

Работа с файлами
помогите решить плиз!!!!!! зарание всем огромное спс!!! Задача 1. Дан файл целых чисел....

Работа с файлами
Есть вот такая вот проблема: нужно с файла *txt считать текст и от туда выбрать все цитаты (слова и...

Работа с файлами в C++
Дан текстовый файл, компонентами которого являются целые числа, не равные нулю. Числа в файле идут...

Работа с файлами
Задача из сборника Златопольского: 14.28. Имеется типизированный файл, элементами которого...

Работа с файлами
Задание-найти в массиве минимальный элемент и записать его в первую строку файла, во вторую строку...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.