Форум программистов, компьютерный форум, киберфорум
Другие языки программирования
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.54/13: Рейтинг темы: голосов - 13, средняя оценка - 4.54
0 / 0 / 0
Регистрация: 07.11.2020
Сообщений: 4
1

[КуМир] Дан массив, содержащий несколько нулевых элементов. «Сжать» его, выбросив эти элементы

08.11.2020, 00:37. Просмотров 2401. Ответов 1

Написать программу на школьном алгоритмическом языке "Кумир". Желательно с комментариями!
Например: ввод - "0 0 0 0 0 1 2 3 4 5", вывод - "1 2 3 4 5".
0
Лучшие ответы (1)
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
08.11.2020, 00:37
Ответы с готовыми решениями:

Задан массив, содержащий несколько нулевых элементов. Сжать его, выбросив эти элементы
Помогите решить)

Задан массив, содержащий несколько нулевых элементов. Сжать его выбросив эти элементы
Задан массив, содержащий несколько нулевых элементов. Сжать его выбросив эти элементы, а оставшиеся...

Задан массив, содержащий несколько нулевых элементов. Сжать его, выбросив эти элементы
Помогите, пожалуйста...

Массивы. Задан массив,содержащий несколько нулевых элементов. Сжать его выбросив эти элементы.
Задан массив,содержащий несколько нулевых элементов. Сжать его выбросив эти элементы.

1
Модератор
62540 / 46714 / 32197
Регистрация: 18.05.2008
Сообщений: 113,060
08.11.2020, 08:25 2
Лучший ответ Сообщение было отмечено Rimches как решение

Решение

Код
алг 
нач
цел таб a[1:100]
цел N,i
нц
вывод "Введите размер масива: "
ввод N
если N<1 или N>100 то вывод "Введите N от 1 до 100",нс
все
кц при N>=1 и N<=100
вывод нс,"Исходный масссив",нс
нц для i от 1 до N
a[i]:=-2+int(rnd(5));
вывод a[i]," "
кц
вывод нс,"Удаление нолей:"
i:=N
N:=0
нц для i от 1 до i 
если a[i]<>0 то 
N:=N+1 
a[N]:=a[i]
все
кц
нц для i от 1  до N
вывод a[i]," "
кц
кон
1
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
08.11.2020, 08:25

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Задан массив, содержащий несколько нулевых элементов. Сжать массив, выбросив эти элементы
Тема 3. Одномерные массивы Задан массив, содержащий несколько нулевых элементов. Сжать массив,...

JavaScript. Дан массив, содержащий несколько нулевых элементов
JavaScript. Дан массив, содержащий несколько нулевых элементов. Сжать его, исключив эти элементы.

Задан массив, содержащий несколько нулевых элементов
4. Задан массив, содержащий несколько нулевых элементов. Сжать его, выбросив эти элементы. я...

. Дан одномерный вещественный массив А(N) , не содержащий нулевых элементов
Товарищи, выручайте. Очень зашиваюсь и с информатикой проблемы.. а учебный план давит =( очень...

Сжать массив, выбросив нулевые элементы
4. Дан массив, содержащий несколько нулевых элементов. Сжать его, выбросив эти элементы. Измененный...

Сжать массив, выбросив нулевые элементы
Задан массив, содержащий нулевые элементы. Сжать его , ыбросив эти элементы, порядок следования...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.