Форум программистов, компьютерный форум, киберфорум
Другие языки программирования
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.92/13: Рейтинг темы: голосов - 13, средняя оценка - 4.92
0 / 0 / 0
Регистрация: 07.11.2020
Сообщений: 4
1

[КуМир] Пригодность детали оценивается по размеру В, который должен находиться в пределах значений от А - b до А + b

08.11.2020, 00:44. Просмотров 2465. Ответов 7
Метки нет (Все метки)

Пригодность детали оценивается по размеру В, который
должен находиться в пределах значений от А - b до А + b. Определить, имеются ли в партии из N деталей бракованные. Если имеются, найти их количество, в противном случае вывести отрицательный ответ.
0
Лучшие ответы (1)
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
08.11.2020, 00:44
Ответы с готовыми решениями:

Как сделать вывод из textbox1 который находиться на Form2 в dataGridView1 который находиться на Form1
Доброго времени суток всем. возникла проблема как сделать вывод из textbox1 который находиться на...

Как сделать вывод из textbox1 который находиться на Form2 в dataGridView1 который находиться на Form1
Доброго времени суток всем. возникла проблема как сделать вывод из textbox1 который находиться на...

Каким должен быть файл и где он должен находиться?
Нашёл код, который берёт текстовый файл, читает его и выбирает слова, в которых есть такая же...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
7
Модератор
62552 / 46721 / 32203
Регистрация: 18.05.2008
Сообщений: 113,077
08.11.2020, 07:40 2
Лучший ответ Сообщение было отмечено Rimches как решение

Решение

алг
нач
вещтаб a[1:100]
цел N,i,k
вещ r,b

вывод "Введите количество деталей: "
ввод N
вывод нс,"Размеры деталей",нс
нц для i от 1 до N
a[i]:=10+rnd(5);
вывод a[i]:5:2," "
кц
вывод нс,"Введите стандартный размер детали:"
ввод r
Код
вывод нс,"Введите отклонение от стандартного размера детали:"
ввод b
k:=0;
нц для i от 1 до N 
если a[i]<b-r или a[i]>b+r то k:=k+1
все
кц
если k=0 то вывод "Бракованных деталей нет"
иначе вывод "Количество бракованных деталей="
вывод k
все

кон
1
Модератор
62552 / 46721 / 32203
Регистрация: 18.05.2008
Сообщений: 113,077
08.11.2020, 07:58 3
Поправил решение.
Pascal
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
алг 
нач
вещтаб a[1:100]
цел N,i,k
вещ r,b
нц
вывод "Введите количество деталей: "
ввод N
если N<1 или N>100 то вывод "Введите N от 1 до 100",нс
все
кц при N>=1 и N<=100
вывод нс,"Размеры деталей",нс
нц для i от 1 до N
a[i]:=10+rnd(5);
вывод a[i]:5:2," "
кц
вывод нс,"Введите стандартный размер детали:"
ввод r
вывод нс,"Введите отклонение от стандартного размера детали:"
ввод b
k:=0;
нц для i от 1 до N 
если a[i]<b-r или a[i]>b+r то k:=k+1
все
кц
если k=0 то вывод "Бракованных деталей нет"
иначе вывод "Количество бракованных деталей="
вывод k
все
 
кон
0
Супер-модератор
Эксперт Pascal/DelphiАвтор FAQ
30771 / 20102 / 7853
Регистрация: 22.10.2011
Сообщений: 34,927
Записей в блоге: 6
09.11.2020, 12:37 4
Что-то не так с генератором случайных чисел в КуМир-е:
0
Миниатюры
[КуМир] Пригодность детали оценивается по размеру В, который должен находиться в пределах значений от А - b до А + b  
Модератор
62552 / 46721 / 32203
Регистрация: 18.05.2008
Сообщений: 113,077
09.11.2020, 12:42 5
У меня вроде нормально
0
Миниатюры
[КуМир] Пригодность детали оценивается по размеру В, который должен находиться в пределах значений от А - b до А + b  
Супер-модератор
Эксперт Pascal/DelphiАвтор FAQ
30771 / 20102 / 7853
Регистрация: 22.10.2011
Сообщений: 34,927
Записей в блоге: 6
09.11.2020, 12:50 6
А у меня - нет. Хоть запускай с 5-ю значениями, хоть с сотней - всегда все одинаковые. Причем, даже после перезапуска компьютера значения одинаковые и ТЕ ЖЕ. Что-то не то. Никакого Randomize там, похоже, в принципе нет, а как заставить эту бредопрограмму взять не то же, а следующее значение - непонятно.
0
Модератор
62552 / 46721 / 32203
Регистрация: 18.05.2008
Сообщений: 113,077
09.11.2020, 13:01 7
Глупость конечно, но не может быть типа ?
Код
вывод a[1]:5:2," "
0
Супер-модератор
Эксперт Pascal/DelphiАвтор FAQ
30771 / 20102 / 7853
Регистрация: 22.10.2011
Сообщений: 34,927
Записей в блоге: 6
09.11.2020, 13:03 8
Ну, так я же запускал тот код, который приведен в 3-ем сообщении. Там, вроде, все нормально написано.
0
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.