Форум программистов, компьютерный форум, киберфорум
Другие языки программирования
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.54/13: Рейтинг темы: голосов - 13, средняя оценка - 4.54
0 / 0 / 0
Регистрация: 10.11.2020
Сообщений: 1
1

[КуМир] Заполнить массив из 10 элементов случайными числами в интервале [-10.10] и сделать реверс всех элементов

10.11.2020, 22:34. Просмотров 2559. Ответов 1
Метки нет (Все метки)

Добрый вечер,помогите пожалуйста решить задачу.

Заполнить массив из 10 элементов случайными числами в
интервале [-10..10] и сделать реверс всех элементов, кроме
последнего.


Пример:
Исходный массив:
-5 3 10 -4 -6 8 -10 1 0 4
Результат:
0 1 -10 8 -6 -4 10 3 -5 4
0
Лучшие ответы (1)
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
10.11.2020, 22:34
Ответы с готовыми решениями:

Заполнить массив из 10 элементов случайными числами и сделать реверс всех элементов, кроме первого
Пожалуйста, помогите решить вот эту задачу. Заполнить массив из 10 элементов случайными числами в...

Заполнить массив из 10 элементов случайными числами и сделать реверс всех элементов, кроме последнего
Пожалуйста, помогите решить вот эту задачу. 1) Заполнить массив из 10 элементов случайными...

Заполнить массив из 10 элементов случайными числами и сделать реверс отдельно для 1-ой и 2-ой половин массива.
Пожалуйста, помогите решить вот эту задачу. 3) Заполнить массив из 10 элементов случайными...

Заполнить массив случайными числами в заданном интервале и подсчитать отдельно среднее значение всех элементов
Заполнить массив случайными числами в интервале и подсчитайте отдельно среднее значение всех...

1
Модератор
62552 / 46721 / 32203
Регистрация: 18.05.2008
Сообщений: 113,077
11.11.2020, 07:21 2
Лучший ответ Сообщение было отмечено MironIS как решение

Решение

Код
алг 
нач
цел i,k
цел n=10
цел таб a[1:n]
вывод "Исходный массив",нс
нц для i от 1 до n
a[i]:=-10+int(rnd(21));
вывод a[i]:4
кц
нц для i от 1 до div(n-1,2)
k:=a[i]
a[i]:=a[n-i]
a[n-i]:=k
кц
вывод нс,"Реверс массива от 1 до n-1",нс
нц для i от 1 до n
вывод a[i]:4
кц
кон
1
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
11.11.2020, 07:21

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Заполнить массив из 12 элементов случайными числами и выполнить реверс для каждой трети массива
Пожалуйста, помогите решить вот эту задачу. Заполнить массив из 12 элементов случайными числами...

Заполнить массив из 10 элементов случайными числами в интервале
Заполнить массив из 10 элементов случайными числами в интервале и найти в нем 2 максимальных...

Заполнить массив из 10 элементов случайными числами в интервале [0.100]
Заполнить массив из 10 элементов случайными числами в интервале и отсортировать первую половину...

Заполнить одномерный массив из 25 элементов случайными числами в интервале [-20; 45]
Заполнить одномерный массив из 25 элементов случайными числами в интервале . Четные элементы...

Заполнить массив из 10 элементов случайными числами в интервале [-50..50] и отсортировать по убыванию
Заполнить массив из 10 элементов случайными числами в интервале и отсортировать по убыванию

Заполнить массив из 10 элементов случайными числами в интервале [-10..10] и отсортировать по убыванию
Заполнить массив из 10 элементов случайными числами в интервале и отсортировать по убыванию.


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.