Форум программистов, компьютерный форум, киберфорум
Другие языки программирования
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.54/13: Рейтинг темы: голосов - 13, средняя оценка - 4.54
0 / 0 / 0
Регистрация: 21.11.2020
Сообщений: 4
1

[КУМИР] Закрасить в каждом углу поля квадраты размером 2*2 клетки

01.12.2020, 19:25. Просмотров 2565. Ответов 3
Метки нет (Все метки)

Здравствуйте . Нужна помощь в выполнении Д/З . В тетради составить для Робота программу: Закрасить в каждом углу поля квадраты размером 2*2 клетки. Программа должна работать для любых размеров поля. Программа должна содержать структуры Цикл, Ветвление, вспомогательный алгоритм. Буду благодарен вам , если вы мне поможете.
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
01.12.2020, 19:25
Ответы с готовыми решениями:

В квадрате размером 4 х 4 клетки расставить 16 букв (по четыре буквы а, b, c, d) так, чтобы в каждом горизонта
В квадрате размером 4 х 4 клетки расставить 16 букв (по четыре буквы а, b, c, d) так, чтобы в...

[КуМир] Квадраты и кубы
Вывести квадраты и кубы 10 чисел следующей последовательности: 1, 2, 4, 7, 11, 16, …

Закрасить клетки в шахматном виде с помощью циклов
Random случайноеЧисло = new Random(); редактор = new...

Закрасить все клетки доски ходами коня
Пытаюсь решить такую задачу, вот что набросал уже clear; clc; n=input('Input quad size: ');...

3
Супер-модератор
Эксперт PythonЭксперт Java
6390 / 3643 / 1393
Регистрация: 21.10.2017
Сообщений: 10,524
01.12.2020, 19:35 2
Cheburash_, какая связь между кумиром и питоном?
0
0 / 0 / 0
Регистрация: 21.11.2020
Сообщений: 4
01.12.2020, 19:58  [ТС] 3
К сожалению я не знаю больше форумов , где бы помогли . Да, я понимаю ,что КУМИР и Python ни коим образом не связаны , но я лишь попросил помочь мне
0
Модератор
62540 / 46714 / 32197
Регистрация: 18.05.2008
Сообщений: 113,060
02.12.2020, 08:39 4
Код
использовать Робот
алг
нач
цел а
квадрат(1)
нц пока снизу не стена
вниз
кц 
вверх
квадрат(2)
вверх
нц пока справа не стена
вправо
кц 
влево
квадрат(3)
нц пока сверху не стена
вверх
кц
вправо
квадрат(4)
кон
|процедура закраски квадратов 2х2
алг квадрат(цел к)
нач
цел а
нц для а от 1 до 2
закрасить
если справа не стена то вправо все
кц
вниз
если к<3 то 
влево 
все
нц для а от 1 до 2
закрасить
если слева не стена то влево все
кц

кон
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
02.12.2020, 08:39

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Создать клеточное поле и закрасить в нем три клетки
я плохо знаком со windows forms.но дали задание: нарисовать поле(клеточное) 3*3(как массив 3*3 ток...

Клетки StringGrid, в которых четные числа закрасить красным, нечетные - синим цветами.
помогите решить) Заполнить StringGrid случайными натуральными числами. Клетки, в которых четные...

Заполнить таблицу n * n числами от 1 до n^2 и закрасить все квадраты
дана таблица n * n заполнить ее числами от 1 до n^2 и закрасить все квадраты.

Возможности пакета Awt. Не получается закрасить квадраты (лэйбл)
/* ЗАДАНИЕ: Две панели размещаются в строку. Левая панель предназначена для рисования...

[КуМир] Дана матрица размером 5×4. Поменять местами заданные столбцы с номерами n1 и n2
Здравствуйте. Помогите пожалуйста с задачей. Дана матрица размером 5×4. Поменять местами...

Построить и закрасить какими-либо цветами квадраты, заданные последовательностью a0, a1, a2, ., a3n-1
Даны натуральные числа n, a0, a1, a2, ..., a3n-1. Каждая тройка чисел ai, ai+1, ai+2, где i кратно...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.