Форум программистов, компьютерный форум, киберфорум
Войти
Регистрация
Восстановить пароль
Другие темы раздела
1С Загрузка Данных Из Терминала Сбора Данных В Требование-накладную Упп https://www.cyberforum.ru/ 1c/ thread2067145.html
В УПП 8.2 стандартно предусмотрена загрузка из терминала сбора данных в документ "ПоступлениеТоваровИУслуг". По этому образцу пытаюсь сделать загрузку в требование-накладную. Для этого в модуль формы...
1С Отчет .rcf
Здравствуйте! У меня такой вопрос, при создании макета для отчета .rcf получается одна колонка слишком широкая (наименование), и из за этого документ не помещается на лист А4! подскажите пожалуйста...
нестандартный автообмен 1С
1cv77 файловая + 3 периферийных организован автообмен в один из дней произошел сбой и группа документов не попала с периферии в центральную базу. дальше все восстановилось кроме не попавших в...
1С Запрос к табличной части Всем бодрого времени суток! Помогите новичку составить запрос. Есть документ "Закупка", в нём реквизит "Товар" (ссылается на справочник "Номеклатура") и табличная часть "СписокМагазинов" с... https://www.cyberforum.ru/ 1c/ thread2067142.html
1С Формирование табличной части https://www.cyberforum.ru/ 1c/ thread2067141.html
Формирование табличной части. Подскажите как можно в реквизиты табличной части добавить записи из справочника, чтобы в шапке таблицы был список из справочника. И подскажите литературу по 1с 8.2....
1С 1С 7.7 тис 964
Запустили базу 1 ноября - регистры были заполнены только ОстаткамиТМЦ и ПартиямиНаличие. Начали работу. существует на одного покупателя заявка от 1 числа, строка выписки банка от 1 числа, реализация...
срок действия Dll 1С
в проге 1С 7,7 есть самописная библиотека dll, так вот с 01.11.2010 года она перестала работать из-за этого вылазит куча ошибок как получилось я на компе поставил системное время на октябрь,...
1С Редактирование внешней печатной формы в 1С V7.7 День добрый всем спецам! Прошу помощи! Нужно чтобы во внешней печатной форме в столбце "ТМЦ" (в добавок к "наименованию") через пробел добавлялся артикул. Код обработки: https://www.cyberforum.ru/ 1c/ thread2067138.html
1С удаленный доступ к 1С 8.1 https://www.cyberforum.ru/ 1c/ thread2067137.html
Здравствуйте! Вопрос такого характера. Переходим на 1С:Предприятие 8.1 (8.1.13.41). Кто работал подскажите плиз. Как лучше подключить клиента (пользователя) если они расположены в разных городах....
1С 7.7 Не удаляется документ Добрый день! Хочу удалить из конфигурации старый документ, который уже не используется, но выдается сообщение: Данный объект использован в: Журнал.Реализация Журнал Реализация обычный, в... https://www.cyberforum.ru/ 1c/ thread2067136.html
otturkryy
20.05.2014, 16:39 0

Цикл Для Подсчета Записей В Таблице

20.05.2014, 16:39. Просмотров 7361. Ответов 10
Метки (Все метки)

Ответ

Цитата Сообщение от Vladal
Очень много кода.
Привел на всякий случай весь модуль.
А вот эта часть:


Результат = Запрос.Выполнить().Выбрать();

к = 1;
Пока Результат.Следующий() цикл

Область = Макет.ПолучитьОбласть("Строка2 ");
Область.Параметры.к1 = к;
Область.Параметры.ДокП = Результат.СсылкаДок;
Область.Параметры.СуммаДокП = Результат.СуммаДокумента;
Область.Параметры.ПациентП = Результат.Пациент;

ТабДок.Вывести(Область);

Если Флажок1 = Истина Тогда

ДокОб = Результат.ССылкаДок.ПолучитьОб ъект();
Для Каждого СтрТЧ из ДокОб.Услуги Цикл

Область = Макет.ПолучитьОбласть("Докумен ты");
Область.Параметры.УслугаП = СтрТЧ.Услуга;
Область.Параметры.СотрП = СтрТЧ.Сотрудник;
Область.Параметры.Специальност ьП = СтрТЧ.СпециализацияВрача;
Область.Параметры.ЦенаЗаУслП = СтрТЧ.Цена;

ТабДок.Вывести(Область);

КонецЦикла;
КонецЕсли;
к = к + 1;

КонецЦикла;
Где в цикле идет итоговый продсчет построчно, и увеличивается переменная k : можно ли использовать ЭТУ часть кода (считающую итоговую сумму по кокретному сотруднику) для счета и контрагентов по этому сотруднику, но на печать не выводить, а продублировать код в другую часть модуля, для искомого отчета, и так уже полученное значение выводить на печать ?

Вернуться к обсуждению:
Цикл Для Подсчета Записей В Таблице
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
20.05.2014, 16:39
Готовые ответы и решения:

Цикл для подсчета записей в таблице
Помогите добавить в код: Процедура Кнопка4 - формирует отчет исходя из: сотрудника и ведомого им...

Цикл для нумерации записей в таблице
Народ подскажите как написать цикл нумерации записей в таблице? Добавлено через 17 минут у меня...

Цикл по одной таблице и обновление соответствующих записей в другой
Всем привет!!! Вопрос наверное совсем новичковый ... нужно в цикле пройтись по записям таблицы А1...

Цикл для подсчета строк ф файле.
какой цикл надо задать чтобы из файла читалось столько строк сколько есть в файле..именно строк а...

10
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.