Форум программистов, компьютерный форум, киберфорум
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
Другие темы раздела
1С Расположение макетов Возник вопрос по поводу возможного расположения Макетов в программе. Нашел в коде следующую строку: Макет = ПолучитьМакет("mxl_МойМакет"); Где МойМакет - внешняя печатная форма. Откуда функция... https://www.cyberforum.ru/ 1c-custom/ thread2582164.html Как данные из СКД вывести в свой макет? 1С
Мне нужно из заказа покупателя вывести счет на предоплату, по сумме предоплаты указанной в договоре с контрагентом. Очень понравилось писать отчеты на CKД, без кода тяп ляп и отчет готов. Но вот...
1С Вывод на экран остатков https://www.cyberforum.ru/ 1c-custom/ thread2582079.html
Имеется регистр накопления, который сохраняет информацию о движении количества товаров на складе. Необходимо каким-то образом отобразить остатки в справочнике. Когда я искал на форуме информацию,...
1С Заголовки таблицы значений https://www.cyberforum.ru/ 1c-custom/ thread2581953.html
Есть массив строк Как сделать так, чтобы элементы этого массива стали заголовками (программно созданной) таблицы значений?
1С Оприходовать товар сразу на несколько складов
Приветствую спецы, возник вопрос в 1с 8.3 БП 3.0 (УФ), как можно сделать так. чтобы в документе "Поступление товаров" в поле склады можно было выбирать отбором в списке несколько нужных складов и...
1С Как в документообороте сформировать программно вордовский файл из шаблона и преобразовать в ПДФ Как? программно это все нужно https://www.cyberforum.ru/ 1c-custom/ thread2580746.html
1С 1С Предприятие, база данных с SQL https://www.cyberforum.ru/ 1c-custom/ thread2579965.html
Подскажите как и возможно ли подключить в 1С предприятие, написанную в SQL Server базу данных, чтобы написать на нее интерфейс?
1С Доработка кода SQL
Друзья, дико нужна помощь. Есть обработка которая вносит данные из excel в программу стек )расчет жкх) на базе sql Необходимо ее чутка доработать, чтобы вносились дополнительные данные добавленные...
1С Не срабатывает дополнительная обработка у бизнес события документооборот Или не срабатывают бизнес события создал обработчик для теста вот код, повесил его на изменение сохранение и регистрацию документа ЭИК_ОбращенияСервер.СОбытиеРегистрацияВходящегоДокумента... https://www.cyberforum.ru/ 1c-custom/ thread2579484.html 1С Уточнения по поводу срабатывания бизнес событий Докуметооборота Подскажите пожалуйста, как срабатывают бизнес события, вопросов три. Дело в том что у нас налаживается работа с документами как штатно - через 1С, так и удаленно через веб сервисы - создание,... https://www.cyberforum.ru/ 1c-custom/ thread2579374.html
Загрузка из txt в 1С 1С
Загружаю данные в справочник 1с из txt файла, всё весьма успешно, но реквизит "Специализация" заполняется из перечисления, и при загрузке все данные есть а специализация пусто &НаСервере...
1С Дублирование строк в табличной части справочника 1С ! Задача такая, есть табличная часть с двумя реквизитами, "Продукт" и "Количество", при добавление в табличную часть продукта необходимо проверять на наличие дублей и если таковы есть, то в уже... https://www.cyberforum.ru/ 1c-custom/ thread2579146.html
44 / 43 / 1
Регистрация: 11.07.2012
Сообщений: 1,024
10.02.2020, 23:00 0

Как принять параметр открываемой формы ? - 1С - Ответ 14243369

10.02.2020, 23:00. Показов 2467. Ответов 2
Метки (Все метки)

Ответ

вот пример от радченко, с передачей параметров из формы в форму
Листинг 8.222. Обработчик события нажатия кнопки «Подбор»
1C
1
2
3
4
5
6
&НаКлиенте
Процедура Подбор(Команда)
ПараметрыПодбора = Новый Структура("ТчТоваровДокумента", Объект.Товары);
ФормаПодбора = ОткрытьФорму("Документ.РасходнаяНакладная.Форма.ФормаПодбора",
ПараметрыПодбора, ЭтаФорма);
КонецПроцедуры
прием

Листинг 8.223. Обработчик события «ПриСозданииНаСервере»
1C
1
2
3
4
5
6
7
8
9
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
ТчТоваровДокумента = Параметры.ТчТоваровДокумента;
Для Каждого ТоварТч Из ТчТоваровДокумента Цикл
Элемент = ОтобранныеТовары.Добавить();
Элемент.Товар = ТоварТч.Товар;
Элемент.Количество = ТоварТч.Количество;
КонецЦикла;
КонецПроцедуры
может и в обычной форме сработает)

Вернуться к обсуждению:
Как принять параметр открываемой формы ? 1С
1
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
10.02.2020, 23:00
Готовые ответы и решения:

Как принять параметр-итератор в шаблоне функции?
Добрый день, знатоки! Чтобы набить руку, затеял наследование от класса std::vector. template...

Обратиться к элементу открываемой формы
Есть две формы: "Добавление товара" "Добавление характеристик" На форме "Добавление товара" есть...

Заполнять поле открываемой формы
Сделал кнопку на открытие формы на создании записи. При этом мне необходимо, чтобы одно из полей...

Задание позиции открываемой формы, относительно предыдущей
Суть: Есть Форма1, на ней расположено множество кнопок имеющих динамический размер и положение...

2
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
10.02.2020, 23:00
Помогаю со студенческими работами здесь

Как принять данные из формы по строкам
Есть поле <textarea></textarea> в него вводятся URLы, каждый строго с новой строки: site1.ru...

Как принять Post данные с формы
как принять данные на контролер с формы пост вот форма @using(var form =...

Как принять параметры из формы по номеру, а не по имени?
У меня тут проблема возникла (даже не одна): в одной ASP-страничке генерится форма с checkbox'ами,...

Как принять данные с формы, если name[phone][name]
Всем привет! Есть форма. Имя полей имеет следующий вид: name="name". Как с них принять с помощью...

0
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin
Copyright ©2000 - 2023, CyberForum.ru