Форум программистов, компьютерный форум, киберфорум
Другие языки программирования
Войти
Регистрация
Восстановить пароль
Другие темы раздела
Python Вычислить значение S при заданном n https://www.cyberforum.ru/ python-beginners/ thread2741570.html
1. Вычислить значение S при заданном n: S=1/1-1/2+1/3...±1/n 2. Вывести на экран для заданного n последовательность символов: + - * * - + и так по кругу.
Работа с файлами Python
У Меня есть файл например: секретарь Сентябрь 2019 Рабочий 3 Менеджер Август 2020 Специалист 5 Бухгалтер Февраль 2017 Руководитель 1 маркетолог июнь ...
Python Состояние гонки
Примеры кода читать, как если бы они были написаны на Пайтон? А то Джаву не знаю. https://ru.wikipedia.org/wiki/Состояние_гонки
Python Исполнение скрипта системой crop = subprocess.check_output("ffmpeg -i "+file+" -ss 10 -vf cropdetect -f null - 2>&1 | awk '/crop/ { print $NF }' | tail -1", shell=True).decode().strip() Запуская скрипт вручную, на выходе... https://www.cyberforum.ru/ python-beginners/ thread2741483.html
Python Парсинг портов https://www.cyberforum.ru/ python-beginners/ thread2741444.html
Добрый вечер, коллеги. Есть задача, написать скрипт, который бы смотрел кто подключился к порту, и вывел бы его ip адрес по возможноти с доменное имя компа. Что то типа утилиты ss или netstat. В...
циклические операторы Python
Решить с помощью циклических операторов. не используя функции math.factorial(n) Вычисление факториала рассмотреть 3 случая: при отрицательно значении n- нет решений, при n=0 факториал =1, при n >0...
Python Найди кота — 6
Найдите, в каких строках из введённых и в каком месте упоминается кот. Вместо явного цикла прохода по строке в цикле используйте подходящий метод строки. Формат ввода На первой строке вводится...
Python Трудность с кодировкой Привет помогите решить вопрос: у меня есть файл в utf-8 кодировке но русские буквы в нём записаны как коды пример: Зоопарк https://www.cyberforum.ru/ python-beginners/ thread2741431.html
Python Скобки https://www.cyberforum.ru/ python-beginners/ thread2741412.html
a = print(''.join(str(a))) Как сделать так, чтобы выводилось без квадратных скобок?
Python Пожалуйста напишите несколько простых программ Доступные языки: GNU C11 7.3 GNU c++17 7.3 Oracle Java 8 Free Pascal 3.0.0 PascalABC.NET 3.5.1 Python 3.7.3 https://i.ibb.co/GnJrWq5/3-2.jpg https://i.ibb.co/Zh4d6V0/3-3.jpg... https://www.cyberforum.ru/ python-beginners/ thread2741401.html
Python Выставка очень нехороших собак https://www.cyberforum.ru/ python-beginners/ thread2741399.html
.тевирП Есть вот такая задачка: В файле input.txt записаны данные о собаках, привезённых на выставку: кличка, возраст и порода каждой собаки. Нужно записать в файл output.txt данные о всех...
Python Орграф в виде количества вершин и последовательности дуг Задан орграф в виде количества вершин n<=10 и последовательности дуг (дуга задается парой “предшественник преемник”). а) Напечатать номера вершин, имеющих более двух преемников. б) Напечатать... https://www.cyberforum.ru/ python-beginners/ thread2741395.html
Модератор
62858 / 46905 / 32327
Регистрация: 18.05.2008
Сообщений: 113,651
02.12.2020, 08:39 0

[КУМИР] Закрасить в каждом углу поля квадраты размером 2*2 клетки

02.12.2020, 08:39. Просмотров 2968. Ответов 3
Метки (Все метки)

Ответ


Код
использовать Робот
алг
нач
цел а
квадрат(1)
нц пока снизу не стена
вниз
кц 
вверх
квадрат(2)
вверх
нц пока справа не стена
вправо
кц 
влево
квадрат(3)
нц пока сверху не стена
вверх
кц
вправо
квадрат(4)
кон
|процедура закраски квадратов 2х2
алг квадрат(цел к)
нач
цел а
нц для а от 1 до 2
закрасить
если справа не стена то вправо все
кц
вниз
если к<3 то 
влево 
все
нц для а от 1 до 2
закрасить
если слева не стена то влево все
кц

кон


Вернуться к обсуждению:
[КУМИР] Закрасить в каждом углу поля квадраты размером 2*2 клетки
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
02.12.2020, 08:39

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь или здесь.

Создать клеточное поле и закрасить в нем три клетки
я плохо знаком со windows forms.но дали задание: нарисовать поле(клеточное) 3*3(как массив 3*3 ток...

Клетки StringGrid, в которых четные числа закрасить красным, нечетные - синим цветами.
помогите решить) Заполнить StringGrid случайными натуральными числами. Клетки, в которых четные...

Заполнить таблицу n * n числами от 1 до n^2 и закрасить все квадраты
дана таблица n * n заполнить ее числами от 1 до n^2 и закрасить все квадраты.

Возможности пакета Awt. Не получается закрасить квадраты (лэйбл)
/* ЗАДАНИЕ: Две панели размещаются в строку. Левая панель предназначена для рисования...

[КуМир] Дана матрица размером 5×4. Поменять местами заданные столбцы с номерами n1 и n2
Здравствуйте. Помогите пожалуйста с задачей. Дана матрица размером 5×4. Поменять местами...

Построить и закрасить какими-либо цветами квадраты, заданные последовательностью a0, a1, a2, ., a3n-1
Даны натуральные числа n, a0, a1, a2, ..., a3n-1. Каждая тройка чисел ai, ai+1, ai+2, где i кратно...

0
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.