Форум программистов, компьютерный форум, киберфорум
Python: GUI, графика
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.89/9: Рейтинг темы: голосов - 9, средняя оценка - 4.89
0 / 0 / 0
Регистрация: 09.01.2021
Сообщений: 39
1

Pyscreeze.PyScreezeException: The Pillow package is required to use this function

10.01.2021, 22:01. Просмотров 1801. Ответов 4
Метки нет (Все метки)

Python
1
2
import pyautogui
print(pyautogui.locateOnScreen('1key.png'))
Traceback (most recent call last):
File "C:\Users\Vladimir\Desktop\Python\Script\testing.py", line 3, in <module>
print(pyautogui.locateOnScreen('1key.png'))
File "C:\Users\Vladimir\AppData\Local\Programs\Python\Python310\l ib\site-packages\pyautogui\__init__.py", line 175, in wrapper
return wrappedFunction(*args, **kwargs)
File "C:\Users\Vladimir\AppData\Local\Programs\Python\Python310\l ib\site-packages\pyautogui\__init__.py", line 213, in locateOnScreen
return pyscreeze.locateOnScreen(*args, **kwargs)
File "C:\Users\Vladimir\AppData\Local\Programs\Python\Python310\l ib\site-packages\pyscreeze\__init__.py", line 359, in locateOnScreen
screenshotIm = screenshot(region=None) # the locateAll() function must handle cropping to return accurate coordinates, so don't pass a region here.
File "C:\Users\Vladimir\AppData\Local\Programs\Python\Python310\l ib\site-packages\pyscreeze\__init__.py", line 134, in wrapper
raise PyScreezeException('The Pillow package is required to use this function.')
pyscreeze.PyScreezeException: The Pillow package is required to use this function.
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
10.01.2021, 22:01
Ответы с готовыми решениями:

Ошибка: e2202 required package 'vcl' not found
ошибка e2202 required package 'vcl' not found что делать?

Исправить ошибку: Required package 'bdertl' not found
Скачал проект на делфи из интернета, открываю с помощью XE8 и при запуске появляется следующая...

[Fatal Error] Required package 'lmdweb30_d7' not found
Программа работает нормально но только с Ехе файла а в делфи она не за пускается и выдает вот такую...

Установка Indy 10 на XE7, ошибка: Required package 'paclientcore' not found
Здравствуйте! Прошу у Вас совета (мучаюсь уже второй день). Устанавливаю сейчас indy 10 на...

4
Модератор
Эксперт Python
1322 / 821 / 305
Регистрация: 23.07.2018
Сообщений: 2,386
Записей в блоге: 1
11.01.2021, 09:08 2
Orang3, The Pillow package is required to use this function.
Для использования этой функции требуется пакет Pillow.
0
0 / 0 / 0
Регистрация: 09.01.2021
Сообщений: 39
11.01.2021, 09:18  [ТС] 3
DmFat, Я скачивал Pillow, при скачивании вылетала ошибка.
0
Модератор
Эксперт Python
1322 / 821 / 305
Регистрация: 23.07.2018
Сообщений: 2,386
Записей в блоге: 1
11.01.2021, 09:20 4
Orang3, да, и какая же?
0
0 / 0 / 0
Регистрация: 09.01.2021
Сообщений: 39
14.01.2021, 22:01  [ТС] 5
DmFat, Выскакивал красный текст, было очень много не понятных символов. Я принял решение просто откатить версию Python. Благодоря откату я смог загрузить Pillow.
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
14.01.2021, 22:01

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

cspin.h inline member function in package class
Как с эти бороться,куча warning сообщений появляется?Дело в классе самом?

Error 'a return expression required in a function with a block body'
Почему появляется данная ошибка и как ее исправить? Текст ошибки: a return expression required in a...

Eclipse. Package внутри package
Разбираюсь в Eclipse IDE 2019-06. Не могу понять как создать package внутри package как в...

Ссылка onclick="location.href" не поддерживает required? Чем заменить required?
Всем привет. Хотел реализовать переход с формы на другую страницу с помощью...

PIllow
помогите пожалуйста с установкой библиотеки Pillow. выскакивает вот такая ошибка что делать?где...

Заменитель Pillow
Имеется ли какая-то библиотека, которую можно использовать на замену Pillow? Нужны текстуры для...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.