Форум программистов, компьютерный форум, киберфорум
C++ Qt
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/7: Рейтинг темы: голосов - 7, средняя оценка - 5.00
3 / 3 / 1
Регистрация: 18.12.2014
Сообщений: 94
1

Никак не могу собрать драйвер под Postgresql

09.02.2016, 09:56. Просмотров 1325. Ответов 8
Метки нет (Все метки)


Помогите плз,
1 На винде версия Qt 5.4.1 mingw..,, почитал мануалы про то , чтобы пересобрать драйвер и получить либы , но там указана папка /src/... у меня таковой даже и нету, скопировал просто либы из plugins/sqldrivers в папку с проектом , нихрена та же ошибка , PSQL driver not loaded , + available drivers .....
2 На Linux Mint не могу вообще из репозитория скачать libqt5sql5-psql , тупо не находит(
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
09.02.2016, 09:56
Ответы с готовыми решениями:

Не могу никак собрать GDB
Делаю все по этому гайду http://qtlinux.narod.ru/make_gdb.htm На пункте четыре после ввода ...

никак не могу найти нормальный драйвер.
Ребят, такая же фигня( PCI\VEN_1102&DEV_0002&SUBSYS_80641102&REV_08...

Возможно ли собрать усб-драйвер под Win7 x64 в DriverStudio 3.2?
Compuware DriverStudio 3.2 позволяет создавать usb-драйвера под 64-битные ОС. Будут такие драйверы...

Никак не могу установить драйвер Realtek PCIe GBE Family Controller для сетевого адаптера
Никак не могу установить драйвер Realtek PCIe GBE Family Controller для сетевого адаптера. На...

8
486 / 364 / 94
Регистрация: 10.03.2011
Сообщений: 1,512
Записей в блоге: 5
09.02.2016, 10:04 2
1) Качаешь посгрю той же разрядности, что и собираемый проект. Прописываешь пути в системный path или в параметрах прожекта. Если не помогает, копируешь DLL'ки посгри и плагин драйвера.
0
576 / 386 / 145
Регистрация: 01.10.2015
Сообщений: 1,146
09.02.2016, 10:31 3
В 5 ветке плагин для PostgreSQL под Windows собирать не нужно, он есть "из коробки". Рядом с exe-файлом программы в структуре каталога сборки (не проекта) должен присутствовать каталог /plugins/sqldrivers, содержащий qsqlpsql.dll / qsqlpsqld.dll, и нужно скопировать из каталога установки PostgreSQL либы intl.dll, libeay32.dll, libpq.dll, ssleay32.dll, положить их рядом с вашим exe.
0
3 / 3 / 1
Регистрация: 18.12.2014
Сообщений: 94
09.02.2016, 11:12  [ТС] 4
положил все нужные либы, та же фигня (
0
486 / 364 / 94
Регистрация: 10.03.2011
Сообщений: 1,512
Записей в блоге: 5
09.02.2016, 11:18 5
Цитата Сообщение от icpu Посмотреть сообщение
Качаешь посгрю той же разрядности
Проверь.
0
3 / 3 / 1
Регистрация: 18.12.2014
Сообщений: 94
09.02.2016, 12:37  [ТС] 6
обе версии х32
0
486 / 364 / 94
Регистрация: 10.03.2011
Сообщений: 1,512
Записей в блоге: 5
09.02.2016, 12:45 7
Я понимаю, скорее всего очепятка, но
Цитата Сообщение от ZxcR Посмотреть сообщение
PSQL
db = QSqlDatabase::addDatabase("QPSQL","МоёИмяПодключенияДаНаКири лицеДаТакТожеМожноНетНеСлишкомДлинноеОйВсё");

На самом деле может быть куча разных причин, начиная от неправильных путей, когда в PATH записывают путь до lib, а не до корня посгри, и заканчивая тем, что из plugins/sqldrivers копировали в корень, а не в sqldrivers, или скопировали не из той сборки. С таким описанием, как у вас, вам не к нам, а к Вангам идти.
0
3 / 3 / 1
Регистрация: 18.12.2014
Сообщений: 94
09.02.2016, 13:00  [ТС] 8
C++ (Qt)
1
2
3
4
5
6
7
QSqlDatabase db = QSqlDatabase::addDatabase("QPSQL");
    qDebug()<<QSqlDatabase::drivers();
    db.setHostName("127.0.0.1");
    db.setDatabaseName("postgres");
    db.setUserName("postgres");
    db.setPassword("");
    bool ok = db.open();
C++ (Qt)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
QT       += core gui
QT       += sql
 
greaterThan(QT_MAJOR_VERSION, 4): QT += widgets
 
TARGET = bzd
TEMPLATE = app
 
 
SOURCES += main.cpp\
        mainwindow.cpp
 
HEADERS  += mainwindow.h
 
FORMS    += mainwindow.ui
Path я вообще не прописывал, да и не знаю куда и что именно((
0
486 / 364 / 94
Регистрация: 10.03.2011
Сообщений: 1,512
Записей в блоге: 5
09.02.2016, 13:25 9
http://www.oszone.net/6157 к примеру.
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
09.02.2016, 13:25

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь или здесь.

Никак не могу настроить D-Link DWL-2100AP под мои нужды:-(
В этом деле я новичёк, поэтому прошу помощи профессионалов. Перед тем как попасть на ваш форум я...

Boost 1.33.0: не могу собрать под Windows
Так сложилось, что потребовался именно boost 1.33.0. Bjam собрался, но почему то обозвался jam0....

Не могу собрать пример из STMF1cube / STemWin под uVision5
Господа, не могу разобраться с проблемой. Пытаюсь под Keil uVision5 собрать пример из STMF1cube /...

Не могу найти драйвер для видеокарты под windows 8, ATI Mobility Radeon x1600
Здравствуйте. Поставил на свой ноут 8ку. Не могу найти драйвер для видеокарты под 8ю винду. Видюшка...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
9
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.