0 / 0 / 0
Регистрация: 10.02.2013
Сообщений: 26
1

установка gem

06.09.2013, 17:10. Показов 1441. Ответов 1
Метки нет (Все метки)

часто случается когда пытаюсь установить какой либо gem вылетает ошибка например:
Bash
1
2
3
gem install authlogic
ERROR:  Error installing authlogic:
        activesupport requires Ruby version >= 1.9.3.
как решить? у меня ruby 1.8.7
__________________
Помощь в написании контрольных, курсовых и дипломных работ, диссертаций здесь
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
06.09.2013, 17:10
Ответы с готовыми решениями:

Установка gem sass локально
Сегодня впервые установил Ruby200-x64 под Win Не пойму как установить gem sass при условии что...

Не загружается ruby gem
хочу скачать ruby gem захожу на сайт откуда раньше скачивал https://rubygems.org/pages/download...

Не работает gem 'bcrypt-ruby' в Rails 4.0.0
У меня стоит Ruby 2 и Rails 4. Проблемы возникли с gem 'bcrypt-ruby'. При установке gem...

Добавление атрибутов к User(gem Devise)
подключить гем devise, установил все настройки сгенерировал User модель достал devise:view...

1
227 / 225 / 23
Регистрация: 30.01.2013
Сообщений: 720
06.09.2013, 17:12 2
Варианта 2:

1. Ставить все же 1.9.3 или уже 2.0 и наслаждаться новыми пакетами для нового интерпретатора Ruby
2. Искать версию authlogic ниже и старее, которая бы подошла под 1.8.7, делается это чтением релизов или методом перебора версий
1
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
06.09.2013, 17:12
Помогаю со студенческими работами здесь

Не могу установить gem json версии 1.7.7
Не могу установить json 1.7.7 в Rails 3.2.12. Использую Windows, в командной строке следующая...

ERROR: Failed to build gem native extension
Всем привет! Не так давно взялся за книгу Ruby on Rails Tutorial и на первых главах застрял с...

Не получается установить gem (и как следствие DevKit)
Помогите разобраться. Не получается установить gem gem install puma -v '2.11.3' Temporarily...

tar.gz установка gem' ов
Установка gem' ов. Скачал narray gem отсюда: https://rubygems.org/gems/narray При установке...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin
Copyright ©2000 - 2022, CyberForum.ru