Форум программистов, компьютерный форум, киберфорум
Turbo Pascal
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.83/6: Рейтинг темы: голосов - 6, средняя оценка - 4.83
-26 / 2 / 0
Регистрация: 05.12.2012
Сообщений: 113
1

Преобразовать в код

27.06.2016, 15:26. Показов 1106. Ответов 6

Данный алгоритм преобразовать в код

Код
цел таб A[1:5, 1:5] 
нц для i от 1 до 5 
 нц для j от 1 до 5 
 если i >= j то 
 A[i, j] := i - j 
 иначе A[i, j] := j - i 
 все 
 кц
кц

Заранее благодарен...
0

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Лучшие ответы (1)
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
27.06.2016, 15:26
Ответы с готовыми решениями:

Нашел код в интернете. Можно ли этот код из С++ преобразовать в язык программирования C#?
Нашел код в интернете можно ли этот код из С++ преобразовать в язык программирования C#. Язык...

Преобразовать двоичный код в двоично-десятичный код (Intel 8051)
Прочитать с порта Р0 один байт двоичного кода 8-4-2-1, превратить его в двоично-десятичный код и...

Преобразовать код на Java в код для ассемблера 3AA
переделать Java программу в программу 3AA все данные типа int for(int i = 0; i < 10; ++i) {...

Преобразовать код без функции в код с функцией
Дан вот такой код, нужно преобразовать его в код с функцией. Спасибо. PROGRAM TEST (INPUT,...

6
Модератор
64059 / 47474 / 32728
Регистрация: 18.05.2008
Сообщений: 115,185
27.06.2016, 15:36 2
А .то код, только в программе Кумир.
Код
алг первый алгоритм
нач
цел таб A[1:5, 1:5]
цел i,j 
нц для i от 1 до 5 
нц для j от 1 до 5 
если i >= j то 
A[i, j] := i - j 
иначе A[i, j] := j - i 
все 
кц
кц
кон
1
-26 / 2 / 0
Регистрация: 05.12.2012
Сообщений: 113
27.06.2016, 15:40  [ТС] 3
Цитата Сообщение от Puporev Посмотреть сообщение
А .то код, только в программе Кумир.

А можете перевести в Паскаль?
0
Модератор
64059 / 47474 / 32728
Регистрация: 18.05.2008
Сообщений: 115,185
27.06.2016, 15:41 4
Пожалуйста, только он не имеет смысла.
Pascal
1
2
3
4
5
6
7
8
var A:array[1..5, 1..5] of byte;
    i,j:byte;
begin
for i:=1 to 5  do
for j:=1 to 5 do
if i>=j then A[i,j]:=i-j
else A[i,j]:=j-i
end.
1
256 / 233 / 185
Регистрация: 02.04.2016
Сообщений: 898
27.06.2016, 15:43 5
Pascal
1
2
3
4
5
6
7
8
9
10
11
12
13
var a:array [1..5,1..5] of integer;
i,j:integer;
BEGIN
For i:=1 to 5 do
  For j:=1 to 5 do
  IF i >= j THEN a[i,j]:=i-j
            ELSE a[i,j]:=j-i;
For i:=1 to 5 do begin //и распечатка массива в подарок.
  For j:=1 to 5 do //
  Write (a[i,j],' ');//
Writeln;//
end;//
END.
1
-26 / 2 / 0
Регистрация: 05.12.2012
Сообщений: 113
27.06.2016, 15:44  [ТС] 6
Цитата Сообщение от Puporev Посмотреть сообщение
он не имеет смысла
Ну почему же он вроде должен создавать таблицу 5 на 5, а если подумать, да действительно, не имеет смысла.
0
Модератор
64059 / 47474 / 32728
Регистрация: 18.05.2008
Сообщений: 115,185
27.06.2016, 16:08 7
Лучший ответ Сообщение было отмечено kozlov как решение

Решение

Просто не надо умничать если нечем,а просто написать чтобы решили задачу.
Pascal
1
2
3
4
5
6
7
8
9
10
11
12
13
14
var A:array[1..5, 1..5] of byte;
    i,j:byte;
begin
for i:=1 to 5  do
 begin
  for j:=1 to 5 do
   begin
    if i>=j then A[i,j]:=i-j
    else A[i,j]:=j-i;
    write(A[i,j]:3);
   end;
  writeln;
 end;
end.
Добавлено через 2 минуты
Цитата Сообщение от kozlov Посмотреть сообщение
он вроде должен создавать таблицу 5 на 5,
Он и создает ее, только выводит фигу. Кстати в Кумире выводит только 2 последних элемента.

Добавлено через 21 минуту
Полностью в Кумире будет так
Код
алг

нач
цел таб A[1:5, 1:5]
цел i,j 
нц для i от 1 до 5 
нц для j от 1 до 5 
если i >= j то 
A[i, j] := i - j 
иначе A[i, j] := j - i
все
вывод A[i, j]," "
кц
вывод нс 
кц
кон
1
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
27.06.2016, 16:08

Преобразовать данный код в код с лямбда-выражениями
Как преобразовать данный код в код с лямбда-выражениями? (((( Не понимаю совсем using System;...

Преобразовать 16-ти разрядный двоичный код в код 8-4-2-1
Помогите пожалуйста составить программу для Intel 8051, которая преобразует 16-ти разрядный...

Wpf не виставляются нормально координати елипса && как преобразовать код xaml в код C#
собственно вот код программы using System; using System.Collections.Generic; using System.Linq;...

Преобразовать код из С++ в код Ассемблера
Прошу о помощи. В условии надо поменять местами первую четверть массива со второй, а третью с...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
7
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.