Форум программистов, компьютерный форум, киберфорум
Ubuntu, Mint Linux
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.96/26: Рейтинг темы: голосов - 26, средняя оценка - 4.96
0 / 0 / 0
Регистрация: 06.08.2014
Сообщений: 16
1

Недоступны стандартные репозитории

20.01.2015, 23:24. Показов 4653. Ответов 5
Метки нет (Все метки)

всем привет! поставил себе ubuntu 12, но возникают проблемы с установкой приложений.
в репозиториях нет даже google chrome. может нужно подключить какие-то другие? при выполнении команды apt-cache update логи показывают, что многие сервера недоступны.
0

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
20.01.2015, 23:24
Ответы с готовыми решениями:

Репозитории
Где взять репозитории для Ubunty. Не понимаю даже где их искать. Как добавить через терминал знаю,...

Репозитории для Ubuntu 8,10
установила не давно Ubuntu 8,10, не знала что этот релиз больше не поддерживается,репозитории...

Ubuntu 13 не получается загрузить репозитории и программы
sudo add-apt-repository ppa:nilarimogard/webupd8 sudo apt-get update sudo apt-get install...

В каком репозитории находится sun-java6-jre?
Хочу поставить aptana, для неё нужен sun-java6-jre. ГДе его найти? какой репозиторий??? ...

5
Эксперт по компьютерным сетямЭксперт NIX
12208 / 7077 / 724
Регистрация: 09.09.2009
Сообщений: 27,651
20.01.2015, 23:27 2
Цитата Сообщение от areva Посмотреть сообщение
нет даже google chrome
в дефолтных - нет, там только хромиум
Цитата Сообщение от areva Посмотреть сообщение
логи показывают, что многие сервера недоступны.
установите в настройках основной сервер вместо локальных зеркал
0
0 / 0 / 0
Регистрация: 06.08.2014
Сообщений: 16
20.01.2015, 23:43  [ТС] 3
Цитата Сообщение от Dmitry Посмотреть сообщение
установите в настройках основной сервер вместо локальных зеркал
я поставил main server вместо сервера РФ, это оно?

а вот я пытался установить google chrome из deb пакета

Код
root@alina-535U3C:/home/alina/Загрузки# dpkg -i google-chrome-39-0-2171-95-64-bits-multi-ubu.deb 
Selecting previously unselected package google-chrome-stable.
(Чтение базы данных ... на данный момент установлено 141836 файлов и каталогов.)
Распаковывается пакет google-chrome-stable (из файла google-chrome-39-0-2171-95-64-bits-multi-ubu.deb)...
dpkg: dependency problems prevent configuration of google-chrome-stable:
 google-chrome-stable зависит от libnss3 (>= 3.14.3), однако:
  Версия libnss3:amd64 в системе 3.13.1.with.ckbi.1.88-1ubuntu7.
 google-chrome-stable зависит от libxss1, однако:
  Пакет libxss1 не установлен.

dpkg: error processing google-chrome-stable (--install):
 проблемы зависимостей -- оставляем не настроенным
Обрабатываются триггеры для man-db ...
Обрабатываются триггеры для desktop-file-utils ...
Обрабатываются триггеры для bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Обрабатываются триггеры для gnome-menus ...
При обработке следующих пакетов произошли ошибки:
 google-chrome-stable
Добавлено через 6 минут
Код
root@alina-535U3C:/etc/default# apt-get install vim-nox
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Пакет vim-nox недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list

E: Для пакета «vim-nox» не найден кандидат на установку
root@alina-535U3C:/etc/default#
0
Эксперт по компьютерным сетямЭксперт NIX
12208 / 7077 / 724
Регистрация: 09.09.2009
Сообщений: 27,651
20.01.2015, 23:54 4
Цитата Сообщение от areva Посмотреть сообщение
это оно?
да
Цитата Сообщение от areva Посмотреть сообщение
а вот....
так вам черным по белому ж пишет:
Цитата Сообщение от areva Посмотреть сообщение
google-chrome-stable зависит от libnss3 (>= 3.14.3), однако:
* Версия libnss3:amd64 в системе 3.13.1
0
0 / 0 / 0
Регистрация: 06.08.2014
Сообщений: 16
21.01.2015, 00:10  [ТС] 5
при выполнении команды apt-get update куча ошибок, вот пара из них:

W: Не удалось получить http://archive.ubuntu.com/ubun... 4/Packages 404 Not Found [IP: 91.189.92.201 80]

W: Не удалось получить http://archive.ubuntu.com/ubun... 4/Packages 404 Not Found [IP: 91.189.92.201 80]

E: Некоторые индексные файлы не скачались. Они были проигнорированы или вместо них были использованы старые версии.

Добавлено через 1 минуту
Установить эти пакеты без проверки [y/N]? y
Ош http://archive.ubuntu.com/ubuntu/ quantal/main vim-runtime all 2:7.3.547-4ubuntu1
404 Not Found [IP: 91.189.91.14 80]
Ош http://archive.ubuntu.com/ubuntu/ quantal/main vim amd64 2:7.3.547-4ubuntu1
404 Not Found [IP: 91.189.91.14 80]
Не удалось получить http://archive.ubuntu.com/ubun... u1_all.deb 404 Not Found [IP: 91.189.91.14 80]
Не удалось получить http://archive.ubuntu.com/ubun... _amd64.deb 404 Not Found [IP: 91.189.91.14 80]
E: Невозможно получить некоторые архивы, вероятно надо запустить apt-get update или попытаться повторить запуск с ключом --fix-missing

Добавлено через 3 минуты
Починилось

sed -i 's/archive.ubuntu/old-releases.ubuntu/' /etc/apt/sources.list
0
Эксперт по компьютерным сетямЭксперт NIX
12208 / 7077 / 724
Регистрация: 09.09.2009
Сообщений: 27,651
21.01.2015, 00:12 6
беда в версии "quantal" убунты. Единственная актуальная "12-я" - это 12.04 - precise .
а quantal - это Ubuntu 12.10, поддержка которой уже прекращена и репозитории ее давно перемещены с "архив-убунту" на "олд-релизес-убунту"...
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
21.01.2015, 00:12

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Как подключить репозитории с нужными версиями пакетов?
Здравствуйте. Я немного недопонимаю действие официальных репозиториев Linux Mint! И так...

Про репозитории и пакеты - GNU/Linux. Заранее спасибо!
Репозиторий может содержать и всего один пакет, не обязательно тысячи, делается это для более...

После установки linux стали недоступны разделы с информацией
после установки linux слились в один все разделы диска. при этом сам линукс установился но...

Пропали многие стандартные программы! Такие, как Paint, стандартные игры
Пропали многие стандартные программы! Такие, как Paint, стандартные игры, перестал работать поиск,...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.