Форум программистов, компьютерный форум, киберфорум
Visual Basic .NET
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/3: Рейтинг темы: голосов - 3, средняя оценка - 5.00
0 / 0 / 0
Регистрация: 28.08.2017
Сообщений: 45
1

Нужно исправить формулу

27.04.2019, 13:13. Просмотров 542. Ответов 3

Привет всем. Я написал функцию на Visual Basic но думаю, что не правильно написал. Подскажите, что нужно исправить.
Кусок кода.
1)
Visual Basic
1
y = Math.Sqrt(Math.Abs(a * x + Math.Atan(c - Math.Tan(x) ^ Math.PI * x / 2))) / x * (a - b)
2)
Visual Basic
1
z = (Math.Abs(x + b) ^ (1 / c)) / Math.Log(a) * (Math.Abs(2 * x - b))
0
Миниатюры
Нужно исправить формулу  
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
27.04.2019, 13:13
Ответы с готовыми решениями:

Метод Монте-карло: исправить формулу
Dim image1 As New Bitmap(800, 800) Dim graph1 As Graphics = Graphics.FromImage(image1) ...

Нужно исправить формулу
Вот что нужно сделать А вот мой код =ЕСЛИ(B1<=0;0,8-0,1*(B1);4,756 LN(B1)+COS(B1)) Как нужно...

Нужно исправить формулу связанное с ЕСЛИ
Препод вузе сказала что нельзя писать два раза ЕСЛИ в формуле. Исправьте пожалуйста код.

Нужно исправить в 14 строке формулу чтобы ответ получился -2,341 при x=5 n=4
1.program summa; 2.var 3. q,x,y,s:real; 4. n,i,p,t:integer; 5.begin 6. writeln('x'); 7. ...

3
Модератор
6660 / 2655 / 514
Регистрация: 24.04.2011
Сообщений: 4,934
Записей в блоге: 10
27.04.2019, 17:30 2
Цитата Сообщение от Azizbacha Посмотреть сообщение
но думаю, что не правильно написал. Подскажите, что нужно исправить.
Всё не правильно. В VB6 нет такого Math.Sqrt, Math.Atan, Math.PI и т.п.
Вам или в другую тему, где изучают VB.NET, или скопировать в интернетах другой кусок кода, который соответствует VB6.
0
0 / 0 / 0
Регистрация: 28.08.2017
Сообщений: 45
27.04.2019, 17:32  [ТС] 3
Это Visual Basic 2010
0
Модератор
6660 / 2655 / 514
Регистрация: 24.04.2011
Сообщений: 4,934
Записей в блоге: 10
27.04.2019, 18:38 4
Цитата Сообщение от Azizbacha Посмотреть сообщение
Это Visual Basic 2010
Это VB.NET
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
27.04.2019, 18:38

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Нужно исправить в 14 строке формулу чтобы ответ получился -2,341 при x=5 n=4
1.program summa; 2.var 3. q,x,y,s:real; 4. n,i,p,t:integer; 5.begin 6. writeln('x'); 7. ...

Исправить формулу
Исходная формула: =CONCATENATE(,]) Однако поля @Year не существует. Есть поле Year. Нужно...

Исправить формулу
Есть задача : Я думал так : ...

Исправить формулу
Вот осваиваю для себя новый язык программирования: Есть формула (Во вложении) и кусок кода: ...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.