Форум программистов, компьютерный форум, киберфорум
VBA
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.67/6: Рейтинг темы: голосов - 6, средняя оценка - 4.67
1 / 1 / 0
Регистрация: 19.11.2010
Сообщений: 7
1

Формула по VBA

19.11.2010, 22:59. Показов 1057. Ответов 2
Метки нет (Все метки)

Кто подскажет буду благодарен
X и n вводятся с клавиатуры. Не могу сделать код под эту прогу.
Заранее спасибо.
0

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Миниатюры
Формула по VBA  
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
19.11.2010, 22:59
Ответы с готовыми решениями:

Формула в VBA
Всем доброго времени суток ! Ребят, помогите пожалуйста есть такое задание, пробую делать но никак...

Формула в функции vba
Здравствуйте. Пишу эту функцию в vba http://www.imagepost.ru/images/WNtTGfG2UoIE5EKXDltN.JPG ...

Формула log в vba
Помогите записать в vba - Log по основанию 1/2 (x^2-1) Когда пишу Log(x^2-1) выдает ошибку записи...

Формула разности VBA
Добрый день. Помогите написАть код VBA, который поместит в ячейку формулу, которая будет считать...

2
1605 / 1337 / 291
Регистрация: 25.10.2009
Сообщений: 3,487
Записей в блоге: 2
21.11.2010, 01:11 2
Наверное так
Visual Basic
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
Private Sub Form_Load()
Dim y As Single, x As Single, sum As Single, n As Single, i As Integer
x = InputBox("x")
n = InputBox("Количество слагаемых")
sum = 1 - x
For i = 2 To n
sum = sum + ((-1) ^ i * (x ^ i / fact(i)))
Next i
MsgBox sum
End Sub
Private Function fact(n As Integer) As Single
If n < 1 Then
fact = 1
Else
fact = n * fact(n - 1)
End If
End Function
1
1 / 1 / 0
Регистрация: 19.11.2010
Сообщений: 7
21.11.2010, 18:54  [ТС] 3
Огромное спасибо
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
21.11.2010, 18:54

Формула log в vba
Почему ему не нравится Log(x) и не дает запустить программу, удаляешь и все вполне работоспособно

Длинная формула VBA
Всем привет! Есть формула, которую надо смигрировать из Mathematica в VBA. Длина 8192 символа :)...

Формула ексель средствами VBA
Господа не могу вшить в код формулу: =ЕСЛИОШИБКА(ВПР($B24;Люди!B:E;4;0);&quot;уволен/переведен&quot;) ...

Почему результат не верен? Формула на VBA
Почему считает не правильно? Подскажите Private Sub CommandButton1_Click() Dim Q, O, t, n, t2,...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.