Форум программистов, компьютерный форум, киберфорум
C# Windows Forms
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.85/34: Рейтинг темы: голосов - 34, средняя оценка - 4.85
1 / 1 / 0
Регистрация: 23.05.2017
Сообщений: 141
1

Не удается установить пакет Nuget

22.04.2018, 15:33. Показов 6331. Ответов 6
Метки нет (Все метки)

Привет!

Для работы мне не обходимы следующие библиотеки:
OtpSharp;
Albireo.Base32;
--

Пытаюсь их установить через NuGet - вот что пишет -

"Не удалось установить пакет "Base32 1.0.0.26". Вы пытаетесь установить этот пакет в проект, требуемая версия платформы которого — ".NETFramework,Version=v4.5",
но в пакете нет объектов нужного типа (ссылки на сборки), совместимых с этой платформой. Дополнительные сведения можно получить у автора пакета."

На одном из форумов прочел, что можно попробовать изменить NETFramework в свойствах проекта с 4.5 на 4.5.2 - но проблема не исчезла.

А лишь изменилась ошибка

"Не удалось установить пакет "Base32 1.0.0.26". Вы пытаетесь установить этот пакет в проект, требуемая версия платформы которого — ".NETFramework,Version=v4.5.2",
но в пакете нет объектов нужного типа (ссылки на сборки), совместимых с этой платформой. Дополнительные сведения можно получить у автора пакета."

В чем может быть причина?
0

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
22.04.2018, 15:33
Ответы с готовыми решениями:

Не могу установить/удалить пакет NuGet: Элемент с тем же ключом был установлен
Пытаюсь установить ЛЮБОЙ пакет из NuGet, в Обозревателе решений видно, что идет установка:...

Как обновить загруженный NuGet пакет на nuget.org?
Как обновить загруженный NuGet пакет на nuget.org?

Не удаётся установить пакет libglu1-mesa-dev
У меня операционная система Ubuntu 16.10. До недавнего времени все программы нормально...

Как установить php5-iconv (не удаётся найти пакет)?
через apt-get никак :( apt-get install php5-iconv Чтение списков пакетов... Готово Построение...

6
4701 / 3245 / 1375
Регистрация: 09.05.2015
Сообщений: 7,961
22.04.2018, 15:56 2
В проект на .NET 4.7.1 пакет добавился без ошибок.
0
1 / 1 / 0
Регистрация: 23.05.2017
Сообщений: 141
22.04.2018, 17:20  [ТС] 3
Someone007, Установил. В настройках выставил 4.7.1. Пробую -
Не удалось установить пакет "Base32 1.0.0.26". Вы пытаетесь установить этот пакет в проект, требуемая версия платформы которого — ".NETFramework,Version=v4.7.1", но в пакете нет объектов нужного типа (ссылки на сборки), совместимых с этой платформой. Дополнительные сведения можно получить у автора пакета.

Не один, не другой пакет не может установиться. Не подскажете в чем может быть проблема, что я могу делать не верно.
0
4701 / 3245 / 1375
Регистрация: 09.05.2015
Сообщений: 7,961
22.04.2018, 17:37 4
Может у вас версия nuget старая? Какая у вас Visual Studio?
0
1 / 1 / 0
Регистрация: 23.05.2017
Сообщений: 141
22.04.2018, 17:38  [ТС] 5
Someone007, Тоже об подумал о старой версии Visual Studio. На данный момент 2012.
Уже Ставлю 2017.
0
0 / 0 / 0
Регистрация: 17.04.2017
Сообщений: 4
23.04.2018, 23:17 6
Подскажите, а в связи с блокировками роскомнадзора у вас проблем с доступом к nuget не возникало? Можно как-то их обойти без VPN, может есть какое-то зеркало ресурса?
0
1 / 1 / 0
Регистрация: 23.05.2017
Сообщений: 141
24.04.2018, 11:02  [ТС] 7
MPZ, Пока с этим проблем нету
P. s. Живу в Беларуси, но чувствую, у нас подобные меры не за горами

Добавлено через 1 минуту
Someone007, Да, предположение подтвердились - старая Visual Studio
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
24.04.2018, 11:02

Заказываю контрольные, курсовые, дипломные работы и диссертации здесь.

Переподключить пакет nuget
Привет! Использую Visual Studio. Через Управление пакетами NuGet... скачал и установил нужный...

Не могу обновить пакет Nuget
в окне Обновления нажимаю "Обновить" на пакете NuGet, скачивается, вроде бы устанавливается, и...

Пакет NuGet и компиляция проекта
Здравствуйте!!!! Есть проект, к нему добавлены NuGet пакеты:ClosedXML, ExcelDataReader. Запускают...

Почему NuGet-пакет успешно устанавливается, если нужной зависимости нет?
Имеем код: <?xml version="1.0" encoding="utf-8"?> <package > <metadata> ...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
7
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.