74 / 7 / 2
Регистрация: 15.11.2018
Сообщений: 72
1

Основы openWRT. Как настроить инет через PPTP

08.10.2021, 12:06. Показов 295. Ответов 3

Добрый день. Уважаемые знатоки поделитесь знаниями
Откопал старенький d-link 300 и захотелось что-нить с ним сделать... Перепрошил на openWRT. Поюзал интерфейс, немного в телнете полазил и понял, что ниче не понимаю.
Первым делом нужно поставить инет. Я конечно через вафлю подключил, пакеты кой-какие для РРТР поставил, но хочется завести его как полагается сразу с кабелем от провайдера.
Инет у меня стат ip выданный провайдером по РРТР шлюз днс в наличии

Код
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd97:7fee:bfa4::/48'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.2.1'
        option _orig_ifname 'eth0.1 wlan0-1'
        option _orig_bridge 'true'
        option ifname 'PPTP41 eth0.1'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr '00:26:5a:9e:mac'

config interface 'wan'
        option _orig_ifname 'eth0.2'
        option _orig_bridge 'false'
        option proto 'static'
        option ipaddr '192.168.**.**'
        option netmask '255.255.255.0'
        option gateway '192.168.**.***'
        option dns '192.168.254.241 192.168.254.240'
        option delegate '0'
        option ifname 'eth0.1'

config device 'wan_dev'
        option name 'eth0.2'
        option macaddr '00:26:5a:mac'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'rt305x'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'rt305x'
        option vlan '1'
        option ports '0 1 2 3 4 5 6t'

config switch_vlan
        option device 'rt305x'
        option vlan '2'
        option ports '6t'

config interface 'wwan'
        option proto 'dhcp'

config interface 'pptp41' - интерфейс РРТР который создал через морду
        option proto 'pptp'
        option server 'vpn...$$$$$$$'
        option username '***'
        option password '***'
        option delegate '0'
        option defaultroute '0'
В общих чертах вот такие настройки получились. Не вкурю что-куда и за что отвечает? каким местом мне прогонять трафик через интерфейс pptp
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
08.10.2021, 12:06
Ответы с готовыми решениями:

Инет VPN через локалку (PPTP)
раньше стояла XP скорость инета (скачки) была 16-15 кб\с поставил Windows 7 (WINDOWS 7 BUILD 7264...

Как настроить инет на 2 компа через DSL2540U?
Ситуация такая, есть 2 компа. Инет на одном компе (по локалке, VPN) и есть маршрутизатор DSL 2540U...

Win2003server настроить как сервер лицензий 1С 7.7 через инет
Имеется локалка, в которой есть 2 сервера. В интернет смотрит через роутер Dlink DI-804HV. Один из...

Как можно настроить сервер, чтобы к нему могли коннектиться через инет?
Как можно настроить сервер, чтобы к нему могли коннектиться через инет?

Prestigio Multipad PMP7280C3G DUO: как настроить инет через SIM карту ?
Вставили SIM-карту Beeline. Открываем браузер - пишет "Веб-страница не доступна". Настройки -->...

3
Эксперт по компьютерным сетям
3333 / 1811 / 386
Регистрация: 17.10.2015
Сообщений: 7,837
12.10.2021, 08:37 2
Цитата Сообщение от ram007 Посмотреть сообщение
пакеты кой-какие для РРТР поставил
а GRE? Поищи готовую сборку для подключения по РРТР к провайдеру. Наверняка есть в сети.
0
74 / 7 / 2
Регистрация: 15.11.2018
Сообщений: 72
13.10.2021, 23:21  [ТС] 3
GRE это про тунеллирование вроде как и тут не при делах.
Вариант поискать сборку не очень хорош тем, что не очень хочется превратить еще рабочую железку в пластиковый кирпичик.
И в целом тут после установки модуля надо только разобраться что куда, а вот с этим и есть проблема. Я вижу и понимаю, что тут все модули/интерфейсы разделены, но тупо не понимаю как направить трафик, те же vlan и pptp не имеют адреса, чтобы на него направить.
Да и задачка поучиться/поизучать в свободное время
0
Эксперт по компьютерным сетям
3333 / 1811 / 386
Регистрация: 17.10.2015
Сообщений: 7,837
14.10.2021, 07:56 4
Цитата Сообщение от ram007 Посмотреть сообщение
GRE это про тунеллирование вроде как и тут не при делах.
а РРТР - это не туннель?
Цитата Сообщение от ram007 Посмотреть сообщение
Вариант поискать сборку не очень хорош тем, что не очень хочется превратить еще рабочую железку в пластиковый кирпичик.
ну если между плеч голова, а не что то другое - ничего не превратиться в кирпичь. Вы жэе не первопроходец, в сети куча мануалов.
Цитата Сообщение от ram007 Посмотреть сообщение
надо только разобраться что куда,
Цитата Сообщение от ram007 Посмотреть сообщение
задачка поучиться/поизучать в свободное время
данное рвение приветствуется. Главное потом расписать всё тут для последующего, изучающего гранит науки, поколения.
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
14.10.2021, 07:56

Как настроить два ноутбука по wi fi для выходя в инет через один USB modem
Проблема в следующем: есть два бука с Win 7, есть один модем ЮСБ от МТС как настроить так что бы на...

Модуль ppp-mod-pptp в openwrt режет скорость
Здравствуйте, форумчане! У меня тут небольшая проблемка. В общем имею роутер tp-link tl-wdr3500...

TP-Link TL-WR740N v4.25, openwrt, PPTP/VPN. Не пробивается в интернет
Здравствуйте! Надеюсь на вашу помощь в настройке роутера TP-Link TL-WR740N 4.25 для раздачи...

Как настроить cron в OpenWrt?
в openwrt в /etc/crontabs ссоздал файл root с правами 775 в котором @reboot...

D-link DIR-620 D1 с прошивкой OpenWRT. Отсутствует выбор PPTP соединения
Всем привет. Перепрошил роутер (Dir-620 D1) в OpenWRT все бы хорошо, но когда создаешь новое...

Настроить инет на 2 ноутах через свич ASUS GX1005B
Вот задал на мэйле вопрос: "Интернет на двух ноутах через свитч ASUS GX1005B" "Вот по...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.