Форум программистов, компьютерный форум, киберфорум
1С: Администрирование и интеграция
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/15: Рейтинг темы: голосов - 15, средняя оценка - 5.00
0 / 0 / 0
Регистрация: 15.10.2013
Сообщений: 85
1

Подобие функции экселя ЧИСТВНДОХ в 1С

07.07.2014, 20:02. Показов 2921. Ответов 5
Метки нет (Все метки)

Добрый день.

Скажите пожалуйста. Есть ли готовая функция на подобие функции экселя ЧИСТВНДОХ ?

может кто-то знает алгоритм для 1С для такой функции?

искал в инете, но ничего путного не нашел.

Спасибо за ранее.

Добавлено через 2 часа 6 минут
нужно для рассчета эффективной процентной ставки.

http://docs.cntd.ru/document/902103615
0

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
07.07.2014, 20:02
Ответы с готовыми решениями:

Как сделать в аксессе подобие экселя:)?
Ситуация следующая. База генерит наклейки и выводит их на печать. Но за одну печать может быть...

функция ЧИСТВНДОХ или ананлоги к ней
1.Почему функция ЧИСТВНДОХ не работает в офисе 2010, а в 2003 вполне все здорово(предположение что...

Как сделать подобие функции rand на php ?
Привет, есть такая конструкция на php в которой js Как сделать эту конструкцию полностью на js ...

TextToColumns из Экселя в C#
Доброго времени суток. В макрорекодере написал макрос: Sub AD() Columns("J:J").Select ...

5
210 / 203 / 15
Регистрация: 29.05.2014
Сообщений: 1,054
08.07.2014, 01:21 2
нет. и не надо.
написать её - не так уж и сложно.
0
0 / 0 / 0
Регистрация: 15.10.2013
Сообщений: 85
08.07.2014, 08:13  [ТС] 3
Цитата Сообщение от wwall Посмотреть сообщение
нет. и не надо.
написать её - не так уж и сложно.
возможно и не сложно, но какая формула хоть для расчета будет ПСК? мне вот это интересно.
Не знаю от чего отталкиваться даже...
0
210 / 203 / 15
Регистрация: 29.05.2014
Сообщений: 1,054
08.07.2014, 09:29 4
- 5 ссылка отсюда http://yandex.ru/yandsearch?te... id=1923020

Добавлено через 1 минуту
сайт - www@****************@ru (замени @ на .)
0
0 / 0 / 0
Регистрация: 15.10.2013
Сообщений: 85
08.07.2014, 15:40  [ТС] 5
Получился такой код

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
Если ТаблицаДат.Количество() Тогда
        
        ПСК = 0.1;
        Пока ПСК < 1 Цикл
            
            Сумма = 0;
            Для Каждого ТекущаяДата Из ТаблицаДат Цикл
                
                РазностьДат = (НачалоДня(ТекущаяДата.Период) - НачалоДня(ТаблицаДат[0].Период)) / (24 * 60 * 60) / 365;
                Сумма = Сумма + ТекущаяДата.СуммаПлатежа / Pow(1 + ПСК, РазностьДат);
                
            КонецЦикла;           
            
            Если Окр(Сумма, 0) <> 0 Тогда
                ПСК = ПСК + 0.000001;
            Иначе
                Возврат Окр(ПСК * 100, 2, 1);
            КонецЕсли;
            
        КонецЦикла;       
        
    КонецЕсли;
только он не очень быстро выполняется
0
210 / 203 / 15
Регистрация: 29.05.2014
Сообщений: 1,054
08.07.2014, 16:32 6
Чуть быстре заработает если В таблицеДат будет приведено все к началу дня, и 24*60*60/365 на 236,712328767123287671232876712,

Добавлено через 50 секунд
кстати, проще завести колонку разность в ТЗ дат и туда положить результат расчета НачалоДня(ТекущаяДата.Период) - НачалоДня(ТаблицаДат[0].Период)
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
08.07.2014, 16:32

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Взаимодействие С и экселя
Народ, никто не сталкивался с извлечением данных из определенной ячейки? Чтобы потом в формуле...

Из Экселя в ворд
Доброго времени суток! ) Помогите пожалуйста дописать код... Sub ввв() Dim nVar1 As...

Закрытие экселя
Возник следующий вопрос: Когда я закрываю эксель файл, то файл закрывается, а окно экселя остаётся...

ПК для экселя и 1с
Добрый день. Нужны небольшие подсказки по сборке пк для офиса. Нанимаем аналитика данных, нужен...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.