Форум программистов, компьютерный форум, киберфорум
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/37: Рейтинг темы: голосов - 37, средняя оценка - 5.00
0 / 0 / 0
Регистрация: 19.08.2013
Сообщений: 19
1
1C 8.x (тонкий)

Расшифровка в отчете на скд

22.04.2014, 15:26. Просмотров 7103. Ответов 6
Метки нет (Все метки)

Необходимо сделать свою расшифровку. Для начала не могу добраться до значения ресурса.

функция ОбработатьРасшифровку(Расшифро вка, СтандартнаяОбработка, ОтчетОбъект, ФормаОтчета) Экспорт

ФормаОтчета.ДанныеРасшифровки. Элементы[Расшифровка].ПолучитьПоля()[0].Значение; - // не выдает значение по которому щелкаешь

КонецФункции
Отчет выглядит как во вложении 1. Настройки во вложении 2
0
Миниатюры
Расшифровка в отчете на скд   Расшифровка в отчете на скд  
Лучшие ответы (1)
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
22.04.2014, 15:26
Ответы с готовыми решениями:

СКД. Расшифровка. Программно
Необходимо вывести дополнительные поля при расшифровке, которых не было при работе отчета....

Расшифровка отчета на СКД
Добрый день.Есть отчет такого вида: Номенклатура|Характеристика|Цена|Количество. По клику на...

Расшифровка в отчете
Добрый день, не могу понять как в отчете, обычные формы, сделать расшифровку, чтобы при двойном...

Иерархия в отчете на скд
Здравствуйте, похожие темы уже точно тут обсуждались, но решения я так и не смогла найти. Есть...

6
21 / 21 / 3
Регистрация: 22.04.2014
Сообщений: 112
22.04.2014, 15:44 2
Лучший ответ Сообщение было отмечено AnStr как решение

Решение

AnStr,

Данные = ПолучитьИзВременногоХранилища( ДанныеРасшифровки);
РасшифровкаПоля = Данные.Элементы.Получить(Расши фровка).ПолучитьПоля()[0].Значение;


Так ты доберешься до значения ресурса
0
0 / 0 / 0
Регистрация: 19.08.2013
Сообщений: 19
22.04.2014, 16:47  [ТС] 3
Еще мне для расшифровки отчета необходимо открыть свою форму. Отчет внешний. Пробовала 2 способами, не работает. форма управляемая.
1. Форма = ПолучитьФорму("ВнешнийОтчет.Мо йОтчет.Форма.ФормаРасшифровкиП рогноза");
Форма.Открыть();
2. ОткрытьФорму("("ВнешнийОтчет.М ойОтчет.Форма.ФормаРасшифровки Прогноза")
что не так? беда просто...
0
21 / 21 / 3
Регистрация: 22.04.2014
Сообщений: 112
22.04.2014, 16:57 4
AnStr,

1C
1
2
3
4
5
6
7
8
&НаКлиенте
Процедура ОткрытьРасшифровку()
 
Параметры = новый структура;
 
ОткрытьФорму("ВнешнийОтчет.МойОтчет.Форма.ФормаРасшифровки Прогноза", параметры)
 
КонецПроцедуры
Где параметры - это структура и в неё ты можешь передать значения для расшифровки.
К примеру:
Параметры.Вставить("Должность" , "ГенеральныйДиректор") ;

И да чтобы открыть внешнюю форму, она должна быть на клиенте.
0
0 / 0 / 0
Регистрация: 19.08.2013
Сообщений: 19
22.04.2014, 17:11  [ТС] 5
У меня в модуле объекта отчета следующие процедуры:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
Процедура ПараметрыИсполненияОтчета() Экспорт 
    
    СтруктураНастроек = Новый Структура;
    СтруктураНастроек.Вставить("ДоработатьКомпоновщикПередВыводом", Истина);
        
    СтруктураНастроек.Вставить("ПроизвольнаяОбработкаРасшифоровки", Истина);
 
    УниверсальныйОтчет.УстановитьПараметрыИсполненияОтчета(СтруктураНастроек);
    
КонецПроцедуры
 
функция ОбработатьРасшифровку(Расшифровка, СтандартнаяОбработка, ОтчетОбъект, ФормаОтчета) Экспорт
    СтандартнаяОбработка = Ложь;
    МассивПолейРасшифровкиСРесурсами = ТиповыеОтчеты.ПолучитьМассивПолейРасшифровки(Расшифровка, ФормаОтчета.ДанныеРасшифровки, , Истина);
    
     ДотупноеПоле = Неопределено;
     Если МассивПолейРасшифровкиСРесурсами.Количество() > 0 тогда
         ДотупноеПоле = ТиповыеОтчеты.ПолучитьДоступноеПоле(Новый ПолеКомпоновкиДанных(МассивПолейРасшифровкиСРесурсами[0].Поле), ОтчетОбъект.КомпоновщикНастроек.Настройки.ДоступныеПоляВыбора);
     Иначе
         Возврат Неопределено;
     КонецЕсли;
     
     ДПоле = Строка(ДотупноеПоле.Поле);
 
     Если  ДПоле = "Прогноз" Тогда 
    ОткрытьФорму("ВнешнийОтчет.ПрогнозПерсоналаTotal.Форма.ФормаРасшифровкиПрогноза"); // не работает
     КонецЕсли; 
 КонецФункции
0
21 / 21 / 3
Регистрация: 22.04.2014
Сообщений: 112
22.04.2014, 17:18 6
AnStr,
Хм.. а формы отчета у вас нет? Все на СКД сделано?
0
0 / 0 / 0
Регистрация: 19.08.2013
Сообщений: 19
23.04.2014, 08:50  [ТС] 7
Да, формы нет...все на скд

Добавлено через 29 минут
Вот так открылось: ЭтотОбъект.ПолучитьФорму("Форм аРасшифровкиПрогноза").Открыть ()
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
23.04.2014, 08:50

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Запрос в отчете с СКД
У меня есть такой запрос: ВЫБРАТЬ МашинноеВремя.Дата КАК Дата, МашинноеВремя.Ссылка,...

Гиперссылка в отчете СКД
Здравствуйте. В отчете СКД вывожу путь к файлу в виде строки. Можно ли вывести путь в виде...

Использование расшифровки в отчете СКД
Есть отчет на СКД, хочу для полей данных открывать соответствующие формы объектов. В книге...

Группировка полей в отчете СКД
Здравствуйте. Делаю отчеты в СКД в собственной конфигурации. Столбцы в отчете: Объект, Договор,...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
7
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.