Форум программистов, компьютерный форум, киберфорум
Python: IDE, инструментарий
Войти
Регистрация
Восстановить пароль
 
0 / 0 / 1
Регистрация: 04.02.2017
Сообщений: 43
1

Как установить pip пакет для pynhon3.X

13.02.2020, 23:19. Просмотров 390. Ответов 3
Метки нет (Все метки)

На ubuntu установлено несколько версий python
Использую pycharm(python3.8). Пытался вызвать модуль graphics и понял,что нужно обновлять pip пакеты или устанавливать дополнительные модули. Пакет graphics загружен,но непонятно для какой версии python. Как обновлять пакеты pip и устанавливать дополнительные модули для определенной версии python,а именно python 3.8
Как использовать команду "python3.8 -m pip"
При вызове команды pip3 --version
pip 8.1.1 from /usr/lib/python3/dist-packages (python 3.5)
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
13.02.2020, 23:19
Ответы с готовыми решениями:

Pip не устанавливает пакет Faker
Добрый день! Подскажите, пожалуйста, в чем может быть проблема: пытаюсь установить пакет Faker...

Python3.7.2 как установить pip в CentOS7
Добрый день. Установлена ОС CentOS7. По умолчанию стоит python 2.7 Я установил python 3.7.2...

Как установить pip под линукс?
Добрый день. подскажите пожалуйста, как установить PIP под линукс? Ввожу apt-get install PIP и ...

Как установить пакет компонентов
Всем привет. В Borland Delphi 7 Решил установить пакет компонентов FastNet, скачал здесь ...

3
1241 / 636 / 354
Регистрация: 07.01.2019
Сообщений: 1,966
14.02.2020, 03:03 2
Цитата Сообщение от riomenx Посмотреть сообщение
Использую pycharm
Так через pycharm и устанавливайте

Добавлено через 6 секунд
Цитата Сообщение от riomenx Посмотреть сообщение
Использую pycharm
Так через pycharm и устанавливайте
0
Модератор
852 / 255 / 92
Регистрация: 23.03.2014
Сообщений: 1,560
14.02.2020, 13:03 3
написать в терминале, для нужной версии python
Код
python -m pip install --upgrade pip
0
0 / 0 / 1
Регистрация: 04.02.2017
Сообщений: 43
14.02.2020, 15:21  [ТС] 4
Кликните здесь для просмотра всего текста
python3.8 -m pip install --upgrade pip
Traceback (most recent call last):
File "/usr/lib/python3.8/runpy.py", line 184, in _run_module_as_main
mod_name, mod_spec, code = _get_module_details(mod_name, _Error)
File "/usr/lib/python3.8/runpy.py", line 143, in _get_module_details
return _get_module_details(pkg_main_name, error)
File "/usr/lib/python3.8/runpy.py", line 110, in _get_module_details
__import__(pkg_name)
File "/usr/lib/python3/dist-packages/pip/__init__.py", line 14, in <module>
from pip.utils import get_installed_distributions, get_prog
File "/usr/lib/python3/dist-packages/pip/utils/__init__.py", line 23, in <module>
from pip.locations import (
File "/usr/lib/python3/dist-packages/pip/locations.py", line 9, in <module>
from distutils import sysconfig
ImportError: cannot import name 'sysconfig' from 'distutils' (/usr/lib/python3.8/distutils/__init__.py)


Добавлено через 30 минут
Пакеты pip устанавливается по пути
1) / home/akm/.local/lib/python3.5/site-packages
2)/home/air/.local/lib/python2.7/site-packages
интерпретатор python3.8 находится по путиz: /usr/lib/python3.8
Я так понимаю,что есть какие то проблемы с зависимостями python и установкой pip.

Добавлено через 28 минут
Решил проблему благодаря официальному источнику:https://pip.pypa.io/en/stable/installing/
Чтобы установить pip, безопасно загрузите: curl https://bootstrap.pypa.io/get-pip.py -o get-pip.py
Затем: python3.8 get-pip.py
Спасибо. Как всегда форум помог)

Добавлено через 14 минут
Установка модуля graphics: pip3.8 install graphics.py
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
14.02.2020, 15:21

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Как установить пакет .deb?
timur@timur-R50-R51:~$ sudo dpkg -i /home/Desktop/Debian/cmotech-qtmodem_1.8_all.deb dpkg: не...

Как установить пакет iterate?
Всю жизнь велосиперничал, но тут захотелось iterate, cffi, tk/tcl - ничего из этого я сделать,...

Как в Denwer установить пакет?
Запускаю c:\WebServers\usr\local\perl\bin\ppm.bat, устанавливаю там XML-RSS-Parser, перезапускаю...

Как установить пакет в виртуальное окружение?
Делаю так: virtualenv .virtualenv ln -s .virtualenv/bin/activate source activate Дальше...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.