0 / 0 / 0
Регистрация: 12.07.2014
Сообщений: 3
1

Gem::Installer::ExtensionBuildError

13.07.2014, 00:01. Показов 1069. Ответов 5
Метки нет (Все метки)

После команды
Код
sudo rails new blog
генерируется структура каталогов.
Ив конце выдает ошибку.
Код
Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension.

        /usr/bin/ruby1.9.1 extconf.rb 
/usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot load such file -- mkmf (LoadError)
        from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
        from extconf.rb:1:in `<main>'

Gem files will remain installed in /var/lib/gems/1.9.1/gems/json-1.8.1 for inspection.
Results logged to /var/lib/gems/1.9.1/gems/json-1.8.1/ext/json/ext/generator/gem_make.out
An error occurred while installing json (1.8.1), and Bundler cannot continue.
Make sure that `gem install json -v '1.8.1'` succeeds before bundling.
вроде нашел вариант исправления.
Код
$ gem install <ruby gem name> — —with-ruby-include=$rvm_path/src/<ruby version>
Но понять что пистаь в <ruby gem name> немогу?
Спсибо.
__________________
Помощь в написании контрольных, курсовых и дипломных работ, диссертаций здесь
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
13.07.2014, 00:01
Ответы с готовыми решениями:

Посоветуйте gem
Хочу написать англо-русский переводчик, посоветуйте какой gem выбрать, чтобы пользоваться API, гугл...

Gem i jekyll - ошибка
Хочу попробовать Jekyll. Для его работы нужно установить Ruby, с которым я дел до сих пор не имел....

Ошибка установки gem'a
Пытаюсь установить ruby-audio 1.6.1.( linux mint 15 ). Помогите, пожалуйста, найти ошибку... # gem...

tar.gz установка gem' ов
Установка gem' ов. Скачал narray gem отсюда: https://rubygems.org/gems/narray При установке...

5
2 / 2 / 0
Регистрация: 16.12.2012
Сообщений: 14
13.07.2014, 07:48 2
Это обычные зависимости походу. На момент написания поста у Вас "Gem" JSon 1.8.1 установлен?
0
0 / 0 / 0
Регистрация: 12.07.2014
Сообщений: 3
13.07.2014, 10:29  [ТС] 3
gem list - показывает что нет JSon 1.8.1
0
227 / 225 / 23
Регистрация: 30.01.2013
Сообщений: 720
13.07.2014, 11:38 4
чем и хороша Ruby инфраструктура, что она в каждой ошибке подсказывает, что надо сделать дальше, чтобы исправить. Вот и в вашем случае все же написано, просто читайте ошибки:

Make sure that `gem install json -v '1.8.1'` succeeds before bundling.
0
0 / 0 / 0
Регистрация: 12.07.2014
Сообщений: 3
13.07.2014, 19:56  [ТС] 5
Я установил
Код
$ gem install json -v '1.8.1'
Fetching: json-1.8.1.gem (100%)
Building native extensions.  This could take a while...
Successfully installed json-1.8.1
Parsing documentation for json-1.8.1
Installing ri documentation for json-1.8.1
Done installing documentation for json after 1 seconds
1 gem installed
Но ошибка всеравно вылазит.
И почему gem list не показывает json-1.8.1 в установленном?

Добавлено через 8 часов 0 минут
Скажите, права на дирректорию приложения и файлы какие нужно ставить,
или это не имеет значения?
0
2 / 2 / 0
Регистрация: 16.12.2012
Сообщений: 14
20.07.2014, 21:18 6
Цитата Сообщение от Vorobey Посмотреть сообщение
И почему gem list не показывает json-1.8.1 в установленном?
"Гугли" на google.ru : "Установка json rails" и "Install json rails".

В дальнейшем будь готов, что с установками компонентов в RoR, да и вообще в любом другом "фреймворке" могут возникнуть проблемы.

Что выдаёт "gem list"?
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
20.07.2014, 21:18
Помогаю со студенческими работами здесь

Could not find a valid gem
Собственно, как решить проблему? Перерыл гугл, толком ничего не нашел. Заранее спасибо!

Отправка почты через gem mail
собственно есть код require 'rubygems' require 'mail' smtp = { :address =&gt;...

Установка гемов - ERROR: Could not find a valid gem 'tk' (>= 0)
Привет, друзья. Задумался значит я поставить себе гем tk, чтобы попрактиковаться в создании...

Как загрузить gem в среду RubyMine 2016
Дело в том что в этой версии нет кнопки install Gem, которые были в предыдущих. А в списке имеются...

Gem::InstallError: rubyzip requires Ruby version >= 1.9.2
Добрый вечер! Изучаю Ruby on Rails Tutorial Michael Hartl. В 3-ей главе на установке $ bundle...

установка gem
часто случается когда пытаюсь установить какой либо gem вылетает ошибка например: gem install...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin
Copyright ©2000 - 2022, CyberForum.ru