Форум программистов, компьютерный форум, киберфорум
VBA
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.67/3: Рейтинг темы: голосов - 3, средняя оценка - 4.67
0 / 0 / 0
Регистрация: 28.05.2013
Сообщений: 43
1

Нужно, чтобы в поле V формула считала при условии что в поле M стоит 0

22.06.2015, 15:15. Показов 582. Ответов 14
Метки нет (Все метки)

привет
нужно, чтобы в поле V формула считала при условии что в поле M стоит 0
в противном случае складывает значения из поля A
моя формула =ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(T13;$D$7:$D$21;0));СУММЕСЛИ($D$7:$D$21 ;T13;$A$7:$A$21)+0;0)
суммирует все значения из поля А, а надо чтобы исключались те, где в поле М не равно 0
спасибо

Добавлено через 1 минуту
вроде прицепил файл, только не вижу где он, странно

Добавлено через 3 минуты
не пойму как файл поместить сюда. при создании темы нажимал на скрепку и грузил нужный файл, а сейчас вот скрепка пропала и файла тоже нет, что не так делаю?
__________________
Помощь в написании контрольных, курсовых и дипломных работ здесь
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
22.06.2015, 15:15
Ответы с готовыми решениями:

Что нужно сделать, чтобы в запросе при выводе в новую таблицу поставилось отдельное поле счетчик?
Что нужно сделать чтобы в моем запросе при выводе в новую таблицу поставилось отдельное поле...

Неправильно отрабатывает запрос при условии что текстовое поле Is Null
Добрый вечер, есть запрос который делает выборку данных с таблицы при условии что текстовое...

Есть форма, на ней поле и кнопка, при запуске программы в поле нужно ввести число и если оно 87, то открывается другое окно.
вобщем мне нужно зделать такую программу: есть форма, на ней поле и кнопка, при запуске программы в...

Нужно чтобы в PHP текст убирался в поле при клике на него
Делаю форму отправки сообщений нужно чтобы когда пользователь кликнет в поле текст в нём убирался и...

14
Супер-модератор
Эксперт Pascal/DelphiАвтор FAQ
31465 / 20512 / 7988
Регистрация: 22.10.2011
Сообщений: 35,628
Записей в блоге: 7
22.06.2015, 15:17 2
Много времени прошло между загрузкой файла и публикацией сообщения.
0
0 / 0 / 0
Регистрация: 28.05.2013
Сообщений: 43
22.06.2015, 15:19  [ТС] 3
и как мне залить сюда нужный файл?
0
Супер-модератор
Эксперт Pascal/DelphiАвтор FAQ
31465 / 20512 / 7988
Регистрация: 22.10.2011
Сообщений: 35,628
Записей в блоге: 7
22.06.2015, 15:21 4
Просто залить файл (через скрепку) и сразу нажать на "Ответить", а не через 5+ минут после того, как файл был загружен.
0
0 / 0 / 0
Регистрация: 28.05.2013
Сообщений: 43
22.06.2015, 15:23  [ТС] 5
дык нету скрепки ведь!
0
0 / 0 / 0
Регистрация: 28.05.2013
Сообщений: 43
22.06.2015, 15:25  [ТС] 6
вот
Вложения
Тип файла: xlsx tmp.xlsx (23.2 Кб, 3 просмотров)
0
0 / 0 / 0
Регистрация: 28.05.2013
Сообщений: 43
23.06.2015, 11:05  [ТС] 7
посоветуйте!
0
323 / 49 / 28
Регистрация: 07.09.2014
Сообщений: 217
23.06.2015, 11:31 8
Предполагаю, что вы запутались с аргументами СУММЕСЛИМН. Еще раз взгляните в каком порядке они должны быть. Если я правильно понял вашу задачу, должно получиться что-то вроде =ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(T14;$D$7:$D$21;0));СУММЕСЛИМН($A$7:$A$ 21;$D$7:$D$21;T14;$M$7:$M$21;"0")+0;0)
0
3486 / 2137 / 713
Регистрация: 02.11.2012
Сообщений: 5,602
23.06.2015, 11:35 9
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(T14;$D$7:$D$21;0));СУММПРОИЗВ(($D$7:$D$21=T14)*($M$7:$M$21=0)*$A$7:$A$21);0)
а при чем здесь VBA?
зачем +0 после СУММЕСЛИ?
0
0 / 0 / 0
Регистрация: 28.05.2013
Сообщений: 43
23.06.2015, 13:20  [ТС] 10
не работает ваша формула, не считает.
моя правильно подсчитывает, но не исключает из суммы (столбец А) те значения, которые в столбце М равны 0
то что я с аргументами промахнулся верно, потому и прошу помочь, не получается правильно выстроить порядок следования этих самых аргументов/условий.

строго говоря, мне даже не суммировать надо, а просто найти значение в столбце А которое соответствует значению в столбце D при условии, что в той же строке в столбце М стоит 0

Добавлено через 5 минут
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(T14;$D$7:$D$50000;0));СУММЕСЛИМН($D$7: $D$50000;T14;$A$7:$A$50000;$M$7:$M$50000;"0")+0;0)
так попробовал - не получается
0
323 / 49 / 28
Регистрация: 07.09.2014
Сообщений: 217
23.06.2015, 13:23 11
old, И снова в последнем варианте вашей формулы в СУММЕСЛИМН у вас идет(Диапазон суммирования, условие 1, диапазон условия 1, диапазон условия 2, условие 2). Исправьте
0
3486 / 2137 / 713
Регистрация: 02.11.2012
Сообщений: 5,602
23.06.2015, 13:31 12
Цитата Сообщение от old Посмотреть сообщение
исключались те, где в поле М не равно 0
Цитата Сообщение от old Посмотреть сообщение
исключает из суммы (столбец А) те значения, которые в столбце М равны 0
Вы сами себе противоречите.
0
0 / 0 / 0
Регистрация: 28.05.2013
Сообщений: 43
23.06.2015, 13:33  [ТС] 13
нет противоречия: над считать те, которые в столбце М равны 0 (исключать те которые не равны 0)
0
3486 / 2137 / 713
Регистрация: 02.11.2012
Сообщений: 5,602
23.06.2015, 13:37 14
Цитата Сообщение от old Посмотреть сообщение
нет противоречия:
внимательней у вас в обоих случаях использовалось слово исключить.
Код
=ЕСЛИОШИБКА(ПРОСМОТР(2;1/(($D$6:$D$22=T11)*($M$6:$M$22=0));$A$6:$A$22);0)
0
0 / 0 / 0
Регистрация: 28.05.2013
Сообщений: 43
23.06.2015, 15:15  [ТС] 15
решение нашел вроде:

=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(T18;$D$6:$D$50000;0));СУММЕСЛИМН($A6:A $50000;$D$6:$D$50000;T18;$M$6:$M$50000;"0")+0;0)

всем спасибо
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
23.06.2015, 15:15

Как сделать, что бы при нажатие кнопки заполнялось только выделенное поле(в котором стоит курсор)?
ммммм есть 10 кнопок- соответствующие цифрам {0-9} и три текстовых поля...Как сделать, что бы при...

Нужно чтобы при выборе radio сразу изменялось значение в поле input
Нужно чтобы при выборе radio сразу изменялось значение в поле input В данный момент есть radio ...

Что нужно добавить в программу чтобы она считала еще и количество слов?
program lab_8; uses crt; {подключаем модуль crt} const s:...

Подстановка значения в текстовое поле при условии
Есть форма: Использует два выпадающих списка: Производитель и Винтовой блок. Подскажите...

Есть два текстовых поля и две кнопки. Нужно, чтобы при нажатии клавиши Enter при фокусе ввода в любом текстовом поле срабатывала первая кнопка.
Есть два текстовых поля и две кнопки. Нужно, чтобы при нажатии клавиши Enter при фокусе ввода в...

Что нужно дописать, чтобы в самой консоли при запуске программы выводилась формула, по которой считается х
Программа сделана для расчета функции по введенному значению х. Вот сама программа: using...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
15
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin
Copyright ©2000 - 2022, CyberForum.ru