Форум программистов, компьютерный форум, киберфорум
Наши страницы
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
Рейтинг: Рейтинг темы: голосов - 43, средняя оценка - 4.65
gavrichenko
7 / 7 / 3
Регистрация: 20.07.2012
Сообщений: 132
#1

Реализовать шифрование и дешифрование текста по шифру Атбаш - MS Excel

01.10.2012, 20:29. Просмотров 6289. Ответов 10
Метки нет (Все метки)

Здравствуйте уважаемые профессионалы. Нужно организовать шифрование и дешифрование текста по шифру Атбаш. Кто незнаком с этим шифром, то вот цитатка. Помогите пожалуйста с оранизацией его в Excel. Хотя бы подскажите с помощью каких функций это можно сделать.

Развернуть и ознакомиться
Атбаш можно считать шифром сдвига на всю длину алфавита или того числа символов, которые представлены к замене. Это простая замена для двух статических алфавитов.
Возьмем два алфавита, один из которых написан наоборот:

АБВГДЕЁЖЗИЙКЛМНОПРСТУФХЦЧШЩЪЫЬЭЮЯ
ЯЮЭЬЫЪЩШЧЦХФУТ С Р ПОНМЛКЙИ ЗЖЁ Е ДГВ Б А

Вы видите, взаимное соответствие букв, которые заменяют друг друга.

Закодировать сообщение этим шифром очень простою
Возьмем текст:

Широкое поле

Получаем перевод ---> ЖЦОРФРЪ ПРУЪ

Шифр атбаш был использован в Библии, в Ветхом завете. Слово Вавилон там иногда пишут как Сесах (или Шешах).

На иврите Вавилон пишется буквами "бет", и "ламед" ( на английском это beth, beth и lamed, что соответствует согласным буквам в слове Babel - Вавилон). При шифровании атбашем вторая в алфавите буква "бет" заменяется предпоследней в алфавите буквой "шин" (shin), а двенадцатая с начала буква "ламед" - двенадцатой с конца буквой "каф". Таким образом, после всех переводов с языка на язык было выяснено, что в тексте Библии слово Сесах (Шешах) обозначает Вавилон.

Название Атбаш и само даёт подсказку, как работает этот шифр. В еврейском алфавите слово "атбаш" состоит из двух первых и двух последних букв алфавита: алеф(а), таб(т), бет(б), шин(ш).

0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
01.10.2012, 20:29
Я подобрал для вас темы с готовыми решениями и ответами на вопрос Реализовать шифрование и дешифрование текста по шифру Атбаш (MS Excel):

Шифрование и дешифрование сообщения по шифру Цезаря
Подобрать ключ и расшифровать сообщение: мсштфрдъмтссдвгейлтудхстчц_

Шифрование текста (методы Атбаш и Цезаря)
Помогите плиз решить задачку на Delphi. Составьте программу для шифрования...

Реализовать "шифрование" и "дешифрование" текста переставляя два подряд идущих символа местами
5.Вся обработка текста должна быть основана на регулярных выражениях. ...

Шифрование и дешифрование текста
Народ вот програма для шифрования текста мне нужно переделать так штоб били...

Реализовать шифрование и дешифрование шифром Вернама
Разработать алгоритмы шифрования и дешифрования блока (потока) открытого текста...

Как реализовать шифрование и дешифрование Xor?
Как реализовать шифрование и дешифрование Xor в питоне

10
Pelena
2435 / 1226 / 207
Регистрация: 25.10.2010
Сообщений: 1,971
01.10.2012, 20:42 #2
Как вариант, написать рядом два алфавита и использовать функции ИНДЕКС и ПОИСКПОЗ
0
gavrichenko
7 / 7 / 3
Регистрация: 20.07.2012
Сообщений: 132
01.10.2012, 20:47  [ТС] #3
а если в строке одна буква будет повторяться несколько раз? цикла не надо?
0
Pelena
2435 / 1226 / 207
Регистрация: 25.10.2010
Сообщений: 1,971
01.10.2012, 20:56 #4
Я предполагала решение формулами, какой там цикл?

Может я неправильно поняла: текст как будет организован? Я предположила, что в каждой ячейке одна буква?
Приложите пример
0
gavrichenko
7 / 7 / 3
Регистрация: 20.07.2012
Сообщений: 132
01.10.2012, 20:59  [ТС] #5
ну если честно, я не силён в excel. я думал здесь что-то подобное, например, как в Паскале.
0
Все имена заняты
1245 / 404 / 51
Регистрация: 14.06.2009
Сообщений: 628
02.10.2012, 00:37 #6
Такой вариант.
0
Вложения
Тип файла: xls шифрование.xls (48.5 Кб, 317 просмотров)
m-ch
5247 / 794 / 261
Регистрация: 25.02.2011
Сообщений: 1,094
Записей в блоге: 1
02.10.2012, 07:38 #7
без учета регистра:
Visual Basic
1
2
3
4
5
6
7
8
9
Function CoDerAtbash$(ByVal txt$)
    Dim i&, n&
    Const s$ = "АБВГДЕЁЖЗИЙКЛМНОПРСТУФХЦЧШЩЪЫЬЭЮЯ"
    For i = 1 To Len(txt$)
        n = InStr(s, UCase$(Mid$(txt, i, 1)))
        If n > 0 Then Mid$(txt, i, 1) = Mid$(s, 34 - n, 1)
    Next i
    CoDerAtbash = txt
End Function
С примером указанном в ссылке - совпадает
0
gavrichenko
7 / 7 / 3
Регистрация: 20.07.2012
Сообщений: 132
02.10.2012, 10:13  [ТС] #8
Всем спасибо, но мне нужно решить задачу средствами электронной таблицы без макросов.
0
gavrichenko
7 / 7 / 3
Регистрация: 20.07.2012
Сообщений: 132
02.10.2012, 10:28  [ТС] #9
вот примерное выполнение. только нужно, чтобы данные из ячейки D2 были в D1.
0
Вложения
Тип файла: xls Книга1.xls (14.5 Кб, 286 просмотров)
Pelena
2435 / 1226 / 207
Регистрация: 25.10.2010
Сообщений: 1,971
02.10.2012, 10:44 #10
Для шифрования в D1
Код
=ИНДЕКС(МАССИВ2;ПОИСКПОЗ(C1;МАССИВ1;))
Для дешифрования в Е1
Код
=ИНДЕКС(МАССИВ1;ПОИСКПОЗ(D1;МАССИВ2;))
1
gavrichenko
7 / 7 / 3
Регистрация: 20.07.2012
Сообщений: 132
02.10.2012, 11:09  [ТС] #11
На всякий случай выложу всё задание. Может я что-то неправильно понимаю. Задание:
Средствами электронных таблиц MS Excel реализовать шифрование (дешифрование) сообщений следующими методами (с использованием формул, функций, чтобы при вводе любого сообщения оно шифровалось/дешифровалось). Шифр Атбаш.
0
02.10.2012, 11:09
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
02.10.2012, 11:09
Привет! Вот еще темы с решениями:

Шифрование/дешифрование текста методом перестановки
Помогите переделать шифрование и дешифрование в отдельные процедуры, чтобы...

Шифрование исходного текста и его дешифрование
Здравствуйте, нужна ваша помощь. Пытаюсь разработать WPF-приложение шифрования...

Шифрование/дешифрование текста: шифр Цезаря
8. Написать программу, которая позволяет зашифровывать и расшифровывать с...

Шифрование и дешифрование текста методом шифрующих таблиц
Помогите написать программу. Выполнить шифрование и дешифрование текста...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
11
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru