Форум программистов, компьютерный форум, киберфорум
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.85/81: Рейтинг темы: голосов - 81, средняя оценка - 4.85
sidrd
0 / 0 / 0
Регистрация: 20.06.2012
Сообщений: 7
1
1C 8.x (тонкий)

Передать структуру из формы в форму управляемые формы

20.06.2012, 14:19. Просмотров 16317. Ответов 14
Метки нет (Все метки)

Нужно передать из произвольной формы у форму документа структуру при закрытии

В форме документа, получаю и заполняю произвольную форму:

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
Если Не Отказ Тогда
        Форма = ПолучитьФорму("Документ.ткТабельУчетаРабочегоВремениУпр.Форма.ВводСотрудникаУпр");
        Форма.ПериодРегистрации = Объект.ПериодРегистрации;
        Форма.Подразделение       = Объект.Подразделение;
        Форма.Бюджет         = Объект.Бюджет;
        Форма.ШтатноеРасписание = Объект.ШтатноеРасписание;
        
        Форма.ДокументТабель = Объект.Ссылка;
        Форма.Сотрудник           = ТекущаяСтрокаСотрудники.ФизЛицо;
        Форма.Должность           = ТекущаяСтрокаСотрудники.Должность;
        Форма.НаборСвойств     = ТекущаяСтрокаСотрудники.НаборСвойств;
        Форма.ГрафикРаботы     = ТекущаяСтрокаСотрудники.ГрафикРаботы;
        
        Форма.УчетПоКатегориямФизЛиц    = ТекущаяСтрокаСотрудники.УчетПоКатегориямФизЛиц;
        Форма.КатегорияФизЛиц              = ТекущаяСтрокаСотрудники.КатегорияФизЛиц;
        Форма.НадбавкиЗаОсобенностиОбъекта = ТекущаяСтрокаСотрудники.НадбавкиЗаОсобенностиОбъекта;
        Форма.ЗПУстановленнаяКлиентом      = ТекущаяСтрокаСотрудники.ЗПУстановленнаяКлиентом;
        
        Форма.ДатаНачалаПериода     = НачалоМесяца(Объект.ПериодРегистрации);
        Форма.ДатаОкончанияПериода = КонецМесяца (Объект.ПериодРегистрации);
                
        Форма.Приказ     = ТекущаяСтрокаСотрудники.Приказ;
        СтруктураПараметров = Форма.ОткрытьМодально();
        Если СтруктураПараметров <> Неопределено Тогда
            ОбработатьРезультатАвтоматическогоЗаполненияСотрудника(СтруктураПараметров);
        Иначе
            Сообщить("Заполнение не произведено.", СтатусСообщения.Информация);
            Отказ = Истина;
//          
        КонецЕсли;
    КонецЕсли;
//  
КонецПроцедуры


Теперь из произвольной формы надо обратно отправить данные из запроса
записанные в структуру, вот из этой функции которую написал в произвольной форме:

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
&НаСервере
Функция ПеренестиСотрудников ()
    
    
    Отказ = Ложь;
    
    // Проверим правильность заполнения
    Для Каждого СтрокаТЗ Из ДанныеДляДокумента Цикл
        Если Не ЗначениеЗаполнено(СтрокаТЗ.ВремяОкончанияРаботы) И Не ЗначениеЗаполнено(СтрокаТЗ.ВремяНачалаРаботы) Тогда  
            Сообщить("Время начала и окончания работы одновременно не могут быть 00:00:00.", СтатусСообщения.ОченьВажное);
            Отказ = Истина;
        КонецЕсли;
    КонецЦикла;
    
    
    // передадим данные
    Если Не Отказ Тогда
        
        ЗапросОтбор = Новый Запрос;
        ЗапросОтбор.УстановитьПараметр("ТЗДанные", ДанныеДляДокумента.Выгрузить());
        ЗапросОтбор.Текст = 
        "ВЫБРАТЬ
        |   ТЗДанные.Дата КАК Дата,
        |   ТЗДанные.Приказ КАК Приказ,
        |   ТЗДанные.ФизЛицо КАК ФизЛицо,
        |   ТЗДанные.Должность КАК Должность,
        |   ТЗДанные.НаборСвойств КАК НаборСвойств,
        |   ТЗДанные.ГрафикРаботы КАК ГрафикРаботы,
        |   ТЗДанные.УчетПоКатегориямФизЛиц КАК УчетПоКатегориямФизЛиц,
        |   ТЗДанные.КатегорияФизЛиц КАК КатегорияФизЛиц,
        |   ТЗДанные.НадбавкиЗаОсобенностиОбъекта КАК НадбавкиЗаОсобенностиОбъекта,
        |   ТЗДанные.ЗПУстановленнаяКлиентом КАК ЗПУстановленнаяКлиентом,
        |   ТЗДанные.ВремяНачалаРаботы КАК ВремяНачалаРаботы,
        |   ТЗДанные.ВремяОкончанияРаботы КАК ВремяОкончанияРаботы,
        |   ТЗДанные.КоличествоЧасов КАК КоличествоЧасов,
        |   ТЗДанные.Перенести КАК Перенести
        |ПОМЕСТИТЬ ВТДанные
        |ИЗ
        |   &ТЗДанные КАК ТЗДанные
        |;
        |
        |////////////////////////////////////////////////////////////////////////////////
        |ВЫБРАТЬ
        |   ВТДанные.Дата,
        |   ВТДанные.Приказ,
        |   ВТДанные.ФизЛицо,
        |   ВТДанные.Должность,
        |   ВТДанные.НаборСвойств,
        |   ВТДанные.ГрафикРаботы,
        |   ВТДанные.УчетПоКатегориямФизЛиц,
        |   ВТДанные.КатегорияФизЛиц,
        |   ВТДанные.НадбавкиЗаОсобенностиОбъекта,
        |   ВТДанные.ЗПУстановленнаяКлиентом,
        |   ВТДанные.ВремяНачалаРаботы,
        |   ВТДанные.ВремяОкончанияРаботы,
        |   ВТДанные.КоличествоЧасов,
        |   ВТДанные.Перенести
        |ИЗ
        |   ВТДанные КАК ВТДанные
        |ГДЕ
        |   ВТДанные.Перенести";
        ТЗДляПередачи = ЗапросОтбор.Выполнить().Выгрузить();
        
                СтруктураПараметров = Новый Структура;
                СтруктураПараметров.Вставить("ТЗДляПередачи", ТЗДляПередачи);
                
        Возврат СтруктураПараметров;
        
        
    КонецЕсли;
        
КонецФункции
Далее при закрытии этой произвольной формы

Надо передать параметры форму документа чтобы заполнить данные из этой структуры.
Как это можно лучше сделать?
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
20.06.2012, 14:19
Ответы с готовыми решениями:

Вызвать форму редактирования списка (8.2 не управляемые формы)
Доброго времени суток! Я тут думаю как реализовать: есть кнопка, по нажатию на нее открывается...

Передать информацию из формы выбора в форму элемента
(версия 8.2. тонкий клиент) Значит так. Проблема вот какая. Речь идет о справочнике. Когда я,...

Управляемые формы 1с
как перебрать строки в таблице на управляемой форме и сделать невидимыми некоторые из них?

Управляемые формы
Начал немного усваивать 1С, вопрос к профи. Есть &quot;управляемые формы&quot;, все формы называются...

14
Fenomen
899 / 876 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
20.06.2012, 14:44 2
Поместите структуру во временное хранилище. Возвращайте адрес в хранилище. Получайте структуру из временного хранилища.
0
sidrd
0 / 0 / 0
Регистрация: 20.06.2012
Сообщений: 7
20.06.2012, 14:47  [ТС] 3
Цитата Сообщение от Fenomen Посмотреть сообщение
Поместите структуру во временное хранилище. Возвращайте адрес в хранилище. Получайте структуру из временного хранилища.
Есть пример или ссылка, я с временным хранилищем не работал
0
Fenomen
899 / 876 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
20.06.2012, 14:54 4
Да там все просто. Посмотрите в синтаксис помощнике:
ПоместитьВоВременноеХранилище
ПолучитьИзВременногоХранилища
0
sidrd
0 / 0 / 0
Регистрация: 20.06.2012
Сообщений: 7
20.06.2012, 15:30  [ТС] 5
Делаю в произвольной форме:

1C
1
2
3
    СтруктураПараметров = Новый Структура;
        СтруктураПараметров.Вставить("ТЗДляПередачи", ТЗДляПередачи);
    ПоместитьВоВременноеХранилище(СтруктураПараметров);

При получении из хранилища пишет о несоответствии типов параметров

а1.Форма(1521)}: Ошибка при вызове метода контекста (ПолучитьИзВременногоХранилища)
ОбработатьРезультатАвтоматическогоЗаполненияСотрудника(ПолучитьИзВременногоХранилища(СтруктураПараметров));
по причине:
Несоответствие типов (параметр номер '1')

Может из-за того что адрес не указан, при записи, получении из временного хранилище в качестве адреса что указывать для структуры?
0
Fenomen
899 / 876 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
20.06.2012, 16:45 6
1C
1
Адрес = ПоместитьВоВременноеХранилище(СтруктураПараметров);
Передаете адрес в нужную форму и вней

1C
1
СтруктураПараметров = ПолучитьИзВременногоХрани(Адрес);
0
sidrd
0 / 0 / 0
Регистрация: 20.06.2012
Сообщений: 7
20.06.2012, 17:49  [ТС] 7
Цитата Сообщение от Fenomen Посмотреть сообщение
1C
1
Адрес = ПоместитьВоВременноеХранилище(СтруктураПараметров);
Передаете адрес в нужную форму и вней

1C
1
СтруктураПараметров = ПолучитьИзВременногоХрани(Адрес);
А как Адрес передать в формудокумента, ну в ту первую форму из котороый мы открываем вторую, причем вторая открыта модально.
0
Fenomen
899 / 876 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
20.06.2012, 18:01 8
В первой форме
1C
1
Адрес = Форма.ОткрытьМодально();
Во второй
Закрывайте ее из кода:
1C
1
Закрыть(Адрес);
0
sidrd
0 / 0 / 0
Регистрация: 20.06.2012
Сообщений: 7
20.06.2012, 18:15  [ТС] 9
Наоборот, я из первой открываю вторую загоняю туда данные, потом из второй надо как раз таки при закрытии в первую передать данные
0
Fenomen
899 / 876 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
20.06.2012, 18:28 10
Цитата Сообщение от sidrd Посмотреть сообщение
Наоборот
Что наоборот?

Цитата Сообщение от sidrd Посмотреть сообщение
я из первой открываю вторую загоняю туда данные, потом из второй надо как раз таки при закрытии в первую передать данные
Приведенный выше код, как раз для этого случая.
0
sidrd
0 / 0 / 0
Регистрация: 20.06.2012
Сообщений: 7
20.06.2012, 18:44  [ТС] 11
Закрываю я форму на клиенте, сама структура с запросом создается на сервере,
я сделал реквизит формы типа ТаблицаЗначений, чтобы с сервера на клиенте закрыть с передачей параметров.
В итоге пишет об ошибке значение не является значением объектного типа
ТЗДанные = СтруктураПараметров.ТЗДляПередачи;

Хотя данные в структуру из начальной таблицы выгружаются.
0
Fenomen
899 / 876 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
20.06.2012, 18:51 12
Используя Ваш код:
1C
1
2
3
4
5
6
7
8
9
10
Форма.Приказ        = ТекущаяСтрокаСотрудники.Приказ;
        АдресВХранилище = Форма.ОткрытьМодально();
        СтруктураПараметров = ПолучитьИзВременногоХранилища(АдресВХранилище );
        Если СтруктураПараметров <> Неопределено Тогда
            ОбработатьРезультатАвтоматическогоЗаполненияСотрудника(СтруктураПараметров);
        Иначе
            Сообщить("Заполнение не произведено.", СтатусСообщения.Информация);
            Отказ = Истина;
//          
        КонецЕсли;
1C
1
2
3
4
СтруктураПараметров = Новый Структура;
                СтруктураПараметров.Вставить("ТЗДляПередачи", ТЗДляПередачи);
                Адрес = ПоместитьВоВременноеХранилище(СтруктураПараметров);
                Возврат Адрес;

После вызова функции ПеренестиСотрудников ()
1C
1
Форма.Закрыть(Адрес);
0
sidrd
0 / 0 / 0
Регистрация: 20.06.2012
Сообщений: 7
20.06.2012, 19:14  [ТС] 13
Вернулся в ту же ошибку что и была вначале

Основная форма документа
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
 &НаКлиенте
Процедура ЗаполнитьАвтоматическиСотрудникаВУчетРабочегоВремени()
//  
    Отказ = Ложь;
//  
    ТекущаяСтрокаСотрудники = Неопределено;
    Если Элементы.Страницы.ТекущаяСтраница.Имя = "ГруппаУчетРабочегоВремени" Тогда
        ТекущаяСтрокаСотрудники = Элементы.Сотрудники.ТекущиеДанные;
    ИначеЕсли Элементы.Страницы.ТекущаяСтраница.Имя = "ГруппаФактРаботыПерсонала" Тогда
        ТекущаяСтрокаСотрудники = Элементы.Сотрудники1.ТекущиеДанные;
    КонецЕсли;
 
   Если Не Отказ Тогда
    
      
        Форма = ПолучитьФорму("Документ.ткТабельУчетаРабочегоВремениУпр.Форма.ВводСотрудникаУпр");
        Форма.ВладелецФормы = ЭтаФорма;
        Форма.ПериодРегистрации = Объект.ПериодРегистрации;
        Форма.Подразделение       = Объект.Подразделение;
        Форма.Бюджет         = Объект.Бюджет;
        Форма.ШтатноеРасписание = Объект.ШтатноеРасписание;
        
        Форма.ДокументТабель = Объект.Ссылка;
        Форма.Сотрудник           = ТекущаяСтрокаСотрудники.ФизЛицо;
        Форма.Должность           = ТекущаяСтрокаСотрудники.Должность;
        Форма.НаборСвойств     = ТекущаяСтрокаСотрудники.НаборСвойств;
        Форма.ГрафикРаботы     = ТекущаяСтрокаСотрудники.ГрафикРаботы;
        
        Форма.УчетПоКатегориямФизЛиц    = ТекущаяСтрокаСотрудники.УчетПоКатегориямФизЛиц;
        Форма.КатегорияФизЛиц              = ТекущаяСтрокаСотрудники.КатегорияФизЛиц;
        Форма.НадбавкиЗаОсобенностиОбъекта = ТекущаяСтрокаСотрудники.НадбавкиЗаОсобенностиОбъекта;
        Форма.ЗПУстановленнаяКлиентом      = ТекущаяСтрокаСотрудники.ЗПУстановленнаяКлиентом;
        
        Форма.ДатаНачалаПериода     = НачалоМесяца(Объект.ПериодРегистрации);
        Форма.ДатаОкончанияПериода  = КонецМесяца (Объект.ПериодРегистрации);
                
        Форма.Приказ     = ТекущаяСтрокаСотрудники.Приказ;
                
        
        АдресВХранилище = Форма.ОткрытьМодально();
                          СтруктураПараметров = ПолучитьИзВременногоХранилища(АдресВХранилище);
    
        
        
        Если СтруктураПараметров <> Неопределено Тогда
 
    ОбработатьРезультатАвтоматическогоЗаполненияСотрудника (СтруктураПараметров);
 
        Иначе
            
    ОбработатьРезультатАвтоматическогоЗаполненияСотрудника(СтруктураПараметров);
                                        
              Сообщить("Заполнение не произведено.", СтатусСообщения.Информация);
    
     Отказ = Истина;
//          
        КонецЕсли;
    КонецЕсли;
//  
КонецПроцедуры

Процедуры из второй произвольной формы, где заполняем рабочее время, и эта форма дожна возратить структуру в основную форму документа

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
&НаСервере
Функция  ПеренестиСотрудников ()
    
    
    Отказ = Ложь;
    
    // Проверим правильность заполнения
    Для Каждого СтрокаТЗ Из ДанныеДляДокумента Цикл
        Если Не ЗначениеЗаполнено(СтрокаТЗ.ВремяОкончанияРаботы) И Не ЗначениеЗаполнено(СтрокаТЗ.ВремяНачалаРаботы) Тогда  
Сообщить("Время начала и окончания работы одновременно не могут быть 00:00:00.", СтатусСообщения.ОченьВажное);
            Отказ = Истина;
        КонецЕсли;
    КонецЦикла;
    
    
    // передадим данные
    Если Не Отказ Тогда
        
        ЗапросОтбор = Новый Запрос;
        ЗапросОтбор.УстановитьПараметр("ТЗДанные", ДанныеДляДокумента.Выгрузить());
        ЗапросОтбор.Текст = 
        "ВЫБРАТЬ
        |   ТЗДанные.Дата КАК Дата,
        |   ТЗДанные.Приказ КАК Приказ,
        |   ТЗДанные.ФизЛицо КАК ФизЛицо,
        |   ТЗДанные.Должность КАК Должность,
        |   ТЗДанные.НаборСвойств КАК НаборСвойств,
        |   ТЗДанные.ГрафикРаботы КАК ГрафикРаботы,
        |   ТЗДанные.УчетПоКатегориямФизЛиц КАК УчетПоКатегориямФизЛиц,
        |   ТЗДанные.КатегорияФизЛиц КАК КатегорияФизЛиц,
        |   ТЗДанные.НадбавкиЗаОсобенностиОбъекта КАК НадбавкиЗаОсобенностиОбъекта,
        |   ТЗДанные.ЗПУстановленнаяКлиентом КАК ЗПУстановленнаяКлиентом,
        |   ТЗДанные.ВремяНачалаРаботы КАК ВремяНачалаРаботы,
        |   ТЗДанные.ВремяОкончанияРаботы КАК ВремяОкончанияРаботы,
        |   ТЗДанные.КоличествоЧасов КАК КоличествоЧасов,
        |   ТЗДанные.Перенести КАК Перенести
        |ПОМЕСТИТЬ ВТДанные
        |ИЗ
        |   &ТЗДанные КАК ТЗДанные
        |;
        |
        |////////////////////////////////////////////////////////////////////////////////
        |ВЫБРАТЬ
        |   ВТДанные.Дата,
        |   ВТДанные.Приказ,
        |   ВТДанные.ФизЛицо,
        |   ВТДанные.Должность,
        |   ВТДанные.НаборСвойств,
        |   ВТДанные.ГрафикРаботы,
        |   ВТДанные.УчетПоКатегориямФизЛиц,
        |   ВТДанные.КатегорияФизЛиц,
        |   ВТДанные.НадбавкиЗаОсобенностиОбъекта,
        |   ВТДанные.ЗПУстановленнаяКлиентом,
        |   ВТДанные.ВремяНачалаРаботы,
        |   ВТДанные.ВремяОкончанияРаботы,
        |   ВТДанные.КоличествоЧасов,
        |   ВТДанные.Перенести
        |ИЗ
        |   ВТДанные КАК ВТДанные
        |ГДЕ
        |   ВТДанные.Перенести";
        ТЗДляПередачи = ЗапросОтбор.Выполнить().Выгрузить();
        
        СтруктураПараметров = Новый Структура;
        СтруктураПараметров.Вставить("ТЗДляПередачи", ТЗДляПередачи);
        
        Адрес = ПоместитьВоВременноеХранилище(СтруктураПараметров);
        
        Возврат Адрес;
        
    КонецЕсли;
    
  
    
КонецФункции
 
 
// закрываю форму и передаю параметры из функции с адресом временного хранилище, как
// Вы и сказали:
// только я сделал по кнопке, сразу закрывается форма и данные приходят в основную форму
 
&НаКлиенте
Процедура Перенести(Команда)
 Закрыть (ПеренестиСотрудников());
КонецПроцедуры


ошибка:

Ошибка при вызове метода контекста (ПолучитьИзВременногоХранилища)
СтруктураПараметров = ПолучитьИзВременногоХранилища(АдресВХранилище);
по причине:
Ошибка получения значение из временного хранилища
по причине:
Ошибка передачи данных между клиентом и сервером. Значение недопустимого типа.
по причине:
Ошибка преобразования данных XDTO:
НачалоСвойства: {http://v8.1c.ru/8.2/mngsrv/ws}response Форма: Элемент Тип: {http://v8.1c.ru/8.1/data/core}Structure
по причине:
Ошибка преобразования данных XDTO:
НачалоСвойства: Value Форма: Элемент Тип: {http://www.w3.org/2001/XMLSchema}anyType
по причине:
Ошибка отображения типов:
Отсутствует отображение для типа '{http://v8.1c.ru/8.1/data/core}ValueTable'

ругается он тут на то что из серверной функции передали адрес хранилище для клиентской функции.

Кстате, а разве временное хранилище при закрытии формы не очищается?
0
Fenomen
899 / 876 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
20.06.2012, 23:13 14
Потому, что Вы на клиенте пытаетесь получить таблицу значений. Получение таблицы и ее обработку нужно делать на сервере.
Если процедура ОбработатьРезультатАвтоматическогоЗаполненияСотрудника , выполняется на сервере, то передавайте в нее адрес и получайте Вашу ТЗ там.
0
asmut
0 / 0 / 0
Регистрация: 19.01.2017
Сообщений: 5
24.01.2014, 22:24 15
Не буду весь ваш код переписывать, покажу суть (ориентируюсь на управляемые формы 8,2):

В форме 1:
1C
1
2
3
4
5
6
7
&НаКлиенте
//Необходимо чтобы данные были записаны и форма сохранена
Структура=Новый Структура;
Структура.Вставить("СсылкаНаДок", Объект.Ссылка);
 
Форма=ПолучитьФорму("Документ.Документ2.Форма.ФД", Структура);
Форма.Открыть();
Вторая форма (ПриСозданииНаСервере):

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
&НаСервере //если жмет можете попробовать БезКонтекста
СсылкаДок1=Параметры.СсылкаНаДок; //СсылкаНаДок это ключ параметра мы передали из формы 1
Объект.Р1=СсылкаДок1.Реквизит1; // присваиваем данные и ваш обсчет идет я так понял в форме
Объект.Р2=СсылкаДок1.Реквизит2;
Номер=СсылкаДок1.Номер;
 
 
 
//Сохраняем документ
Записать();
 
//По ссылке получаем форму1 и передаем в нее ссылку данного документа
Структура=Новый Структура;
Структура.Вставить("СсылкаНаДок2", Объект.Ссылка);
Док=Документы.Документ1.НайтиПоНомеру(Номер);
Док.ПолучитьФорму("НазваниеФормы",Структура);
//ОПять в первой форме
1C
1
2
СсылкаДок2=Параметры.СсылкаНаДок2;
Реквизит1=СсылкаДок2.Реквизит1;
Это суть. Выложите файл можно пнуть чтобы взлетел))
0
24.01.2014, 22:24
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
24.01.2014, 22:24

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Перевести матрицу на управляемые формы
Как можно переделать данный код на версию 1С 8.2 и не используя квалификатор числа. Форма создана...

Автозаполнение табличной части, управляемые формы
Есть справочник Клиенты(реквизиты Наименование, Код) и документ Работа, с табличной частью...

Управляемые формы и Com -объект (страшные тормоза)
Задачка была по переносу из Com-объекта информации в базу. Написал обработку. Открывается файл -...

Управляемые формы, подкрасить цветом поле
создаю таблицу на клиенте и хочу подкрасить колонки в разные цвета в зависимости от значений в...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
15
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.