Форум программистов, компьютерный форум, киберфорум
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/15: Рейтинг темы: голосов - 15, средняя оценка - 5.00
0 / 0 / 0
Регистрация: 25.12.2011
Сообщений: 17
1

Как можно сделать, чтобы при нажатии кнопки заполнялись сразу все поля?

17.01.2012, 18:10. Просмотров 2896. Ответов 15
Метки нет (Все метки)

Подскажите пожалуйста в документе есть табличная часть (номенклатура, характеристика номенклатуры ед.изм, кол-во, цена, сумма), причем колонки номенклатура, характеристика номенклатуры заполняется когда товар отщелкали по штрихкоду, а кол-во, цена, сумма заполняется из регистра при нажатии на кнопку, при этом на каждой строке приходится нажимать на кнопку чтобы заполнились поля. Как можно сделать, чтобы при нажатии кнопки заполнялись сразу все поля???
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
17.01.2012, 18:10
Ответы с готовыми решениями:

Сделать так, чтобы при нажатии кнопки все поля в форме DBGrid заполнились
Есть форма для DBGrid, чтобы заполнить поля. Теперь мне необходимо чтобы при нажатие кнопки все...

Как сделать чтобы при нажатии кнопки чтобы активировались все неактивные кнопки?
На форме имеются три кнопки. При открытии формы кнопка "button1" становится неактивна:...

Как сделать, чтобы в Form1 все компоненты скрылись при нажатии кнопки?
такой вопрос. Как сделать, чтобы в Form1 все компоненты скрылись при нажатии кнопки. Или нудно всем...

Как сделать, чтобы при выборе поля в ListBox и нажатии кнопки "Выбор" поле исчезло
список ListBox c черырьмя опциями, RadioGroup с теми же опциями, флажок CheckBox, кнопка «Выбор» и...

15
145 / 145 / 3
Регистрация: 25.03.2011
Сообщений: 512
17.01.2012, 18:21 2
Вызвать событие происходящее при нажатие на эту кнопку для всех строк (цикл)? Ну или есть в типовых обработка таб. частрей в общих модулях.
0
0 / 0 / 0
Регистрация: 25.12.2011
Сообщений: 17
17.01.2012, 18:25  [ТС] 3
А если циклом сделать по табличной части, подскажите пожалуйста как это сделать? код табличной части
1C
1
2
3
4
5
6
7
8
9
10
        Пока Выборка1.Следующий() Цикл
         ЭлементыФормы.Товары.ТекущиеДанные.КоличествоУчет = Выборка1.Количество;
         ЭлементыФормы.Товары.ТекущиеДанные.Сумма = Выборка1.Стоимость;
         ЭлементыФормы.Товары.ТекущиеДанные.СуммаРегл = Выборка1.Стоимость;
         перемен = Выборка1.Стоимость/Выборка1.Количество;
         ЭлементыФормы.Товары.ТекущиеДанные.Цена = перемен;
         перемен1 = (ЭлементыФормы.Товары.ТекущиеДанные.КоличествоУчет - ЭлементыФормы.Товары.ТекущиеДанные.Количество)* ЭлементыФормы.Товары.ТекущиеДанные.Цена;
         перемен2 = перемен1 + ЭлементыФормы.Товары.ТекущиеДанные.Сумма;
         ЭлементыФормы.Товары.ТекущиеДанные.СуммаУчет = перемен2;   
        КонецЦикла;
0
145 / 145 / 3
Регистрация: 25.03.2011
Сообщений: 512
17.01.2012, 18:30 4
Ну вот в цикл, что выше вставь что то типа в конце...

1C
1
2
3
4
5
6
7
8
9
10
11
12
ОбработкаТабличныхЧастей.ПриИзмененииНоменклатурыТабЧасти(НовСтрокаНовДок, ДокПост);
                ОбработкаТабличныхЧастей.ЗаполнитьСтавкуНДСТабЧасти(НовСтрокаНовДок, ДокПост, "Приобретение");
                 
                мВалютаРегламентированногоУчета = глЗначениеПеременной("ВалютаРегламентированногоУчета");
                
                СтруктураШапкиДокумента = Новый Структура("Контрагент, ТипЦен, ДоговорКонтрагента, ДатаДокумента, ВалютаДокумента, УчитыватьНДС, СуммаВключаетНДС",
                ДокПост.Контрагент, ДокПост.ТипЦен, ДокПост.ДоговорКонтрагента, ДокПост.Дата, ДокПост.ВалютаДокумента, ДокПост.УчитыватьНДС, ДокПост.СуммаВключаетНДС);
                ОбработкаТабличныхЧастей.ЗаполнитьЕдиницуЦенуПокупкиТабЧасти(НовСтрокаНовДок, ДокПост, СтруктураШапкиДокумента, мВалютаРегламентированногоУчета); 
                
                // Рассчитываем реквизиты табличной части.
                ОбработкаТабличныхЧастей.РассчитатьСуммуТабЧасти(НовСтрокаНовДок, ДокПост);
                ОбработкаТабличныхЧастей.РассчитатьСуммуНДСТабЧасти(НовСтрокаНовДок, ДокПост);
эт кароч, пример, сделай так же) НовСтрокаНовДок - это строка, ДокПост - это документ..
0
0 / 0 / 0
Регистрация: 25.12.2011
Сообщений: 17
17.01.2012, 18:34  [ТС] 5
Думаю, что это не подойдет мне то что в конце написано

Добавлено через 1 минуту
А вместо РассчитатьСуммуНДСТабЧаст мне что писать?
0
145 / 145 / 3
Регистрация: 25.03.2011
Сообщений: 512
17.01.2012, 18:36 6
Цитата Сообщение от Irina_IV Посмотреть сообщение
Думаю, что это не подойдет мне то что в конце написано
Я уверен, что это подойдет 100% если это одна из типовых конф)))

Ну или просто в конце цикла вызови процедуру "при изменении номенклатуры" этой формы...

Добавлено через 1 минуту
Цитата Сообщение от Irina_IV Посмотреть сообщение
Думаю, что это не подойдет мне то что в конце написано

Добавлено через 1 минуту
А вместо РассчитатьСуммуНДСТабЧаст мне что писать?
Ее и пиши, прост передай в нее ЭлементыФормы.ТекущиеДанные и ЭтотОбъект.Ссылка
0
0 / 0 / 0
Регистрация: 25.12.2011
Сообщений: 17
17.01.2012, 18:42  [ТС] 7
Ошибки выдает...
0
145 / 145 / 3
Регистрация: 25.03.2011
Сообщений: 512
17.01.2012, 18:43 8
Цитата Сообщение от Irina_IV Посмотреть сообщение
Ошибки выдает...
Я не телепат) Поставь точку останова в местах где ошибка и посомтри, что не так...
0
0 / 0 / 0
Регистрация: 25.12.2011
Сообщений: 17
17.01.2012, 18:49  [ТС] 9
НовСтрокаНовДок - это строка Я вместо этого должна написать ЭлементыФормы.Товары.ТекущиеДанные. а после текущих данных?
0
Модератор
Эксперт 1С
2927 / 2649 / 481
Регистрация: 10.03.2011
Сообщений: 9,999
Записей в блоге: 1
18.01.2012, 00:39 10
Бедняжка.

Добавлено через 4 минуты
C
1
2
3
4
5
6
7
8
9
10
11
12
Для каждого х Из ИмяТабличнойЧасти Цикл
РасчитатьСуммуНДСИВсеЧтоМожноРасчитатьИлиЖеХотелось(х);
КонецЦикла;
 
Процедура РасчитатьСуммуНДСИВсеЧтоМожноРасчитатьИлиЖеХотелось(Строка)
 
//Тут пишем код пересчета (Умножения, деления, Сложение, разность и т.д.)
//Пример
 
Строка.Сумма = Строка.Количество*Строка.Цена;
 
КонецПроцедуры
0
0 / 0 / 0
Регистрация: 25.12.2011
Сообщений: 17
18.01.2012, 00:43  [ТС] 11
Спасибо за помощь! Я уже давно написала через цикл и все получилось, как и вы аналогично.
0
308 / 308 / 1
Регистрация: 16.01.2011
Сообщений: 1,073
18.01.2012, 00:44 12
а после лучше написать ребятам, которые за определенную сумму денег сделают всё что вы хотите.
0
0 / 0 / 0
Регистрация: 25.12.2011
Сообщений: 17
18.01.2012, 00:46  [ТС] 13
Зачем кому-то писать, за определенную сумму денег и я могу написать.
0
308 / 308 / 1
Регистрация: 16.01.2011
Сообщений: 1,073
18.01.2012, 00:48 14
я вижу, но лучше бы ослеп
0
Модератор
Эксперт 1С
2927 / 2649 / 481
Регистрация: 10.03.2011
Сообщений: 9,999
Записей в блоге: 1
18.01.2012, 00:52 15
fimbulwinter, Здорова, где пропадаЛ?
Не желаешь обработку от великодушной Irina_IV???
0
308 / 308 / 1
Регистрация: 16.01.2011
Сообщений: 1,073
18.01.2012, 01:04 16
Цитата Сообщение от Dethmontt Посмотреть сообщение
fimbulwinter, Здорова, где пропадаЛ?
Не желаешь обработку от великодушной Irina_IV???
пусть учится )))))) Без литературы мы никак. Так что глубокоуважаемая Ирина, прежде чем задавать подобные вопросы попробуйте почитать. Разжевать и в ротик положить не по нашей части, простите.
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
18.01.2012, 01:04

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Как сделать так, чтобы при нажатии кнопки появлялся текст?Чтобы без javascript
Как сделать так, чтобы при нажатии кнопки появлялся текст? На html или php можно сделать . Типо...

Как сделать, чтобы при нажатии кнопки 1 нажималась кнопка 2
Как сделать так, что я, например, кликаю на кнопку 1, и после клика происходил автоматический клик...

Как сделать так чтобы два поля заполнялись в два и более Edit?
procedure TForm1.DBGrid1CellClick(Column: TColumn); begin...

Как сделать, чтобы при первом нажатии кнопки таймер запускался а при втором останавливался
Подскажите пожалуста как зделать чтобы при первом нажатии кнопки таймер запускался а при втором...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
16
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.