Форум программистов, компьютерный форум, киберфорум
Программирование Android
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.91/11: Рейтинг темы: голосов - 11, средняя оценка - 4.91
9 / 9 / 8
Регистрация: 03.07.2015
Сообщений: 219
1

Update Google Play Services

13.12.2016, 03:24. Просмотров 2211. Ответов 5
Метки нет (Все метки)

Cтолкнулся со следующей проблемой:
W/GooglePlayServicesUtil: Google Play services out of date. Requires 10084000 but found 9879470
W/FA: Service connection failed: ConnectionResult{statusCode=SE RVICE_VERSION_UPDATE_REQUIRED, resolution=null, message=null}


Второй день долюблюсь над этой проблемой и не могу никак решить. У занакомого на компе все пошло без проблем, у меня же нет. В SDK Tools видно, что google play services не нуждается в обновлении. Может кто стакивался с данной проблемой???
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
13.12.2016, 03:24
Ответы с готовыми решениями:

Google Play Services Sign In / com.google.android.gms.common.api.ApiException: 10
Пробую запустить простейший семпл для авторизации в Google Play Services, но всё время получаю одну...

Google play services ladderboard
Вот и пришло и мое время создать создать тему с дурацкими вопросами. Честно, я уже устал читать...

Google play services libs
Всем привет. Проблема странная, сам первый раз сталкиваюсь но попробуйте понять. Собираюсь писать...

Exception при использовании LocationClient (Google Play Services)
Я пишу сервис для получения location. Есть IntentService и AlarmReceiver (чтобы получать location...

5
Модератор
3308 / 2099 / 333
Регистрация: 13.01.2012
Сообщений: 8,156
13.12.2016, 10:32 2
Цитата Сообщение от Aliaxandr Посмотреть сообщение
У занакомого на компе все пошло без проблем
все - что? после чего началось это чудо?
0
2870 / 2282 / 769
Регистрация: 12.05.2014
Сообщений: 7,978
13.12.2016, 11:56 3
в build.gradle сторка
Java
1
apply plugin: 'com.google.gms.google-services'
должна быть в самом низу кода, то есть идти самой последней

если таки есть - сюда весь код build.gradle
0
9 / 9 / 8
Регистрация: 03.07.2015
Сообщений: 219
13.12.2016, 20:40  [ТС] 4
Паблито, данная строка у меня уже была в самом низу:
build.gradle
apply plugin: 'com.android.application'

android {
compileSdkVersion 25
buildToolsVersion "25.0.1"
defaultConfig {
applicationId "com.example.aleksander.logapi "
minSdkVersion 14
targetSdkVersion 25
versionCode 1
versionName "1.0"
testInstrumentationRunner "android.support.test.runner.A ndroidJUnitRunner"
}
buildTypes {
release {
minifyEnabled false
proguardFiles getDefaultProguardFile('progua rd-android.txt'), 'proguard-rules.pro'
}
}
}

dependencies {
compile fileTree(dir: 'libs', include: ['*.jar'])
androidTestCompile('com.androi d.support.test.espresso:espres so-core:2.2.2', {
exclude group: 'com.android.support', module: 'support-annotations'
})
compile 'com.android.support:appcompat-v7:25.0.1'
testCompile 'junit:junit:4.12'
compile 'com.google.firebase:firebase-auth:10.0.1'
compile 'com.google.android.gmslay-services:10.0.1'
}
apply plugin: 'com.google.gms.google-services'
0
2870 / 2282 / 769
Регистрация: 12.05.2014
Сообщений: 7,978
13.12.2016, 20:45 5
тогда как вариант - на девайсе установлена не самая последняя версия play services
тогда проще всего понизить слегка, например
Java
1
2
    compile 'com.google.firebase:firebase-auth:9.2.0'
    compile 'com.google.android.gmsplay-services:9.2.0'
0
9 / 9 / 8
Регистрация: 03.07.2015
Сообщений: 219
13.12.2016, 21:58  [ТС] 6
Я пишу простое приложение с регистрацией пользователя. Для данных целей использую firebase. Проект начал делать по урокам в нете. Проблема с обновлением у меня появилась после первого запуска проекта на AVD. Тот же проет на другом компе заработал без ошибок. Делаю вывод, что действительно в android studio загвоздка. Снес андроид студио и установил заново(версия была уже повыше), но это проблему не решило

Добавлено через 11 минут
Паблито, ранее пытался уже изменять версию на более низкую, но грэдэл тогда даже не мог построить проект, ну вот и в данно случае для версии 9.2.0 gradle ругается:

Error:Execution failed for task ':app:transformClassesWithDexF orDebug'.
> com.android.build.api.transfor m.TransformException: com.android.ide.common.process .ProcessException: java.util.concurrent.Execution Exception: com.android.dex.DexIndexOverfl owException: method ID not in [0, 0xffff]: 65536


Добавлено через 59 минут
Паблито, при запуске AVD следующее уведомление
com.android.tools.fd.runtime.B ootstartApplication won't run unless you update Google Play Services
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
13.12.2016, 21:58

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Как тестировать приложение с Google Play Services на эмуляторе?
Можно ли протестировать приложение с гугл плей сервисом на эмуляторе ?

Google Play Services Library не может найти ресурсы
Здравствуйте! Пытаюсь использовать AdMob, подключаю по этой инструкции Саму библиотеку...

Регистрацией в Google AdSense (для последующей регистрации в Google Play)
Помогите с регистрацией в Google AdSense: завел свой блог на blogger.com (blogspot). И...

Статистика Google Play Service и баг Google Analytics
В процессе написания простейшего приложения с использованием Google Analytics v4 нашел забавный...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.