0 / 0 / 0
Регистрация: 05.12.2016
Сообщений: 7
1
1C 8.x

Заполнение табличной части одного документа из табличной части этого же документа

27.12.2017, 19:50. Показов 2288. Ответов 3
Метки нет (Все метки)

Здравсвуйте. 1С 8.2.
Есть документ в этом документе 2 табличные части
В 1 табличной части считается общая стоимость запчастей по заказу
Во 2-ой табличной части считается общая стоимость заказа т.е стоимость услуги +общая стоимость запчастей(из 1 табличной части), не знаю как взять эту общую стоимость запчастей из 1 табличной части.
Помогите пожалуйста.

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
&НаКлиенте
Процедура ЗаказаныеУслугиУслугаПриИзменении(Элемент)
    
    СтрокаТабличнойЧасти=Элементы.ЗаказаныеУслуги.ТекущиеДанные;
    
    СтрокаТабличнойЧасти.СтоимостьУслуги = РаботаСоСправочниками.Услуги(Объект.Дата,СтрокаТабличнойЧасти.Услуга);
    
    РаботаСДокументами.РассчитатьУслугу(СтрокаТабличнойЧасти);
 
КонецПроцедуры
 
&НаКлиенте
Процедура ЗаказаныеУслугиСтоимостьУслугиПриИзменении(Элемент)
    СтрокаТабличнойЧасти=Элементы.ЗаказаныеУслуги.ТекущиеДанные;
    РаботаСДокументами.РассчитатьУслугу(СтрокаТабличнойЧасти);
КонецПроцедуры
 
&НаКлиенте
Процедура ЗаказаныеУслугиЦенаЗапчастейПриИзменении(Элемент)
    СтрокаТабличнойЧасти=Элементы.ЗапчастиЗаказа.ТекущиеДанные;
    РаботаСДокументами.РассчитатьУслугу(СтрокаТабличнойЧасти);
 
КонецПроцедуры
__________________
Помощь в написании контрольных, курсовых и дипломных работ, диссертаций здесь
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
27.12.2017, 19:50
Ответы с готовыми решениями:

Заполнение табличной части одного документа из табличной части другого документа
Здравсвуйте. 1С 8.2. Есть документ Приход и документ Расход. Оба документа имеют табличные части -...

Заполнение табличной части одного документа при проведение другого
Подскажите пожалуйста, какой можно использовать синтаксис при такой ситуации. Добавлено через 31...

Заполнение реквизита табличной части документа (строки, из справочника наименования, внутри документа)
Здравствуйте. Волею судеб нужно сваять пару документов в 1с 77. Вроде бы как все шло нормально,...

Заполнение табличной части документа
Добрый вечер! Ситуация. Есть справочник ученики, в котором есть ученики и группа (допустим). И...

3
1086 / 648 / 187
Регистрация: 22.04.2013
Сообщений: 4,828
Записей в блоге: 1
27.12.2017, 20:26 2
ПерваяТабличнаяЧасть.Итог("КолонкаСтоимостиЗапчастей")
0
0 / 0 / 0
Регистрация: 05.12.2016
Сообщений: 7
27.12.2017, 20:32  [ТС] 3
Спасибо за ответ, а можно как-нибудь по подробнее куда это вставить ?

 Комментарий модератора 
Нарушение правил форума, п.5.18:
Запрещено размещать задания и решения в виде картинок и других файлов с их текстом.
Миниатюры
Заполнение табличной части одного документа из табличной части этого же документа  
0
1086 / 648 / 187
Регистрация: 22.04.2013
Сообщений: 4,828
Записей в блоге: 1
27.12.2017, 20:39 4
естественно не знаю.
Вам нужна сумма по столбцу в ТЧ1 - я написал как её найти. а куда её пристроить в трёх неизвестных процедурах, вызывающих четвёртую - нет. не в курсе.
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
27.12.2017, 20:39
Помогаю со студенческими работами здесь

Заполнение табличной части вызываемого документа
Доброе утро прошу подсказать знающих как вывести результат запроса в табличную часть вызываемой...

Автоматическое Заполнение Табличной Части Документа
Всем привет! Подскажите: как программным способом заполнить табличную часть документа данными из...

Перенос табличной части одного документа в ТЧ другого?
Всем привет ! Есть следующие объекты: - Cправочник "Товары". - Документ ЗаказПокупателя c ТЧ...

Перенос данных табличной части из одного документа в другой
Всем доброго времени суток. Такая проблема-есть документ АктПриемаСдачи. В этом документе допустим...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin
Copyright ©2000 - 2022, CyberForum.ru