96 / 92 / 16
Регистрация: 13.04.2015
Сообщений: 545
1

Подсчет количества ячеек из диапазона со временем

24.11.2015, 00:52. Показов 1805. Ответов 4
Метки нет (Все метки)

Author24 — интернет-сервис помощи студентам
Здравствуйте, знатоки!!! Помогите, не могу сообразить, в столбце А дан набор длительностей разной в формате 00:02:00, 00:05:35 и т.д.Необходимо посчитать количество длительности меньше 2 минут но больше 1 минут. Как можно сделать? Пятый час долбаюсь
Вложения
Тип файла: xlsx Primer.xlsx (8.2 Кб, 6 просмотров)
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
24.11.2015, 00:52
Ответы с готовыми решениями:

Подсчет количества непустых ячеек диапазона
Есть диапазон rang1=range(cells(a,b), cells(c,d))' где a,b,c,d заранее определенные переменные....

Подсчёт суммы из ячеек разных листов при выборе диапазона
Здравствуйте! Есть макрос, который при выполнении считает сумму со всех ячеек всех листов книги...

Подсчет количества ячеек
помогите с запросом (новичок поэтому неправильно сформулировать): есть база xxx.dbf в ней столбец...

Подсчет количества ячеек в таблице
Как с помощью ява скрипт узнать количество ячеек в таблице?

4
4135 / 2239 / 940
Регистрация: 01.12.2010
Сообщений: 4,624
24.11.2015, 01:22 2
Лучший ответ Сообщение было отмечено Aleks777 как решение

Решение

Код
=СУММПРОИЗВ((ЗНАЧЕН(A1:A19)>=ВРЕМЗНАЧ("00:01:00"))*(ЗНАЧЕН(A1:A19)<=ВРЕМЗНАЧ("00:02:00")))
P.S. Вместо ВРЕМЗНАЧ("00:01:00") и ВРЕМЗНАЧ("00:02:00") можно использовать 0,000694444444444444 и 0,00138888888888889 , а ЗНАЧЕН заменить на 1* или 0+ или -- (или изначально не хранить время/дату/число как текст)
0
2900 / 1716 / 703
Регистрация: 04.09.2015
Сообщений: 3,442
24.11.2015, 01:22 3
Лучший ответ Сообщение было отмечено Aleks777 как решение

Решение

Код
=СУММПРОИЗВ((A1:A19*1440>1)*(A1:A19*1440<2))
0
2900 / 1716 / 703
Регистрация: 04.09.2015
Сообщений: 3,442
24.11.2015, 01:30 4
Лучший ответ Сообщение было отмечено Aleks777 как решение

Решение

или
Код
=СУММПРОИЗВ((--A1:A19>--"0:01")*(--A1:A19<--"0:02"))
=СУММПРОИЗВ((-A1:A19<-"0:01")*(-A1:A19>-"0:02"))
0
96 / 92 / 16
Регистрация: 13.04.2015
Сообщений: 545
24.11.2015, 10:11  [ТС] 5
pashulka, AlexM, огромное спасибо! все работает!
0
24.11.2015, 10:11
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
24.11.2015, 10:11
Помогаю со студенческими работами здесь

Подсчет количества одинаковых ячеек
Здравствуйте. Подскажите, пожалуйста. Имеется 2 столбца с данными, 0 или 1, сгенерированных...

Подсчет количества ячеек в диапазоне их значений
1. Подсчет количества ячеек в диапазоне их значений. Нужно посчитать, например, в файле в колонке С...

подсчёт количества ячеек в формате дата
Помогите с формулой: Нужно подсчитать количество ячеек, в которых введено время в формате...

Подсчет количества ячеек по сложному условию
Собственно проблема такая: Есть табличка в первом столбце названия серверов (Firewall1,2,3;...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin
Copyright ©2000 - 2024, CyberForum.ru