Форум программистов, компьютерный форум, киберфорум
C# Windows Forms
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.75/8: Рейтинг темы: голосов - 8, средняя оценка - 4.75
22 / 22 / 1
Регистрация: 25.02.2012
Сообщений: 132
1

Конфликт из-за несоответствия версий FW приложения и компонента

01.10.2012, 11:20. Просмотров 1533. Ответов 4
Метки нет (Все метки)


Для проекта скачал кастом контролл, но вот незадача, при подключение проект контролла возникает конфликт, из за того что тот был написан под 2.0, а у меня 4.0.

Предупреждение 2 целевая платформа .NET Framework ".NETFramework,Version=v4.0,Profile=Client" не включает "System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", необходимый для работы сборки "CustomControls", на которую указывает ссылка. Это приводит к невозможности разрешить сборку, на которую указывает ссылка. Для устранения этой ошибки либо (1) измените целевую платформу .NET Framework, для которой предназначен проект, либо (2) удалите из проекта соответствующую сборку. RealmManager
просьба собственно в чём, кто может переписать код под новый фреймворк?
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
01.10.2012, 11:20
Ответы с готовыми решениями:

Не удается открыть БД из-за несоответствия версий
После создания базы данных в ms sql 2008 r2 пытался подключить её к проекту на C# с помощью ADO.NET...

Что за несоответствия Width и Height компонента на основе TCustomControl?
Добрый день! Подскажите пожалуйста кто сталкивался.... У меня собственный компонент на основе...

Конфликт версий ?
стоял питон33, поставил 26, теперь в IDLE 33его написанно: Personal firewall software may warn...

Конфликт версий jQuery
Здравствуйте! На сайте есть две функции: 1. Открытие изображений в модальном окне. Плагин...

__________________
Помогаю в написании студенческих работ здесь.
Записывайтесь на профессиональные курсы С#-разработчиков‌
4
22 / 22 / 1
Регистрация: 25.02.2012
Сообщений: 132
01.10.2012, 12:07  [ТС] 2
Из за переименования темы, вложение решения было утрачено, перезалил по новой.
0
Вложения
Тип файла: rar RealmManagerAtt.rar (5.46 Мб, 9 просмотров)
Почетный модератор
Эксперт .NET
8691 / 3643 / 404
Регистрация: 14.06.2010
Сообщений: 4,513
Записей в блоге: 9
01.10.2012, 16:31 3
Что-то я не понял проблемы Проект с контролом есть? - Есть. Так почему не изменить его версию .NET на нужную? Поменяйте и все заработает (Properties -> Application -> Target Framework).
0
22 / 22 / 1
Регистрация: 25.02.2012
Сообщений: 132
01.10.2012, 21:47  [ТС] 4
всё бы ничего, но при смене версии FW в контролле, весь код начинает сыпаться (основан на классах, а в классах не силён увы) вот и попросил чтоб знающий человек, кому это не трудно, переписал, это от силы 20-30 минут в самом худшем случае
0
Почетный модератор
Эксперт .NET
8691 / 3643 / 404
Регистрация: 14.06.2010
Сообщений: 4,513
Записей в блоге: 9
01.10.2012, 22:28 5
Пересобрал
1
Вложения
Тип файла: rar RealmManager.rar (5.76 Мб, 7 просмотров)
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
01.10.2012, 22:28

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь или здесь.

Конфликт версий jQuery
Здравствуйте. Подскажите как решить проблему с конфликтующими версия jQuery. Сайт на MODx. Дизайнер...

Локальный конфликт версий
Доброго времени суток. Видел несколько тем по похожей тематике, но мне не совсем подходит, т.к....

Конфликт двух версий jquery
Дорогие форумчане, прошу совета. Есть сайт асремонт.рф на wordpress, использую плагин smart...

Visual Studio конфликт версий
Установлена Visual Studio 2015. Затем установлена Visual Studio 2010. Открыл файл .sln сначала...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.