Форум программистов, компьютерный форум, киберфорум
Наши страницы

Массив - C++

Войти
Регистрация
Восстановить пароль
Другие темы раздела
C++ Добрый вечер, прошу помощи по строкам и лексемам (strtok) http://www.cyberforum.ru/cpp-beginners/thread394194.html
суть в чем... Строка будет скопирована из формул в экселе. По типу "=ЕСЛИ(A1>=12; 3;..." ит.п. Пытаюсь игнорировать пробелы, деля строку на лексемы пробелами, а потом уже в каждой лексеме выделять...
C++ Найти наименьший элемент 3-его столбца матрицы Доброго времени суток всем.. Помогите решить задачку. Дана матрица А(5,3) 1) Создать новый одномерный массив, каждый элемент которого равен среднему арифметическому элементов соответствующей... http://www.cyberforum.ru/cpp-beginners/thread394193.html
C++ Задачи массивы( объяснение)
Здравствуйте,не могли бы помочь в написании кода и обьяснить некоторые подробности есть несколько типов задач, по массивам которые хотелось бы разобрать первая это сортировка,но я ее сделал и вышло...
Кратчайший путь в графе. C++
Такая задача: Дан ориентированный взвешенный ациклический граф. Требуется найти в нем кратчайший путь из вершины s в вершину t. Первая строка входного файла содержит четыре целых числа n, m, s и t...
C++ Вывести слова, заканчивающиеся буквой "а" http://www.cyberforum.ru/cpp-beginners/thread394175.html
Дана строка символов. Признак конца строки "\n" (перевод строки). Строка состоит из слов, разделенных пробелами. Вывести слова, заканчивающиеся буквой "а", с порядковыми номерами этих слов в данной...
C++ двумерная матрица А произвольной размерности Пусть есть двумерная матрица А произвольной размерности. Сформировать на ее основе вектор В элементами которого является сумма элементов строк подробнее

Показать сообщение отдельно
shtefeek
5 / 5 / 0
Регистрация: 30.10.2010
Сообщений: 22
28.11.2011, 22:27
Не нашел смысла в этом участке кода:
C
1
2
3
4
5
6
7
8
for(i = 0; i < c; j++)
        {
                if(i == k)
                t = b[i];
        }
        printf("%d ", b[i]);
        printf("\nSr = %f", Sr);
        printf("\nk positive el: %d ", t);
i++,а не j++
ну это ладно еще, но зачем создавать цикл, можно просто написать
C
1
printf("%d",b[k])
C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
#include <iostream>
#include <stdio.h>
using namespace std;
int main()
{
        const int n = 8;
        int i, k, S=0, t, c=0,j=1;
        int a[n], b[10];
        float Sr;
        printf("Enter k - ");
        scanf("%d",&k);
        for (i=0;i<n;i++)
        {
            printf("a[%d]=",i+1);
            scanf("%d",&a[i]);
        }
        for (i=0;i<n;i++)
        {
            S=S+a[i];
        }
        Sr=S/n;
        for (i=0;i<n;i++)
        {
            if (a[i]>0 && a[i]>Sr)
            {
                           b[j]=a[i];
                           j++;
                       }
        }
        printf("B[k]=%d\n",b[k+1]);
        system("PAUSE");
        return 0;
        }
1
 
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru