Форум программистов, компьютерный форум, киберфорум
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.86/7: Рейтинг темы: голосов - 7, средняя оценка - 4.86
0 / 0 / 0
Регистрация: 14.01.2015
Сообщений: 20
1

Подстановка значений

03.12.2015, 13:49. Просмотров 1332. Ответов 10
Метки нет (Все метки)

Подскажите пожалуйста, как сделать следующее?
В таблице нужно чтобы ячейки столбца А сверяли с ячейками столбца С. И если находятся одинаковое значение в столбце С то рядом с той ячейкой столбца А, которая схожа с ячейкой столбца С, было значение столбца D соответствующее ячейкам столбца С.
То есть если:
А1=С2, то В1=Д2;
А5=С10, то В5=Д10;
А10=С27, то В10=Д27;
А11=С27, то В11=Д27;
А12=С27, то В12=Д27 и так далее...
пример прилагается.
0
Вложения
Тип файла: xlsx пример.xlsx (10.8 Кб, 5 просмотров)
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
03.12.2015, 13:49
Ответы с готовыми решениями:

Подстановка значений
Здравствуйте. Помогите пожалуйста. Есть бланк заявки. заполняется бригад и тип крепи которым она...

Подстановка не значений а формул
Ребята подскажите как можно сделать следующее:есть стандартный список позиций.Для каждой позиции...

Подстановка значений по параметру
Добрый день помогите в решение проблемы, уже пару дней боюсь ничего не получается: Задача...

Сравнения таблиц,подстановка значений
ПРивет, у меня сайт и с периодичностью в ручную делаю сравнения и подстановку значений из таблиц с...

10
2581 / 1674 / 687
Регистрация: 04.09.2015
Сообщений: 3,350
03.12.2015, 13:51 2
Функция ВПР()+ЕСЛИОШИБКА()
1
0 / 0 / 0
Регистрация: 14.01.2015
Сообщений: 20
03.12.2015, 13:53  [ТС] 3
Если честно, то не очень понятен смысл вашего ответа(((можно более подробно, пожалуйста?
0
83 / 60 / 21
Регистрация: 03.12.2014
Сообщений: 231
03.12.2015, 13:59 4
Лучший ответ Сообщение было отмечено lahesis как решение

Решение

lahesis, В ячейке В1 вставляете формулу
Visual Basic
1
=ЕСЛИОШИБКА(ВПР(A1;$C$1:$D$27;2;0);"Нет в столбце С")
и протягиваете на остальные.
1
3234 / 1978 / 637
Регистрация: 02.11.2012
Сообщений: 5,118
03.12.2015, 14:03 5
lahesis, если создаете тему на нескольких форумах как минимум уведомляйте об этом.
Кросс на планете.
1
0 / 0 / 0
Регистрация: 14.01.2015
Сообщений: 20
03.12.2015, 14:16  [ТС] 6
А подскажите пожалуйста, почему в данном случае не совсем работает?
0
Вложения
Тип файла: xlsx пример2.xlsx (94.1 Кб, 7 просмотров)
2581 / 1674 / 687
Регистрация: 04.09.2015
Сообщений: 3,350
03.12.2015, 14:17 7
Цитата Сообщение от Vlad999 Посмотреть сообщение
Кросс на планете
и в Мир MS Excel
1
0 / 0 / 0
Регистрация: 14.01.2015
Сообщений: 20
03.12.2015, 14:17  [ТС] 8
Простите, просто очень срочно нужно вот так и получилось...
0
2581 / 1674 / 687
Регистрация: 04.09.2015
Сообщений: 3,350
03.12.2015, 14:21 9
А так?
Код
=ЕСЛИОШИБКА(ВПР(A1;$C$1:$D$1999;2;0);"Нет в столбце С")
2
3234 / 1978 / 637
Регистрация: 02.11.2012
Сообщений: 5,118
03.12.2015, 14:28 10
Лучший ответ Сообщение было отмечено lahesis как решение

Решение

Цитата Сообщение от lahesis Посмотреть сообщение
почему в данном случае не совсем работает?
по тому что фактическая таблица (в которой ищем) больше чем вы указали диапазон в формуле.
П,С, если вопрос решен не забудьте отписаться на других форумах с прикладыванием правильного ответа.
1
0 / 0 / 0
Регистрация: 14.01.2015
Сообщений: 20
03.12.2015, 14:32  [ТС] 11
Да уже увеличил диапазон и все решилось. Спасибо всем большое!
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
03.12.2015, 14:32

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Подстановка значений по одному условию
Доброй ночи ! вот такая задача встала , с vba я не дружу, хотелосьбы формулой обойтись у меня...

Автоматическая подстановка значений в ячейки
Добрый день, господа! Собствнно, сабж. Есть таблица: одна строка, два столбца. Можно ли как-то...

Подстановка значений через раскрывающийся список
Приветствую вас уважаемые гуру MS Excel Есть простой пример, нужно по схеме при выборе например...

Подстановка значений в таблицу на основе ЭТАЛОНА
Помогите, пожалуйста, решить следующую задачу: Есть эталонная таблица, в которой каждому...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
11
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.