Форум программистов, компьютерный форум, киберфорум
Наши страницы
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/5: Рейтинг темы: голосов - 5, средняя оценка - 5.00
volganin
0 / 0 / 0
Регистрация: 18.01.2020
Сообщений: 4
1

Несколько ЕСЛИ+СЦЕП

14.02.2020, 18:50. Просмотров 888. Ответов 8
Метки нет (Все метки)

Совсем "зеленый" в EXCEL. Как сцепить ячейки, чтобы получился формат как в желтом поле.
0
Вложения
Тип файла: xlsx Даты для паспортов.xlsx (10.8 Кб, 8 просмотров)
Лучшие ответы (1)
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
14.02.2020, 18:50
Ответы с готовыми решениями:

ЕСЛИ - несколько условий
Есть данная формула: =ЕСЛИ('Общий список'!$B$7=Список!D3;МАКС(Список!$A$2:A2)+1;"") Мне нужно...

Условие Если и несколько аргументов
Здравствуйте, столкнулся с задачей, которую не получается решить. Что я имею: 1.Есть табличка с...

Нужно сделать несколько ЕСЛИ в Excel
Доброго времени суток, как сделать несколько условий исходя из этого задания: Мой вариант: ...

Две или несколько функций =ЕСЛИ в одной ячейке
Здравствуйте, как в одной ячейке совместить две или несколько формул с функцией =ЕСЛИ. Спасибо

Если несколько ячеек равны, то удаляется вся строка
Здравствуйте, очень прошу помочь с таким делом, есть файл на 4500 тыс строк, из него надо удалить...

8
Narimanych
807 / 575 / 285
Регистрация: 23.03.2015
Сообщений: 1,963
14.02.2020, 19:07 2
volganin,
Так у вас в столбце "Е" уже есть формулы...
0
volganin
0 / 0 / 0
Регистрация: 18.01.2020
Сообщений: 4
14.02.2020, 19:20  [ТС] 3
Там не полностью выполняются все условия, 3 из 6. Как сделать чтобы пустые ячейки пропускались. Когда встречается просто месяц было вот в таком формате паспорт №0356 от Март 2020. И есть номер но нет даты паспорт №654 б/д
0
Fairuza
5379 / 2756 / 515
Регистрация: 23.11.2010
Сообщений: 9,061
14.02.2020, 21:46 4
что "Март 2020", что "11.02.2018" - формат ячейки "Дата", каким образом их разделять... насколько глобально необходимо
0
Narimanych
807 / 575 / 285
Регистрация: 23.03.2015
Сообщений: 1,963
14.02.2020, 22:10 5
volganin,
попробуй :
=СЦЕПИТЬ(ЕСЛИ(И($B1="",$C1=""),"",$A1)," ",ЕСЛИ($B1="","",ЕСЛИ($B1="б/н",$B1,СЦЕП("№ ",$B1)))," ",ЕСЛИ($C1="","",ЕСЛИ($C1="б/д",$C1,СЦЕП(" от ",ТЕКСТ($C1,ЕСЛИ(ЯЧЕЙКА("формат",$C1)="D1","mmmm yyyy","DD.MM.YYYY"))))))

Пайл приложен....
1
Вложения
Тип файла: xlsx СЦЕПКА.xlsx (10.8 Кб, 6 просмотров)
volganin
0 / 0 / 0
Регистрация: 18.01.2020
Сообщений: 4
15.02.2020, 08:00  [ТС] 6
Narimanych , спасибо большое! Все получилось.
0
AlexM
2195 / 1565 / 639
Регистрация: 04.09.2015
Сообщений: 3,129
15.02.2020, 22:36 7
Лучший ответ Сообщение было отмечено volganin как решение

Решение

Код
=ЕСЛИ(B1&C1="";"";A1)&ТЕКСТ(B1;" № 0;;; б\/н")&ТЕКСТ(C1;" о\т "&ЕСЛИ(ЯЧЕЙКА("формат";C1)="D3";"ММММ ";"ДД.ММ.")&"ГГГ;;; б\/\д")
1
Вложения
Тип файла: xlsx СЦЕПКА_01.xlsx (9.5 Кб, 7 просмотров)
volganin
0 / 0 / 0
Регистрация: 18.01.2020
Сообщений: 4
16.02.2020, 09:29  [ТС] 8
Большое спасибо!AlexM, не могли бы вы расписать как работает формула. Я только начал постигать азы. Очень хотелось понять как работает это решение. Ни где не видел тройные "; "
0
AlexM
2195 / 1565 / 639
Регистрация: 04.09.2015
Сообщений: 3,129
16.02.2020, 09:53 9
Функция
ТЕКСТ(значение;"положительное;отрицательное;нулевое;текстовое")
Фрагмент формулы ТЕКСТ(B1;" № 0;;; б\/н")
формат положительном значении - № 0 (пробел,№, пробел,0) при нуле значение выводится от одного знака и больше.
Формат при отрицательном значении отсутствует, так как отрицательного быть не может
Формат при нулевом значении отсутствует, так как нулевого быть не может
Формат при текстовом значении - б\/н (пробел,б/н) так как знак / является спец символом его нужно экранировать знаком \

Прочитайте статью о пользовательских форматах Пользовательский формат
1
16.02.2020, 09:53
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
16.02.2020, 09:53

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Можно ли в рамках ЕСЛИ рассчитывать и выводить сразу несколько значений
Смысл в следующем. Необходимо решить квадратное уравнение при определенных условиях. Решения...

Функция ЕСЛИ со значениями формата "Дата", несколько условий
Добрый день! Просьба посмотреть формулу из файла во вложении. Если "Срок жизни" менее года,...

А если учить сразу несколько несколько ПЯ?
Народ всем привет плиз за тему не убивайте ок:-D У меня вопрос я хочу C++,html,css,javascript...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
9
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.